Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Uso o MK 3.30 aqui na empresa e montei um servidor utilizando o sistema ultracache para servir de cache full.
    As configurações dos meus ips são:
    MK :
    eth1(internet): 10.0.4.x
    eth2 (MK 3.30) : 180.0.4.3
    eth3 (proxy - ultracache): 192.168.3.3
    Proxy : 192.168.3.2
    Clientes : 180.0.4.0/22

    A rede esta funcionando blz. Os clientes navegam e controlo a banda deles pelo Qos.

    Para comunicar com o Proxy usei a seguinte linha de comando :

    /ip firewall nat
    add action=masquerade chain=srcnat comment="Proxy - UltraCache" disabled=no src-address=192.168.3.2



    Pingo o proxy e acesso ele normalmente via navegador de qualquer maquina.

    Minha Duvida:

    Usei a linha de comando :

    /ip firewall nat
    add action=masquerade chain=srcnat comment=""Proxy - Ultracache" disabled=no src-address=180.0.4.0/22 dst-address=!192.168.3.2

    Esta faltando alguma coisa poís não consigo fazer o cache e nem trafego na placa do proxy tem?

    Obrigado




  2. Caro colega, não conheço o ultracache, mas acredito que essa regra que você postou é só o mascaramento para a rede do proxy, tá faltando você fazer o redirecionamento do tráfego para o proxy, tipo uma regra assim

    /ip firewall nat add chain=dst-nat protocol=tcp dst-port=80 action=dst-nat to-addresses=ip do proxy to-ports=3128 (porta do proxy)

    acho q só falta isso, respondi de cabeça não sei se está totalmente correto a sintaxe da regra.. Veja no manual do proxy..

    veja as regras no site do ultracache.. se puder cara postar a iso em algum lugar pra gente poder dar uma olhada melhor..
    http://www.webtecno.com.br/ultracache/downloads/



  3. Opa, obrigado por responder. No site as regras que estão hospedadas lá são para MK 5.8 e estão assim:

    http://www.ultracache.net.br/modos/

    /ip firewall nat
    add action=masquerade chain=srcnat comment="Proxy - UltraCache" disabled=no
    src-address=192.168.3.2

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="Proxy - UltraCache" disabled=no
    dst-address=!192.168.3.2 dst-port=80 protocol=tcp
    src-address=192.168.1.0/24 to-addresses=192.168.3.2 to-ports=3128

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=UltraCache disabled=no dscp=12 new-connection-mark=proxy-hits
    passthrough=yes
    add action=mark-packet chain=prerouting connection-mark=proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=no

    Só que qndo uso essas regras a internet dos clientes param de funcionar. Tem algumas linhas de codigo que a sintaxe do MK3.30 é diferente. Eu tambem acho que esta faltando o redirecionamento, dormi essa noite pensando nisso. =)

  4. Configure seu navegador para acessar através do proxy e poste o resultado.



  5. Engraçado fiz as configurações denovo usando a linha de comando :

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="Proxy - UltraCache" disabled=no
    dst-address=!192.168.3.2 dst-port=80 protocol=tcp
    src-address=180.0.4.0/24 to-addresses=192.168.3.2 to-ports=3128

    Tirei o final /24 e as paginas voltaram a abrir. Sera que vai funcionar o redirecionamento sem ele ?






Tópicos Similares

  1. Problemas com Mk 3.30 com cache full
    Por JEANCORREA no fórum Redes
    Respostas: 2
    Último Post: 16-06-2011, 07:53
  2. SERVIDOR COM MK 3.30 + CACHE FULL + PCC
    Por rafaelcm no fórum Redes
    Respostas: 0
    Último Post: 31-05-2011, 23:58
  3. Respostas: 9
    Último Post: 05-11-2010, 18:45
  4. Não consigo fazer cache full no server mk 3.30
    Por carneirinhobad no fórum Redes
    Respostas: 6
    Último Post: 07-09-2010, 09:21
  5. Respostas: 3
    Último Post: 16-06-2010, 14:54

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L