Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom dia.

    Estou fazendo uns testes com pppoe-server e me deparei com alguns problemas, e não sei se tem como solucionar.

    Estou com a seguinte situação:

    Eu autentico no Mikrotik com um Link de 1Mbps. até ai blz, (autenticação utilizo radius etc.. ele define default-queue)
    Começo a navegar, maravilha, ai vou testar a velocidade, abro um torrent, e começa a fazer download a 120kb/s , maravilhar controle perfeito.

    Ai surge o problema, se eu tentar abrir uma pagina, não abre pois o tunel já está em 100% de uso, e eu gostaria de tratar isto com queue.

    Gostaria de dar uma preferencia "dentro do tunel" do cliente para a porta 80,81, não criar uma outra queue com um limite de banda sobressalente de banda . (Fiz isto para o ping do cliente não subir quando está com link 100%) .

    Alguma sugestão ?

    Obrigado

  2. da pra fazer algo assim:

    Código :
    /ip firewall mangle
    add action=mark-connection chain=prerouting disabled=no dst-port=80 \
        in-interface=br0 new-connection-mark=conn_web passthrough=yes protocol=\
        tcp tcp-flags=syn
    add action=mark-packet chain=prerouting connection-mark=conn_web disabled=no \
        new-packet-mark=pkt_web passthrough=no
     
     
    /queue type
    add kind=pcq name=queue_web pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=2M pcq-src-address-mask=\
        32 pcq-src-address6-mask=64 pcq-total-limit=2000
     
     
     
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=web packet-mark=pkt_web parent=global-in priority=8 \
        queue=queue_web

    no primeiro comando, in-interface é a interface LAN (clientes).
    no segundo comand eh a velocidade que voce quer liberar ..

    o que isto faz:

    trafego web de 2M para CADA cliente... ou seja.. 2M de web e + a velocidade que ele contrata para as outras coisas...

    um detalhe eh, no pppoe, o in-interface nao tem como setar .. entao voce pode tirar esse in-interface !! (porque cada conexao pppoe é uma interface virtual)



  3. Alexandre, desculpa a pergunta idiota hehehe, mas qual o motivo de habilitar a a opção tcp-flags=syn ??

    Obrigado

  4. para que ele marque o inicio das conexoes.. o primeiro pacote de cada conexao é SYN ..



  5. Alexandre, surgiu uma duvida com tua regra.
    Do modelo que você fez, o usuario, começa a navegar, porta 80, ele não está fazendo download, ele vai usar o tunel dele ? ou os 2Mb da queue ?






Tópicos Similares

  1. Instal impressoras no win2000, dentro de um Dom no Samba.
    Por brother_fnh no fórum Servidores de Rede
    Respostas: 0
    Último Post: 13-08-2005, 10:18
  2. Como bloqueio com iptables um IP dentro de minha rede?
    Por Pollus no fórum Servidores de Rede
    Respostas: 12
    Último Post: 04-04-2005, 13:55
  3. estou tendo problemas de configuracao pppoe no gentoo..
    Por leeyeanhoo no fórum Servidores de Rede
    Respostas: 2
    Último Post: 08-12-2004, 14:29
  4. Acessar uma VPN dentro de outra VPN. Como ?
    Por thiagomz no fórum Servidores de Rede
    Respostas: 0
    Último Post: 31-03-2004, 08:35
  5. apache user e group dentro de virtualhost
    Por itamarjp no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-12-2003, 12:50

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L