Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Avatar de LU32xT
    Ingresso
    Jun 2011
    Localização
    Rio de Janeiro - interior
    Posts
    29

    Padrão Hotspot não redireciona para pagina de login quando for para site com https://

    O certo é sempre a primeira vez que for navegar na internet aparecer a tela de login do hotspot. Porem não aparece essa tela para nenhum site com certificado SSL(https) por exemplo: https://www.santander.com.br/
    Clique na imagem para uma versão maior

Nome:	         tela de erro.jpg
Visualizações:	759
Tamanho: 	16,0 KB
ID:      	38601
    Mas redireciona normalmente para qualquer site que não tenha esse certificado por exemplo http://google.com.br

    Clique na imagem para uma versão maior

Nome:	         sem erro.jpg
Visualizações:	529
Tamanho: 	11,6 KB
ID:      	38600

  2. #2

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    É normal.



  3. #3

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    aqui esta indo normal.

  4. #4
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    O Pior é que quando está logado no google, ele vai ficar https://google.com.br

    Muitas vezes tenho que tirar o "s" para poder logar.

    Infelismente ainda não foi implementado para as versões atuais do mikrotick, talvez em breve sairá uma versão com o https: funcionando de qualquer modo.



  5. #5
    Avatar de LU32xT
    Ingresso
    Jun 2011
    Localização
    Rio de Janeiro - interior
    Posts
    29

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Obrigado pelas respostas... É que eu pensei que eu tinha errado na configuração mas pelo visto é bug do mikrotik

  6. #6

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Se me recordo bem, na época que usava Hotspot, ele redirecionava sim.
    Acredito ser alguma configuração errada.
    Tem como voce fazer um export das suas regras do hotspot para verificarmos?



  7. #7

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Bom dia LU32xT,

    acrescenta essa regra em seu firewall, nat

    /ip firewall nat
    add action=redirect chain=hotspot disabled=no dst-port=443 hotspot=local-dst \
    protocol=tcp to-ports=64873

    testa ai e diz!

  8. #8

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Citação Postado originalmente por RFjonas Ver Post
    Bom dia LU32xT,

    acrescenta essa regra em seu firewall, nat

    /ip firewall nat
    add action=redirect chain=hotspot disabled=no dst-port=443 hotspot=local-dst \
    protocol=tcp to-ports=64873

    testa ai e diz!
    n~~ao ´´e 64874?


    Verifiquei ´´e 64873 mesmo
    Última edição por icebox; 30-10-2012 às 16:08. Razão: ok



  9. #9
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Testei aqui e não funcionou

  10. #10

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    realmente pensei que era normal aqui tambem nao direciona, vou testa essa regra ai.



  11. #11
    Avatar de LU32xT
    Ingresso
    Jun 2011
    Localização
    Rio de Janeiro - interior
    Posts
    29

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Ola! Eu testei essa regra, mas não funcionou.

    Essa é a configuração do meu hotspot

    Código :
     
    # oct/31/2012 15:01:19 by RouterOS 3.30
    # software id = IZNE-2AYR
    #
    /ip hotspot profile
    set default dns-name="" hotspot-address=0.0.0.0 html-directory="hotspot 2" http-proxy=0.0.0.0:0 login-by=http-chap name=\
        default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no
    add dns-name="" hotspot-address=192.168.0.1 html-directory=hotspot http-proxy=0.0.0.0:0 login-by=http-chap name=hsprof1 \
        rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no
    add dns-name=internet.bandalarga.net hotspot-address=10.0.0.1 html-directory=hotspot http-proxy=0.0.0.0:0 login-by=\
        http-chap name=hsprof2 rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no
    /ip hotspot
    add address-pool=local addresses-per-mac=1 disabled=no idle-timeout=5m interface="REDE LOCAL - PORT 2" keepalive-timeout=\
        none name=hotspot1 profile=hsprof2
    /ip hotspot user profile
    set default idle-timeout=none keepalive-timeout=2m name=default shared-users=1 status-autorefresh=1m transparent-proxy=no
    add advertise=yes advertise-interval=30m advertise-timeout=immediately advertise-url=/atraso.htm idle-timeout=10m \
        keepalive-timeout=10m name=ATRASADOS open-status-page=always rate-limit=64K/424K shared-users=1 status-autorefresh=5m \
        transparent-proxy=yes
    /ip hotspot ip-binding
    add address=10.0.0.14 comment="" disabled=no mac-address=18:E7:F4:77:74:51 type=bypassed
    /ip hotspot service-port
    set ftp disabled=no ports=21

  12. #12

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Citação Postado originalmente por RFjonas Ver Post
    Bom dia LU32xT,

    acrescenta essa regra em seu firewall, nat

    /ip firewall nat
    add action=redirect chain=hotspot disabled=no dst-port=443 hotspot=local-dst \
    protocol=tcp to-ports=64873

    testa ai e diz!
    testei não funciona, alguém conseguiu ai??



  13. #13

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Citação Postado originalmente por kfdigital Ver Post
    testei não funciona, alguém conseguiu ai??
    eu consegui, só adicionei a régua no terminal e já ta redirecionando,

  14. #14

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Citação Postado originalmente por germanian Ver Post
    eu consegui, só adicionei a régua no terminal e já ta redirecionando,
    voce colocou essa regra aqui, /ip firewall nat
    add action=redirect chain=hotspot disabled=no dst-port=443 hotspot=local-dst \
    protocol=tcp to-ports=64873 , deu certo??



  15. #15

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Citação Postado originalmente por kfdigital Ver Post
    voce colocou essa regra aqui, /ip firewall nat
    add action=redirect chain=hotspot disabled=no dst-port=443 hotspot=local-dst \
    protocol=tcp to-ports=64873 , deu certo??
    isso, essa mesmo.

  16. #16

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Citação Postado originalmente por germanian Ver Post
    isso, essa mesmo.
    aqui ja coloquei já tirei coloquei em primeiro plano, e nao adianta, qual versao do seu sistema? e servidor pc ou rb? qual sua mascara de rede? /24?



  17. #17

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Citação Postado originalmente por kfdigital Ver Post
    aqui ja coloquei já tirei coloquei em primeiro plano, e nao adianta, qual versao do seu sistema? e servidor pc ou rb? qual sua mascara de rede? /24?
    to com uma RB450G v5.0. mascara 24, acabei de desativar a régua pois parece que algums clientes só conseguem acessar o google, sei la porque, vou ver agora detarde isso.

  18. #18

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Alguém conseguiu resolver esse problema do Https??



  19. #19
    Avatar de LU32xT
    Ingresso
    Jun 2011
    Localização
    Rio de Janeiro - interior
    Posts
    29

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    Ainda não! Eu fiz um teste em hotspot da OI VELOX e Coca-Cola Wi-Fi(grátis) e em outras grandes empresas. Nenhuma conseguiu capturar os pacotes https para redirecionar para o hotspot, o que eu acho que daria certo é um redirecionamento por DNS!

  20. #20

    Padrão Re: Hotspot não redireciona para pagina de login quando for para site com https://

    BOM DIA GALERA !!!! atraves daqui do post de vez
    consegui verifica pq alguns conseguem usa regra e outros não

    ;;; direcionamento hotspot
    /ip firewall nat
    chain=hotspot action=redirect to-ports=64875 protocol=tcp hotspot=local-dst dst-port=443

    a minha porta hotspot "64875" a de alguns pode ser 64873, 64874, 64876 isso vai depender do seu servidor para vcs
    conseguir ver isso utilizem o winbox e na parte grafica vao no ip firewall e veja que tem varias regras de direcionamento
    e uma delas é 443 ai vcs abrem e na aba action vcs vão ver qual é sua port ai utiliza a regra a cima trocando 64875 atualmente pela porta de vcs ai não tem erro vai funfar