+ Responder ao Tópico



  1. #1
    Suporte em Redes Avatar de wdnc5
    Ingresso
    Nov 2011
    Localização
    LUZIANIA GO
    Posts
    546

    Padrão Ajuda algoritimo

    Olá amigo,

    alguem poderia me fazer um super favor abaixo segue 3 exercicio que meu professor me passou e eu ainda não conseguir fazer sera que alguem de vocês poderia me ajudar?

    ele pediu para fazer o algorítimo e incrementar em php.


    Algoritmos c/ Repetição:

    01- Escrever um algoritmo que leia um número não determinado de valores e calcule a
    média aritmética dos valores lidos, a quantidade de valores positivos, a quantidade de
    valores negativos e o percentual de valores negativos e positivos. Mostre os resultados.

    02-Escrever um algoritmo que leia uma quantidade desconhecida de números e conte
    quantos deles estão nos seguintes intervalos: [0.25], [26,50], [51,75] e [76,100]. A
    entrada de dados deve terminar quando for lido um número negativo.

    Algoritmos Seqüênciais e Condicionais:

    01-
    O cardápio de uma lancheria é o seguinte: Especificação Preço unitário
    100 Cachorro quente 1.100
    101 Bauru simples 1.300
    102 Bauru c/ovo 1.500
    103 Hamburger 1.100
    104 Cheeseburger 1.300
    105 Refrigerante 1.000
    Escrever um algoritmo que leia o código do item pedido, a quantidade e calcule
    o valor a ser pago por aquele lanche. Considere que a cada execução somente
    será calculado um item.

    Amigos sei que é trabalhoso mais por favor me ajudem ai tenho que entregar urgente:
    ele me pediu pra fazer o algoritmo e o php e eu não entendo de nenhum dos dois ainda rsrrs

    vou mostrar abaixo um exemplo de como estamos trabalhando com algorítimo:

    01- faça um algorítimo que leia a nota de 3 alunos, e ao final apresente a media aritmética da turma:

    solução:

    Principal ( )
    { inteiro nota1,nota2,nota3,soma,real media;
    leia (nota 1);
    leia (nota 2);
    leia (nota 3);
    media=(nota1+nota2+nota3)/3;
    escreva (media);
    }

    abraços...

  2. #2
    Suporte em Redes Avatar de wdnc5
    Ingresso
    Nov 2011
    Localização
    LUZIANIA GO
    Posts
    546

    Padrão Re: Ajuda algoritimo

    Citação Postado originalmente por Marcionetfast Ver Post
    Fiz este para um cara tem +- uns 4 anos .
    Tenho muitos guardados em meu word.
    Estou meio enferrujado mas vamos lá :



    Exercício 1




    Inicio
    inteiro contador=0,i=0;
    inteiro soma=0; //soma de valores
    inteiro num; //valor
    real media; //media aritmetica
    inteiro contador_negativos=0; //contador de numeros negativos
    inteiro contador_positivos=0; //contador de numeros positivos
    real percent_negativos; //percentual de numeros negativos
    real percent_positivos; //percentual de numeros positivos

    imprima("quantidade de valores");
    leia(cont);
    Enquanto (i<=cont) faça
    inicio
    imprima("insira valor");
    leia(num);
    soma=soma+num;
    se (num>0) então
    inicio
    contador_positivos=contador_positiv…
    fim
    senão se (num<0) então
    inicio
    contador_negativos=contador_negativ…
    fim
    fim

    media = (soma/cont);
    percent_negativos = (contador_negativos/soma)*100;
    percent_positivos = (contador_positivos/soma)*100;

    Imprima("Media aritmetica: ", media);
    Imprima("Quantidade de numeros positivos: ", contador_positivos);
    Imprima("Quantidade de numeros negativos: ", contador_negativos);
    Imprima("Percentual de numeros positivos: ", percent_positivos);
    Imprima("Percentual de numeros negativos: ", percent_negativos);
    fim


    Exercício 2

    algoritmo "semnome"
    // Função :
    // Autor :
    // Data : 10/6/2010
    // Seção de Declarações
    var
    quant_repetir,cont,numero,exibir:inteiro
    inicio
    // Seção de Comandos
    escreval("Informe a quantidade a ser repetida: ")
    leia(quant_repetir)
    para cont de 1 ate quant_repetir passo 1 faca
    escreval("Informe o numero desejado de 1 até 100: ")
    escreval("Se escolher um numero negativo irá sair do programa")
    leia(numero)
    se(numero >= 0)e(numero <= 25) entao
    exibir <- numero
    escreval("Ele está entre 0 e 25 o numero é ",exibir)
    senao
    se(numero > 25)e(numero <= 50)entao
    exibir <- numero
    escreval("Ele está entre 25 e 50 o numero é ",exibir)
    senao
    se(numero > 50)e(numero <= 75)entao
    exibir <- numero
    escreval("Ele está entre 50 e 75 o numero é ",exibir)
    senao
    se(numero > 75)e(numero <= 100)entao
    exibir <- numero
    escreval("Ele está entre 75 e 100 o numero é ",exibir)
    senao
    se(numero < 0)entao
    fimalgoritmo
    fimse
    fimse
    fimse
    fimse
    fimse
    fimpara
    fimalgoritmo

    Exercício 3
    Este aqui vc dá uma estudada, tem que pensar um pouquinho não é brother , troca pelo menos os valores, pois fiz também tem um tempo, dê uma incrementada , seja criativo.

    programa ola;
    variaveis
    a,b,c,d,e,f,g : real;
    h,i,j,l,m,n,o,p,q,r : texto;
    inicio
    escreva("Loja Maioneta");
    escreva("Digite o codigo do produto");
    leia(a);
    escreva("Escreva a quantidade");
    leia(b);
    if (a=100) entao
    inicio
    h:="cachorro-quente");
    c:=b*3,50;
    fimif
    if (a=101) entao
    inicio
    h:="bauru simples");
    c:=b*4,00;
    fimif
    if (a=102) entao
    inicio
    h:="bauru com ovo");
    c:=b*4,50;
    fimif
    if (a=103) entao
    inicio
    h:="hamburger");
    c:=b*4,00;
    fimif
    if (a=104) entao
    inicio
    h:="cheesburger");
    c:=b*3,00;
    fimif
    escreva("Você pediu ",b,h,"por R$",c);
    fim.


    Aproveite o que te passei e estude brother, entenda uma coisa , algorítimo é feito para que entendam o processo do sistema, se seu professor exige um padrão ele está errado, pois a intenção do algorítimo é fazer entender.
    Quando comecei a programar era portugol simples, faça isto, faça aquilo etc etc
    Vlw !
    Cara muito obrigado! fico muito grato pela ajuda, com certeza irei estudar muito, mais muito mesmo.

    essa vale 10 estrelinhas como não tem como vai só uma mesmo kkkk



  3. #3
    Suporte em Redes Avatar de wdnc5
    Ingresso
    Nov 2011
    Localização
    LUZIANIA GO
    Posts
    546

    Padrão Re: Ajuda algoritimo

    Citação Postado originalmente por Marcionetfast Ver Post
    Fiz este para um cara tem +- uns 4 anos .
    Tenho muitos guardados em meu word.
    Estou meio enferrujado mas vamos lá :



    Exercício 1




    Inicio
    inteiro contador=0,i=0;
    inteiro soma=0; //soma de valores
    inteiro num; //valor
    real media; //media aritmetica
    inteiro contador_negativos=0; //contador de numeros negativos
    inteiro contador_positivos=0; //contador de numeros positivos
    real percent_negativos; //percentual de numeros negativos
    real percent_positivos; //percentual de numeros positivos

    imprima("quantidade de valores");
    leia(cont);
    Enquanto (i<=cont) faça
    inicio
    imprima("insira valor");
    leia(num);
    soma=soma+num;
    se (num>0) então
    inicio
    contador_positivos=contador_positiv…
    fim
    senão se (num<0) então
    inicio
    contador_negativos=contador_negativ…
    fim
    fim

    media = (soma/cont);
    percent_negativos = (contador_negativos/soma)*100;
    percent_positivos = (contador_positivos/soma)*100;

    Imprima("Media aritmetica: ", media);
    Imprima("Quantidade de numeros positivos: ", contador_positivos);
    Imprima("Quantidade de numeros negativos: ", contador_negativos);
    Imprima("Percentual de numeros positivos: ", percent_positivos);
    Imprima("Percentual de numeros negativos: ", percent_negativos);
    fim


    Exercício 2

    algoritmo "semnome"
    // Função :
    // Autor :
    // Data : 10/6/2010
    // Seção de Declarações
    var
    quant_repetir,cont,numero,exibir:inteiro
    inicio
    // Seção de Comandos
    escreval("Informe a quantidade a ser repetida: ")
    leia(quant_repetir)
    para cont de 1 ate quant_repetir passo 1 faca
    escreval("Informe o numero desejado de 1 até 100: ")
    escreval("Se escolher um numero negativo irá sair do programa")
    leia(numero)
    se(numero >= 0)e(numero <= 25) entao
    exibir <- numero
    escreval("Ele está entre 0 e 25 o numero é ",exibir)
    senao
    se(numero > 25)e(numero <= 50)entao
    exibir <- numero
    escreval("Ele está entre 25 e 50 o numero é ",exibir)
    senao
    se(numero > 50)e(numero <= 75)entao
    exibir <- numero
    escreval("Ele está entre 50 e 75 o numero é ",exibir)
    senao
    se(numero > 75)e(numero <= 100)entao
    exibir <- numero
    escreval("Ele está entre 75 e 100 o numero é ",exibir)
    senao
    se(numero < 0)entao
    fimalgoritmo
    fimse
    fimse
    fimse
    fimse
    fimse
    fimpara
    fimalgoritmo

    Exercício 3
    Este aqui vc dá uma estudada, tem que pensar um pouquinho não é brother , troca pelo menos os valores, pois fiz também tem um tempo, dê uma incrementada , seja criativo.

    programa ola;
    variaveis
    a,b,c,d,e,f,g : real;
    h,i,j,l,m,n,o,p,q,r : texto;
    inicio
    escreva("Loja Maioneta");
    escreva("Digite o codigo do produto");
    leia(a);
    escreva("Escreva a quantidade");
    leia(b);
    if (a=100) entao
    inicio
    h:="cachorro-quente");
    c:=b*3,50;
    fimif
    if (a=101) entao
    inicio
    h:="bauru simples");
    c:=b*4,00;
    fimif
    if (a=102) entao
    inicio
    h:="bauru com ovo");
    c:=b*4,50;
    fimif
    if (a=103) entao
    inicio
    h:="hamburger");
    c:=b*4,00;
    fimif
    if (a=104) entao
    inicio
    h:="cheesburger");
    c:=b*3,00;
    fimif
    escreva("Você pediu ",b,h,"por R$",c);
    fim.


    Aproveite o que te passei e estude brother, entenda uma coisa , algorítimo é feito para que entendam o processo do sistema, se seu professor exige um padrão ele está errado, pois a intenção do algorítimo é fazer entender.
    Quando comecei a programar era portugol simples, faça isto, faça aquilo etc etc
    Vlw !
    Alguém ai poderia me ajudar com a parte do PHP?