+ Responder ao Tópico



  1. Bom Dia,

    estou com um problema que quando cai o meu adsl o pppoe não reconectar tenho q entra na Rb e Desabilitar e habilitar o pppoe client.

    Gostaria de fazem um script que testa o link com ping e se não pingar mais ele faça isso pra min Desabilitar e habilitar o pppoe.

    Como eu posso fazer isso ? ow tem algum outra forma melhor ?


    Obrigado,

  2. Opa amigao vc pode fazer isso com uma ferramenta do RouterOS que se chama [1]NETWATCH ... ele fica pingando em um host(ip),com determinada latência e com intervalo de tempo que você coloca e quando nao pingar ele rodará o script e quando voltar a pingar vc coloca ou nao um outro script...ele é muito usado em fail over de internet, para testar sites e rotas determinadas para redundancias rodar automaticamente.

    [1]http://wiki.mikrotik.com/wiki/Manual:Tools/Netwatch



  3. So possui 1 link ou mais neste Router?

  4. 1 link só



  5. Nunca tivemos esse problema nos provedores. Porem vou lhe ajudar com o pedido:

    Coloca o nome da sua conexão PPPoE-Client = PPPOE1, e comentario PPPOE1


    Segue Script Completo, qualquer duvida só postar.

    target-

    /ip route

    add comment="TESTE PPPOE1" disabled=no distance=50 dst-address=\
    200.192.112.8/32 gateway=PPPOE1 scope=30 target-scope=10

    /tool netwatch

    add comment=PPPOE1 disabled=no down-script="interface pppoe-client disable PPP\
    OE1\r\
    \n\r\
    \ninterface pppoe-client enable PPPOE1" host=200.192.112.8 interval=1m \
    timeout=10s up-script=""

    /interface pppoe-client
    add ac-name="" add-default-route=yes allow=pap,chap,mschap1,mschap2 comment=\
    PPPOE1 dial-on-demand=no disabled=no interface=4-INTELIG max-mru=1480 \
    max-mtu=1480 mrru=disabled name=PPPOE1 password=seu_senha profile=default \
    service-name="" use-peer-dns=yes user=seu_usuario






Tópicos Similares

  1. Script ping DNS e Proxy e muda caso esteja off!
    Por 2fast4youbr no fórum Redes
    Respostas: 1
    Último Post: 16-05-2013, 18:46
  2. Script para pegar resposta de ping e executar função.
    Por easyBSD no fórum Linguagens de Programação
    Respostas: 3
    Último Post: 24-07-2007, 10:32
  3. Script para desativar e abilitar PPPOE
    Por rfm no fórum Redes
    Respostas: 0
    Último Post: 09-07-2007, 08:02
  4. Ping Alto pelo PPPoE
    Por alamdias no fórum Redes
    Respostas: 9
    Último Post: 11-12-2006, 21:06
  5. Respostas: 8
    Último Post: 16-11-2005, 00:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L