+ Responder ao Tópico



  1. ALGUÉM PODEIRA PASSAR ESTES ALGORITIMO PARA LINGUAGEM C?

    fico grato se os amigos poder me dar esta força, antes que me faça critica porque não postei nada de inicio gostaria de informa que não conheço nada de C meu professor apenas passou o desafio para ver quem ia conseguir levar vale 2 pontos .

    Código :
    [COLOR=#2A2A2A][FONT=Segoe UI]segue da lanchonete:[/FONT][/COLOR][COLOR=#2A2A2A][FONT=Segoe UI]algoritmo "Algoritimo lanchonete"
    // Função :calcular pedido caixa
    // Autor : 
    // Data : 24/09/2012
    // Seção de Declarações 
    var
       codigo, quantidade, valor: real
    inicio
    //seção de comandos
       escreva ("informe o codigo do produto:")
       leia (codigo)
       se (codigo = 100) entao
       escreva ("informe a quantidade:")
       leia (quantidade)
       valor <- (1.100 * quantidade)
       escreva ("Pedido:", quantidade , "-cachorro quente total:R$",valor)
       fimse
        se (codigo = 101) entao
        escreva ("informe a quantidade:")
        leia (quantidade)
        valor <- (1.300 * quantidade)
        escreva ("Pedido:",quantidade, "-bauru simples total:R$", valor)
        fimse
          se (codigo = 102) entao
          escreva ("informe a quantidade:")
          leia (quantidade)
          valor <- (1.500 * quantidade)
          escreva ("Pedido:",quantidade,"bauru com ovo total:R$", valor)
          fimse
            se (codigo = 103) entao
            escreva ("informe a quantidade:")
            leia (quantidade)
            valor <- (1.200 * quantidade)
            escreva ("Pedido:",quantidade,"hamburguer total:R$", valor)
            fimse
               se (codigo = 104) entao
               escreva ("informe a quantidade:")
               leia (quantidade)
               valor <- (1.300 * quantidade)
               escreva ("Pedido:",quantidade,"cheeseburguer total: R$", valor)
               fimse
                  se (codigo = 105) entao
                  escreva ("informe a quantidade:")
                  leia (quantidade)
                  valor <- (1.000 * quantidade)
                  escreva ("Pedido:",quantidade,"refrigerante total:R$", valor)
                  fimse
    [/FONT][/COLOR]
    [COLOR=#2A2A2A][FONT=Segoe UI]fimalgoritmo[/FONT][/COLOR]

    2:

    algoritmo "Media de notas"// Função : Aritimetica
    // Autor : Aricélio, Joel, Wanderson
    // Data : 23/09/2012
    // Seção de Declarações: Real
    var
    nota1, nota2, nota3, media: real
    inicio
    // Entrada de Dados
    escreval ("digite sua nota")
    leia (nota1)


    escreval ("digite sua nota")
    leia (nota2)


    escreval ("digite sua nota")
    leia (nota3)
    // Seção de Comandos
    media<-(nota1+nota2+nota3)/3


    escreval ("Sua media é")


    escreval (media:2:2)


    // Seção Condicional


    se media>= 6 entao
    escreval ("Parabens você está Aprovado!!!!")

    senao
    escreval ("Estude mais você foi Reprovado.")
    fimse


    fimalgoritmo
    3.

    algoritmo "semnome"
    // Função :
    // Autor :
    // Data : 10/6/2010
    // Seção de Declarações
    var
    quant_repetir,cont,numero,exibir:inteiro
    inicio
    // Seção de Comandos
    escreval("Informe a quantidade a ser repetida: ")
    leia(quant_repetir)
    para cont de 1 ate quant_repetir passo 1 faca
    escreval("Informe o numero desejado de 1 até 100: ")
    escreval("Se escolher um numero negativo irá sair do programa")
    leia(numero)
    se(numero >= 0)e(numero <= 25) entao
    exibir <- numero
    escreval("Ele está entre 0 e 25 o numero é ",exibir)
    senao
    se(numero > 25)e(numero <= 50)entao
    exibir <- numero
    escreval("Ele está entre 25 e 50 o numero é ",exibir)
    senao
    se(numero > 50)e(numero <= 75)entao
    exibir <- numero
    escreval("Ele está entre 50 e 75 o numero é ",exibir)
    senao
    se(numero > 75)e(numero <= 100)entao
    exibir <- numero
    escreval("Ele está entre 75 e 100 o numero é ",exibir)
    senao
    se(numero < 0)entao
    fimalgoritmo
    fimse
    fimse
    fimse
    fimse
    fimse
    fimpara
    fimalgoritmo

  2. Citação Postado originalmente por Marcionetfast Ver Post
    1-
    #include<stdio.h>
    #include<conio.h>
    main()

    {
    int qtd, cod;
    float vt;
    printf("\nLanchonete P@to Donalds\n\n");
    printf("Lista de Lanches\n\n Lanche COD Preco\n\n Cachorro Quente 100 1,20\n Bauru Simples 101 1,30\n Bauru Com Ovo 102 1,50\n");
    printf(" Hamburger 103 1,20\n Cheeseburger 104 1,30\n Refrigerante 105 1,00\n");
    printf("\nDigite a Codigo do lanche\n\n");
    scanf("%d",&cod);
    printf("\nQuantos ?\n");
    scanf("%d",&qtd);
    switch (cod)
    {
    case 100:
    vt=qtd*1.20;
    printf ("\n\nCachorro Quente * %d = %3.2f", qtd, vt);
    break;
    case 101:
    vt=qtd*1.30;
    printf ("\n\nBauru Simples * %d = %3.2f", qtd, vt);
    break;
    case 102:
    vt=qtd*1.50;
    printf ("\n\nBauru com Ovo * %d = %3.2f", qtd, vt);
    break;
    case 103:
    vt=qtd*1.20;
    printf ("\n\nHamburger * %d = %3.2f", qtd, vt);
    break;
    case 104:
    vt=qtd*1.30;
    printf ("\n\nChesseburger * %d = %3.2f", qtd, vt);
    break;
    case 105:
    vt=qtd*1.00;
    printf ("\n\nRefrigerante * %d = %3.2f", qtd, vt);
    break;
    default:
    printf ("\n\nEste iten Nao consta no menu.\n");
    }
    getch();
    }



    Só confere os nomes pois como te disse tenho estes exercícios guardados a tempos ! vou ver se tenho os outros !

    Cara você é nota 1000, fico muito grato pela ajuda!






Tópicos Similares

  1. Em que linguagem você programa?
    Por hez4el no fórum Linguagens de Programação
    Respostas: 24
    Último Post: 01-07-2004, 09:27
  2. Linux + Linguagem C
    Por NeoRamza no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-03-2004, 00:51
  3. Linguagem de Programação no linux
    Por ricardodru no fórum Servidores de Rede
    Respostas: 8
    Último Post: 23-11-2003, 18:07
  4. Linguagem C
    Por tato no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-05-2003, 09:33
  5. Linguagem SQL
    Por sensui no fórum Servidores de Rede
    Respostas: 3
    Último Post: 22-01-2003, 18:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L