Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Ola pessoal.
    Estou com um problema aqui com o script ChangeIp no Mikrotik, ele não atualiza o ip.
    Já tentei vários script, inclusive um para No-ip que também não atualizava.
    Vi outros tópicos sobre esse assunto mais as soluções apresentadas não resolveram meu problema, ou talvez estou deixando passar algo.
    Peço ajuda pois não sei mais oque fazer.

    Clique na imagem para uma versão maior

Nome:	         change.jpg
Visualizações:	95
Tamanho: 	83,3 KB
ID:      	39357

    O script :

    :log info "DDNS: Begin"
    :global ddns-user "xxxxxxxxxxxx"
    :global ddns-pass "xxxxxxxxx"
    :global ddns-host "xxxxxxxxxxxx.xxx.xx"
    :global ddns-interface "PPPoE1"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

    ( só lembrando no ligar da carinha na verdade é : e a letra p )

  2. Qual e sua veção desse seu mikrotik amigo ... Me add ae eu posso te ajuda allybmx1@hotmail.com



  3. Bom dia. Estou usando a versão 5.20 em uma rb750.

  4. Citação Postado originalmente por Jacksonjm Ver Post
    Bom dia. Estou usando a versão 5.20 em uma rb750.

    entao a regra nao e essa amigo me add no msn q te ajundo caralho



  5. Ja mandei o convite.






Tópicos Similares

  1. Script ChangeIP não Executa
    Por TATATHUNDERNET no fórum Redes
    Respostas: 4
    Último Post: 30-12-2011, 02:04
  2. Script ChangeIp.com nao atualiza
    Por kurole no fórum Redes
    Respostas: 12
    Último Post: 26-08-2011, 21:41
  3. Respostas: 0
    Último Post: 31-07-2003, 13:22
  4. Sophos não atualiza!
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 15-05-2003, 16:12
  5. script que nao inicia no boot
    Por demiurgo no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-03-2003, 17:02

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L