Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá estou com um pequeno problema em um loab balance, alguem com experiencia poderia dar uma analisada nesta regras abaixo e me informa se tem algum erro?

    as regras foi geradas automaticamente pelo PCC 1.1

    ele não esta rodando os 2 link simultâneos,

    CENÁRIO:
    1MODEM EM BRIDGE E 1 ROTEADO
    o scprit esta configurada pra 3 link mais esta em uso somente 2

    não coloquei os 2 em bridge devido ter dado o mesmo erro devido os gw ser iguais.

    Código :
    # ip address --------------------------/ip address add address=192.168.4.1/24  interface=LOCAL
    /ip address add address=10.1.1.2/24  interface=LINK02
     
     
    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=LINK01 max-mru=1480 max-mtu=1480 mrru=disabled name=LINK01adsl password=1234000 profile=default service-name="" use-peer-dns=no user=1234000@oi.com.br
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=LINK03 max-mru=1480 max-mtu=1480 mrru=disabled name=LINK03adsl password=user1 profile=default service-name="" use-peer-dns=no user=user1
     
     
    # ip dns --------------------------------
    /ip dns set primary-dns=8.8.8.8
    /ip dns set secondary-dns=8.8.4.4
    /ip dns set allow-remote-requests=yes
     
     
    # ip dns statico------------------------
    /ip dns static add address=192.168.4.1 comment="" disabled=no name=192.168.4.1.provedor.com.br ttl=1d
     
     
    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=provedor.com.br disabled=no
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!LINK02 src-address=192.168.4.1/24
     
     
    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK02
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK01adsl
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK03adsl
     
     
    # ip firewall mangle------------------------
    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=LOCAL
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=LOCAL
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=LINK02 new-connection-mark=LINK02_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=LINK01adsl new-connection-mark=LINK01adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=LINK03adsl new-connection-mark=LINK03adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK02_conn disabled=no new-routing-mark=to_LINK02 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK01adsl_conn disabled=no new-routing-mark=to_LINK01adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK03adsl_conn disabled=no new-routing-mark=to_LINK03adsl passthrough=yes
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=10.1.1.0/24 in-interface=LOCAL
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=LINK02_conn passthrough=yes per-connection-classifier=both-addresses:3/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=LINK01adsl_conn passthrough=yes per-connection-classifier=both-addresses:3/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=LINK03adsl_conn passthrough=yes per-connection-classifier=both-addresses:3/2
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK02_conn disabled=no in-interface=LOCAL new-routing-mark=to_LINK02 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK01adsl_conn disabled=no in-interface=LOCAL new-routing-mark=to_LINK01adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK03adsl_conn disabled=no in-interface=LOCAL new-routing-mark=to_LINK03adsl passthrough=yes
     
     
    # ip route----------------------------------
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=to_LINK02 comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK01adsl routing-mark=to_LINK01adsl comment="Link1"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK03adsl routing-mark=to_LINK03adsl comment="Link2"
    /ip route add check-gateway=ping comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=LINK01adsl scope=30 target-scope=10
    /ip route add comment="Link2" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=LINK03adsl scope=30 target-scope=10
     
     
    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback
     
     
    # /system script--------------------------------------
    /system script add name=Link0Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link0\"] disabled=yes;" 
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;" 
    /system script add name=Link2Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link2\"] disabled=yes;" 
    /system script add name=Link0Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=no;\r\ \n/ip route set [find comment=\"Link0\"] disabled=no;" 
    /system script add name=Link1Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\ \n/ip route set [find comment=\"Link1\"] disabled=no;" 
    /system script add name=Link2Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link2\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link2\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link2\"] disabled=no;\r\ \n/ip route set [find comment=\"Link2\"] disabled=no;"

  2. Citação Postado originalmente por wdnc5 Ver Post
    Olá estou com um pequeno problema em um loab balance, alguem com experiencia poderia dar uma analisada nesta regras abaixo e me informa se tem algum erro?

    as regras foi geradas automaticamente pelo PCC 1.1

    ele não esta rodando os 2 link simultâneos,

    CENÁRIO:
    1MODEM EM BRIDGE E 1 ROTEADO
    o scprit esta configurada pra 3 link mais esta em uso somente 2

    não coloquei os 2 em bridge devido ter dado o mesmo erro devido os gw ser iguais.

    Código :
    # ip address --------------------------/ip address add address=192.168.4.1/24  interface=LOCAL
    /ip address add address=10.1.1.2/24  interface=LINK02
     
     
    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=LINK01 max-mru=1480 max-mtu=1480 mrru=disabled name=LINK01adsl password=1234000 profile=default service-name="" use-peer-dns=no user=1234000@oi.com.br
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=LINK03 max-mru=1480 max-mtu=1480 mrru=disabled name=LINK03adsl password=user1 profile=default service-name="" use-peer-dns=no user=user1
     
     
    # ip dns --------------------------------
    /ip dns set primary-dns=8.8.8.8
    /ip dns set secondary-dns=8.8.4.4
    /ip dns set allow-remote-requests=yes
     
     
    # ip dns statico------------------------
    /ip dns static add address=192.168.4.1 comment="" disabled=no name=192.168.4.1.provedor.com.br ttl=1d
     
     
    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=provedor.com.br disabled=no
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!LINK02 src-address=192.168.4.1/24
     
     
    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK02
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK01adsl
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK03adsl
     
     
    # ip firewall mangle------------------------
    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=LOCAL
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=LOCAL
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=LINK02 new-connection-mark=LINK02_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=LINK01adsl new-connection-mark=LINK01adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=LINK03adsl new-connection-mark=LINK03adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK02_conn disabled=no new-routing-mark=to_LINK02 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK01adsl_conn disabled=no new-routing-mark=to_LINK01adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK03adsl_conn disabled=no new-routing-mark=to_LINK03adsl passthrough=yes
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=10.1.1.0/24 in-interface=LOCAL
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=LINK02_conn passthrough=yes per-connection-classifier=both-addresses:3/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=LINK01adsl_conn passthrough=yes per-connection-classifier=both-addresses:3/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=LINK03adsl_conn passthrough=yes per-connection-classifier=both-addresses:3/2
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK02_conn disabled=no in-interface=LOCAL new-routing-mark=to_LINK02 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK01adsl_conn disabled=no in-interface=LOCAL new-routing-mark=to_LINK01adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK03adsl_conn disabled=no in-interface=LOCAL new-routing-mark=to_LINK03adsl passthrough=yes
     
     
    # ip route----------------------------------
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=to_LINK02 comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK01adsl routing-mark=to_LINK01adsl comment="Link1"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK03adsl routing-mark=to_LINK03adsl comment="Link2"
    /ip route add check-gateway=ping comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=LINK01adsl scope=30 target-scope=10
    /ip route add comment="Link2" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=LINK03adsl scope=30 target-scope=10
     
     
    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback
     
     
    # /system script--------------------------------------
    /system script add name=Link0Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link0\"] disabled=yes;" 
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;" 
    /system script add name=Link2Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link2\"] disabled=yes;" 
    /system script add name=Link0Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=no;\r\ \n/ip route set [find comment=\"Link0\"] disabled=no;" 
    /system script add name=Link1Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\ \n/ip route set [find comment=\"Link1\"] disabled=no;" 
    /system script add name=Link2Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link2\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link2\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link2\"] disabled=no;\r\ \n/ip route set [find comment=\"Link2\"] disabled=no;"

    Eu não vi nenhum erro, mas prefiro usar os modens em bridge, nao tem problema se e o mesmo gatway, pq a rota busca pela interface pppoe, pode fazer tudo pppoe que vai rolar sem problema, vc usou a versao 1.1, vou deixa uma versao mais nova 1.5 vou deixar o link ai abaixo.

    ftp://189.76.232.10/programas/isaque/PCC/



  3. Citação Postado originalmente por isacloko Ver Post
    Eu não vi nenhum erro, mas prefiro usar os modens em bridge, nao tem problema se e o mesmo gatway, pq a rota busca pela interface pppoe, pode fazer tudo pppoe que vai rolar sem problema, vc usou a versao 1.1, vou deixa uma versao mais nova 1.5 vou deixar o link ai abaixo.

    ftp://189.76.232.10/programas/isaque/PCC/
    Olá,

    amigo obrigado pela atenção, já testei uns 3 tipos de load balance em bridge gerado por todas as versões do PCC e mesmo assim não funcionou, sempre rodava somente um link. estou tendo problemas somente com este ai deste cliente, já fiz varios load balance com o PCC e roda ate hoje sem problema o único que ta dando problema é este ate agora não descobri o porque vou fazer o ultimo teste que é colocar os 2 modens em modo router.

    abraços...

  4. Amigo aki eu usava Lb de dois links em bridge mt bom e sem problemas....ai a pouco mais de 2 meses tive que adquirir mais 1 link....ai agora estou usando um com 3 links em bridge...e está rodando a uns dois meses e sem problemas..se quiser te passo..um txt...e quanto aos gatway's, com modem em bridge ñ há problema.
    msn:bboy_maninho03@hotmail.com



  5. amigo segue este detonado aqui
    http://routeros.forumpramim.net/t238...hlight=balance
    não tem errada






Tópicos Similares

  1. Ajudem a Fazer um Load Balance de 5 links
    Por isacloko no fórum Redes
    Respostas: 5
    Último Post: 29-12-2008, 08:28
  2. Ajuda com Load Balance da D-link
    Por netuai no fórum Redes
    Respostas: 6
    Último Post: 19-11-2008, 23:38
  3. Load Balancing Com 02 Links Cable Modem
    Por mson77 no fórum Redes
    Respostas: 3
    Último Post: 16-03-2008, 11:48
  4. Melhor forma de Load Balance p 3 links
    Por fabianojean no fórum Redes
    Respostas: 11
    Último Post: 29-08-2007, 18:55
  5. load balance com 2 links de velocidades diferentes funciona?!
    Por Cleiton no fórum Servidores de Rede
    Respostas: 11
    Último Post: 19-04-2006, 09:30

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L