+ Responder ao Tópico



  1. #1

    Question Balancemento por Grupo + Servidor de Autenticação

    Estou usando uma rb 1100, nela tem o balance por grupo+hotspot+servidor de autenticação.

    O problema é que perdi o acesso ao servidor de autenticação, depois que implantei o balance, alguém sabe como resolver esse problema?

  2. #2

    Padrão Re: Balancemento por Grupo + Servidor de Autenticação

    vc perdeu o acesso ao Servidor Radius (externo) ou perdeu o acesso ao Mikrotik (ou seja o seu winbox não acha a sua RB)?



  3. #3

    Padrão Re: Balancemento por Grupo + Servidor de Autenticação

    Eu perdi comunicação com servidor de autenticação.

    Para mim pode acessar o servidor de autenticação, digito no navegador. o ip dela 172.31.255.2/admin - no caso é um mkauth.

    Com as regras do balance, não abre de jeito nem um.

  4. #4

    Padrão Re: Balancemento por Grupo + Servidor de Autenticação

    Citação Postado originalmente por Natan123 Ver Post
    Eu perdi comunicação com servidor de autenticação.

    Para mim pode acessar o servidor de autenticação, digito no navegador. o ip dela 172.31.255.2/admin - no caso é um mkauth.

    Com as regras do balance, não abre de jeito nem um.
    Se você conseguir "pingar" no servidor pode ser alguma regra de mascaramento, caso contrário verifique se o ip do mk-auth não foi embora por acidente no Address List.



  5. #5

    Padrão Re: Balancemento por Grupo + Servidor de Autenticação

    De dentro do servidor eu pingo normal.

    Agora, pelo o pc não ping de jeito nem um.

    E o address do mk auth esta lá, pois é so desabilitar a regra do balance eu acesso.

  6. #6

    Padrão Re: Balancemento por Grupo + Servidor de Autenticação

    Citação Postado originalmente por Natan123 Ver Post
    De dentro do servidor eu pingo normal.

    Agora, pelo o pc não ping de jeito nem um.

    E o address do mk auth esta lá, pois é so desabilitar a regra do balance eu acesso.
    Bicho passa a regra desse balance aew incluindo as classes de ips dos clientes .



  7. #7

    Padrão Re: Balancemento por Grupo + Servidor de Autenticação

    regras:




    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" disabled=no new-routing-mark=GrupA passthrough=no src-address=192.168.0.2-192.168.0.128


    add action=mark-routing chain=prerouting comment="GrupB" disabled=no new-routing-mark=GrupB passthrough=no src-address=192.168.0.129-192.168.0.254


    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=10.10.10.1 routing-mark=GrupA scope=255 target-scope=10


    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10


    galera agora vou colocar uns sripts para se for o caso de algum link cair:


    Regras:


    /system script
    add name=link1-on policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"


    add name=link1-off policy=ftp,reboot,read,write,policy,test,w inbox,password,sniff source="/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"


    add name=link2-on policy=ftp,reboot,read,write,policy,test,w inbox,password,sniff source="/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"


    add name=link2-off policy=ftp,reboot,read,write,policy,test,w inbox,password,sniff source="/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"


    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=10.10.10.1 interval=5m timeout=1s up-script=link1-on


    add comment="Rota - Grupo B" disabled=no down-script=link2-off host=20.20.20.1 interval=5m timeout=1s up-script=link2-on

  8. #8

    Padrão Re: Balancemento por Grupo + Servidor de Autenticação

    Citação Postado originalmente por Natan123 Ver Post
    regras:




    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" disabled=no new-routing-mark=GrupA passthrough=no src-address=192.168.0.2-192.168.0.128


    add action=mark-routing chain=prerouting comment="GrupB" disabled=no new-routing-mark=GrupB passthrough=no src-address=192.168.0.129-192.168.0.254


    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=10.10.10.1 routing-mark=GrupA scope=255 target-scope=10


    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10


    galera agora vou colocar uns sripts para se for o caso de algum link cair:


    Regras:


    /system script
    add name=link1-on policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"


    add name=link1-off policy=ftp,reboot,read,write,policy,test,w inbox,password,sniff source="/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"


    add name=link2-on policy=ftp,reboot,read,write,policy,test,w inbox,password,sniff source="/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"


    add name=link2-off policy=ftp,reboot,read,write,policy,test,w inbox,password,sniff source="/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"


    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=10.10.10.1 interval=5m timeout=1s up-script=link1-on


    add comment="Rota - Grupo B" disabled=no down-script=link2-off host=20.20.20.1 interval=5m timeout=1s up-script=link2-on


    Faltou a Regra de mascaramento aí brow, acho que vc mudou os ips "estão marcados em vermelho" para o que está na sua rede né, acho q se não caso contrário esse balance nem está funfando.



  9. #9

    Wink Re: Balancemento por Grupo + Servidor de Autenticação

    Pow, vlw mesmo deu certo aqui, o problema estava na regra das rotas mesmo
    As regras de mascaras ja tem no nat é que não postei aqui.

    Depois que coloquei a faixa de ip funcionou blz.

    Obrigadão amigo.

  10. #10

    Wink Re: Balancemento por Grupo + Servidor de Autenticação

    Falow qq coisa tamos aew!