+ Responder ao Tópico



  1. Estou precisando colocar o seguinte cenário para rodar:

    Link 1 = DSL 50 megas

    Link 2 = DSL 35 megas

    Coloquei os dois modens em bridge, os conectei cada um em uma ether diferente no servidor, criei os devidos discadores e desmarquei em ambos os discadores as opções add default route e Use Peer Dns.

    Em seguida criei em ip route a seguinte marcação:

    Na primeira em gateway coloquei a interface pppoe-out1, Routing Mark Link-01
    Na segunda em gateway coloquei a interface pppoe-out2

    Após isso em ambas as nat:

    Chain:srcnat
    Out interface: pppoe-out1
    Action: Masquerade

    Chain:srcnat
    Out interface: pppoe-out2
    Action: Masquerade

    Seguindo em mangle:

    Chain: prerouting
    Src. Address:10.1.0.0/16
    Action: mark routing new mark routing: Link-01
    Passthrough: YES

    Chain: prerouting
    Src. Address:10.2.0.0/16
    Action: mark routing new mark routing: Link-02
    Passthrough: YES


    Até ai esta tudo funcionando as mil maravilhas, mas tem um detalhe, faço muito uso da opção de acessar os aps clientes remotamente e com essa regra de balance só consigo acessar os clientes que estao na minha faixa de ip ,ou seja, 10.2.x.x .

    Sei que alguém poderá dizer, " ueh, é só você trocar sua faixa para 10.1.x.x para acessar os outros clientes " ,

    Mas pergunto, é possível eu acessar estando na faixa 10.2.x.x clientes que estão na faixa 10.1.x.x , porque antes tínhamos aqui faixa 10.10.x.x , 10.20.x.x , 10.30.x.x , 10.40.x.x e eu estando em qualquer uma delas acessa clientes de qualquer uma.

    Detalhe, antes tínhamos load balance por pcc e por rotas estáticas ( um link assumia tudo, menos algumas rotas de alguns sites de vídeos )

    Obrigado!

  2. coloca o router 2 na rede do router 1 como se fosse um pc, e coloca um ip static no router 2

    ex:router 1
    192.168.1.2


    router 2
    192.168.1.80



  3. Boa tarde,

    Seja mais específico em suas regras de NAT. Por exemplo:

    Código :
    /ip firewall nat
    add chain=srcnat src-address=10.1.0.0/16 dst-address=!10.2.0.0/16 out-interface=pppoe-out1  action=masquerade
     
    /ip firewall nat
    add chain=srcnat src-address=10.2.0.0/16 dst-address=!10.1.0.0/16 out-interface=pppoe-out2  action=masquerade
    Use também essa opção de dst-address na suas regras de mangle.

    Abraço

  4. EDITADO EM: 23/11/2012 as 19:48


    /ip route
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Link-Dados-1 \
    routing-mark=Link-01 scope=30 target-scope=10
    add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=Link-Dados-2 \ scope=30 target-scope=10


    /ip firewall nat
    add action=masquerade chain=srcnat comment="Mascaramento para o range de ips 10.1.0.0/16" disabled=no dst-address=!10.2.0.0/16 out-interface=Link-Dados-1 \
    src-address=10.1.0.0/16
    add action=masquerade chain=srcnat comment="Mascaramento para o range de ips 10.2.0.0/16" disabled=no dst-address=!10.1.0.0/16 out-interface=Link-Dados-2 \
    src-address=10.2.0.0/16



    /ip firewall mangle
    add action=mark-routing chain=prerouting disabled=no dst-address=!10.2.0.0/16 new-routing-mark=Link-01 passthrough=yes src-address=10.1.0.0/16
    Última edição por BillGates; 23-11-2012 às 18:48.






Tópicos Similares

  1. 2 redes locais acessando o mesmo link de internet
    Por emerson2703 no fórum Servidores de Rede
    Respostas: 4
    Último Post: 31-07-2009, 21:29
  2. Respostas: 1
    Último Post: 08-01-2009, 09:43
  3. Mesmo link de internet pra 2 redes
    Por dmgamer no fórum Servidores de Rede
    Respostas: 3
    Último Post: 10-07-2007, 02:18
  4. Como configurar um servidor de internet com 2 placas de rede
    Por salsa no fórum Servidores de Rede
    Respostas: 5
    Último Post: 15-09-2005, 14:09
  5. Regra de iptables para barrar faixa de ip
    Por wellesximenes no fórum Servidores de Rede
    Respostas: 4
    Último Post: 31-01-2005, 15:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L