Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Digamos que eu tenha dois roteadores RB1100.( e para cada RB1100, eu tenha vários rb450 conectando no seu devido RB1100)

    eu tenho no roteador no primeiro RB1100 a área 0(backbone) e a área 10(para os clientes).
    no segundo roteador RB1100 eu tenho a área 0(backbone) e a area 11(para clientes)

    Obviamente os dois roteadores RB1100 formam adjacência pela área 0.

    Também, tenho em cada roteador RB100 duas instâncias ( uma para a área backbone e outra para área dos clientes)

    Faço isso, por que eu não quero que as rotas que estão saindo do primeiro RB1100 e indo para o segundo RB1100, penetre na área dos clientes.

    Faço isso, por deixar na instância que designei para área dos clientes marcado como "no" e "never" nas opções do ospf.
    nas instâncias que designei para a área backbone eu seto o "Redistribuite Other OSPF Routes" como "as type 1".
    Nesse caso, as rotas da área do cliente é redistribuida pelo backbone para o ouitro RB1100.

    Beleza até ai?

    Pois então,

    eu quero fazer sumarização das rotas que estão configuradas na área dos clientes.

    Vai um exemplo:

    no primeiro RB1100 eu tenho na aba network do ospf as redes 10.10.0.0/26 , 10.10.0.64/26, 10.10.0.128/26( todos na área 10)
    Nesse caso, eu vou em "area ranges" e coloco lá 10.10.0.0/20 associado a área 10.

    No segundo RB1100 eu tenho na aba network do ospf as redes 10.16.0.0/26, 10.16.0.64/26, 10.16.0.128/26(todos na área 11).
    Nesse caso, eu vou em "area range" e coloco lá 10.16.0.0/22 associado a área 11.


    Pergunta:

    Um RB1100 está enviando o anúncio de sumarização, o outro não.
    As configurações estão iguais.

    Existe alguma maneira mais fácil de fazer isso?

    Att,

  2. Boa tarde,

    Não é muito comum usar mais de uma instância OSPF. Para fazer o que você está querendo, que é não injetar rotas externas em uma área diferente da zero, basta que as áreas 10 e 11 sejam do tipo stub.

    Esse tipo não permite que rotas externas ingressem na área, ao invés disso, o protocolo irá criar uma rota default. Resumindo, você terá apenas rotas internas a sua área, mais uma rota default.

    Sobre a sumarização não estar funcionando, mande-nos os detalhes da sua configuração. Confira também a opção Advertise.

    Abraço




  3. Bom dia,

    Deixe-me explicar primeiro o que aconteceu com a sumarização.

    A opção "Advertise" estava marcado.

    Na primeira vez que eu inseria a informação na aba "area ranges", a sumarização ocorria normalmente, porém a fim testes
    quando bloqueava a rede sumarizada em routing > filter, utilizando o chain ospf-out, o anúncio da sumarização era bloqueado - como esperado.

    Desabilitando a mesma regra do filter, a sumarização não voltava a ocorrer, sendo que o problema era sanado apenas, e apenas,
    quando na janela da instância do ospf eu trocava o nome das chains ( trocada de ospf-out para ospf-out2).

    Pronto,

    Resolvido, embora haja um erro - caracterizando um bug? - na forma do RouterOS lidar com a situação.


    Agora, quanto ao conselho para utilizar uma área como stub.

    Muito obrigado, utilizar o stub como tipo de área é realmente um benefício, porém surgiu algumas questões.

    Como informação de referência[1], percebe-se que uma área stub recebe e envia anúncios type 3, ou seja recebe e anúncia redes internas.

    Apenas anúncios type 5 - gerados pelo ASBR- não são inseridas nas áreas stub.

    Essa é a teoria, agora vamos ao que aconteceu na prática ( E é exatamente aqui onde começa a surgir as questões de dúvida de que falei, devido a provavelmente eu estar entendo alguma coisa errado.)

    Como sugerido( inicialmente para testes) eu eliminei em um RB1100 a existência de duas instâncias, optando por uma.
    Deixei as duas áreas(backbone e área do cliente) na mesma instância, coloquei como "no" o
    "Redistribuite Other OSPF Routes" e coloquei a área do cliente em stub - no roteador cliente também foi feito isso.

    Ok, formou adjacência perfeitamente, e as rotas das outras áreas não foram aprendidas ( primeira dúvida: o wiki da mikrotik não fala que lsa do type 3 não são enviadas para área stub?)

    Segundo, as rotas que estavam vinculadas a área backbone( que nesse caso são a faixa de endereço da rede backbone e os LOs dos roteadores) foram propagadas para dentro da área stub ( segunda dúvida: por que, embora essas duas situações sejam similares(não são?) houve dois comportamentos diferentes? Por que o backbone e a área do cliente estão juntos na mesma instância?


    Enfim, se me delonguei demais, peço desculpas.

    Att




    [1] http://wiki.mikrotik.com/wiki/Manual:OSPF_Case_Studies






  4. Vamos analisar com mais detalhes o seu cenário. Mande-nos o export das configurações do OSPF.

    Áreas Stub não aceitam anúncios externos MAS aceitam rotas sumarizadas, que é o seu caso certo? Então acredito que as rotas que foram injetadas na área stub foram sumarizadas.

    Áreas Totally Stub não aceitam anúncios externos e também não aceitam rotas sumarizadas, acho que essa é a melhor escolha para você.

    Vamos analisar as suas configuração a ajustá-las para o seu ambiente.

    Abraço



  5. Acredito que esteja havendo um engano aqui gamineiro.


    Avançando nos testes, constatei que uma área stub permite lsa type 3( como mencionei no post anterior), o que significa que anúncios de redes internas do dominio ospf irão adentrar na área stub.

    Nesse ponto, começa o primeiro ponto de discórdia.
    Por "dominio ospf", de imediato eu entenderia como um grupo de roteadores fazendo parte de um área.
    Mas pelos testes, não é isso.

    Ou seja, todos os roteadores de todas as áreas fazem parte do dominio ospf.

    E baseado na própria wiki do mikrotik, uma área stub, apenas não aceita anúncios lsa type 5( lsa gerados apenas pelos ASBR).

    Respondendo a sua pergunta, eu retirei as configurações de sumarização para fazer os testes.
    Então, não eram as rotas sumarizadas que estavam sendo propagadas dentro da área stub.


    Você citou Áreas Totally Stub, porém o mikrotik não implementa esse conceito, correto?

    Um dos fabricantes que conheço que implementa isso é a cisco.

    Abaixo vai o export que você pediu - o export é de um rb1100, citado na minha narração no primeiro post.


    # apr/21/1970 20:02:48 by RouterOS 5.19
    # software id = 6RAB-CSXR
    #
    /routing ospf instance
    set [ find default=yes ] disabled=no distribute-default=never in-filter=\
    ospf-in metric-bgp=auto metric-connected=20 metric-default=1 \
    metric-other-ospf=auto metric-rip=20 metric-static=20 name=default \
    out-filter=ospf-out redistribute-bgp=no redistribute-connected=no \
    redistribute-other-ospf=as-type-1 redistribute-rip=no \
    redistribute-static=no router-id=10.20.0.2
    add disabled=no distribute-default=always-as-type-1 in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=\
    auto metric-rip=20 metric-static=20 name=areas out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no \
    redistribute-rip=no redistribute-static=no router-id=10.20.0.4
    /routing ospf area
    set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=\
    backbone type=default
    add area-id=0.0.0.10 disabled=no instance=areas name=area10 type=default
    /routing ospf area range
    add advertise=yes area=area10 cost=calculated disabled=yes range=10.10.0.0/20
    /routing ospf interface
    add authentication=none authentication-key="" authentication-key-id=1 cost=10 \
    dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=\
    ether1 network-type=nbma passive=no priority=1 retransmit-interval=5s \
    transmit-delay=1s use-bfd=no
    add authentication=none authentication-key="" authentication-key-id=1 cost=10 \
    dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=\
    "VID 921" network-type=broadcast passive=no priority=0 \
    retransmit-interval=5s transmit-delay=1s use-bfd=no
    add authentication=none authentication-key="" authentication-key-id=1 cost=10 \
    dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=\
    LO network-type=broadcast passive=yes priority=1 retransmit-interval=5s \
    transmit-delay=1s use-bfd=no
    add authentication=none authentication-key="" authentication-key-id=1 cost=10 \
    dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=\
    "VID 922" network-type=nbma passive=no priority=1 retransmit-interval=5s \
    transmit-delay=1s use-bfd=no
    add authentication=none authentication-key="" authentication-key-id=1 cost=10 \
    dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=\
    "VID 923" network-type=nbma passive=no priority=1 retransmit-interval=5s \
    transmit-delay=1s use-bfd=no
    add authentication=none authentication-key="" authentication-key-id=1 cost=10 \
    dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=\
    LO2 network-type=broadcast passive=yes priority=1 retransmit-interval=5s \
    transmit-delay=1s use-bfd=no
    /routing ospf nbma-neighbor
    add address=10.10.0.10 disabled=no instance=areas poll-interval=2m priority=0
    add address=10.10.0.11 disabled=no instance=areas poll-interval=2m priority=0
    add address=10.10.0.12 disabled=no instance=areas poll-interval=2m priority=0
    add address=10.10.0.13 disabled=no instance=areas poll-interval=2m priority=0
    add address=10.10.0.66 disabled=no instance=areas poll-interval=2m priority=0
    add address=10.10.0.67 disabled=no instance=areas poll-interval=2m priority=0
    add address=10.10.0.130 disabled=no instance=areas poll-interval=2m priority=\
    0
    add address=10.10.0.131 disabled=no instance=areas poll-interval=2m priority=\
    0
    /routing ospf network
    add area=backbone disabled=no network=192.168.10.0/24
    add area=backbone disabled=no network=10.20.0.2/32
    add area=area10 disabled=no network=10.10.0.0/26
    add area=area10 disabled=no network=10.10.0.64/26
    add area=area10 disabled=no network=10.10.0.128/26
    add area=area10 disabled=no network=10.20.0.4/32










Tópicos Similares

  1. OSPF com 2 links em pontos diferentes
    Por claudinhohw no fórum Redes
    Respostas: 10
    Último Post: 20-10-2015, 10:47
  2. WRT54G com antenas diferentes?
    Por Neofito no fórum Redes
    Respostas: 4
    Último Post: 28-06-2007, 07:40
  3. Quagga + OSPF com 3 roteadores
    Por EJALES no fórum Redes
    Respostas: 1
    Último Post: 06-05-2007, 12:04
  4. Mesmos Arquivos com tamanhos diferentes
    Por Dedao no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-04-2007, 13:54
  5. espelhamento com HDs diferentes
    Por eagm no fórum Servidores de Rede
    Respostas: 6
    Último Post: 11-01-2005, 16:56

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L