Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal preciso fazer o seguinte :

    Tenho um link de 10 mb com vários ips válidos, e uns 10 cliente de empresas que precisam de ip válido e redirecionamento de portas para acessos externos ou outro tipo de comunicação. O link entra por uma porta em uma RB1100 e os clientes entra por outra.

    Preciso fazer o redirecionamento dos clientes para esses ips válidos e suas respectivas portas, gostaria de fazer via nat para não precisar fazer marcação de pacotes.

    Alguém teria alguma ideia ?

  2. Boa noite,


    Segue um exemplo de regra de redirecionamento.

    Código :
    /ip firewall nat
    add action=dst-nat chain=dstnat dst-address=200.200.200.200 dst-port=8080 protocol=tcp to-addresses=192.168.0.1

    Voce também precisa fazer com que a saída desse cliente seja pelo mesmo IP válido usado na entrada.

    Código :
    /ip firewall nat
    add action=src-nat chain=srcnat out-interface=ether-wan src-address=192.168.0.1 to-addresses=200.200.200.200

    Lembre-se que ao menos a segunda regra precisa ficar antes da sua regra de NAT geral.

    Abraço



  3. Citação Postado originalmente por gamineiro Ver Post
    Boa noite,


    Segue um exemplo de regra de redirecionamento.

    Código :
    /ip firewall nat
    add action=dst-nat chain=dstnat dst-address=200.200.200.200 dst-port=8080 protocol=tcp to-addresses=192.168.0.1

    Voce também precisa fazer com que a saída desse cliente seja pelo mesmo IP válido usado na entrada.

    Código :
    /ip firewall nat
    add action=src-nat chain=srcnat out-interface=ether-wan src-address=192.168.0.1 to-addresses=200.200.200.200

    Lembre-se que ao menos a segunda regra precisa ficar antes da sua regra de NAT geral.

    Abraço
    Desculpa não poder ajudar e levantar mais dúvidas, mas acho melhor do que criar um outro tópico com assunto parecido.
    Seguinte, utilizo suas regras citadas pra direcionar ip validos aqui, funciona. Pois estou com um probleminha, seguindo seu exemplo imagine o cenário

    200.200.200.201 - INTERFACE-LINK
    200.200.200.202 - INTERFACE-LINK
    200.200.200.203 - INTERFACE-LINK
    200.200.200.204 - INTERFACE-LINK
    192.168.0.254/24 - INTERFACE-CLIENTES1
    192.168.1.254/24 - INTERFACE-CLIENTES2



    Como viu tenho 4 ips válidos adicionados na interface que recebo o link.

    Meu mascaramento ta assim:
    1 Chain: srcnat , Src Address: 192.168.0.0/24, Action Masquerade
    2 Chain: srcnat , Src Address: 192.168.1.0/24, Action Masquerade


    Usando as regras citadas eu eu defino dois ips públicos para dois clientes qualquer:
    200.200.200.204 > 192.168.0.100
    200.200.200.203 > 192.168.0.101

    Até ai sem problemas, agora como defino qual qual endereço publico os clientes normais vão utilizar? (os das duas lans citadas acima)

    As vezes quando adiciono um IP VALIDO na interface do LINK para redirecionar para algum cliente acaba que os clientes das duas lans são redirecionadas automaticamente pra ele, impossibilitando eu utilizar para para um cliente especifico.

    Tentei a regra citada usando o endereço da rede invés do endereço do cliente especifico (exemplo 192.168.0.0/24)
    Apesar de funcionar perco o acesso ao mikrotik pelo IP Válido.

    Grato pela ajuda =D

  4. Woops, Pensando bem aqui, nesse caso eu deveria usar apenas a regra dizendo que tudo que vem da faixa local sai por determinado IP valido, correto? Ou devo fazer de outra forma?



  5. Bom dia,

    A segunda regra que te passei é justamente para isso. Quando você utiliza masquerade, digamos que seja "aleatório" a escolha do IP de saída quando você tem mais de um IP na interface WAN.

    Use esse código e faça as alterações necessárias:
    Código :
    /ip firewall nat add action=src-nat chain=srcnat out-interface=ether-wan src-address=192.168.0.1 to-addresses=200.200.200.200

    Abraço






Tópicos Similares

  1. Respostas: 2
    Último Post: 26-12-2012, 09:37
  2. Direcionar PING para um IP ESTATICO
    Por aka2005 no fórum Redes
    Respostas: 6
    Último Post: 04-06-2010, 09:01
  3. Direcionar tráfego de entrada externo para um ip interno
    Por eume5mo no fórum Servidores de Rede
    Respostas: 1
    Último Post: 25-06-2008, 08:52
  4. Direcionar tráfego de entrada de uma porta para um IP da rede
    Por lothario no fórum Servidores de Rede
    Respostas: 3
    Último Post: 13-05-2008, 23:27
  5. REDIRECIONAR PORTAS PARA UM IP DO CLIENTE
    Por tianguapontocom no fórum Servidores de Rede
    Respostas: 7
    Último Post: 22-06-2006, 16:35

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L