+ Responder ao Tópico



  1. #1

    Padrão Redirecionamento (regras corretas, mas nao funciona)

    Caros amigos, tenho um balance com dois links e um servidor de autenticaçao, quero redirecionar o acesso via winbox que chega no LB para o server, porem a coisa nao funciona de jeito nenhum.

    LB > ipadresss> 192.168.100.1/24

    Server> ipadress> 192.168.100.2/24

    LB > iproute> 192.168.100.2

    Server> iproute> 192.168.100.1

    LB > ip services > winbox porta 8291

    Server > ip services > winbox porta 8291

    add action=dst-nat chain=dstnat comment="Red WINBOX p Servidor" disabled=no
    dst-port=8292 protocol=tcp to-addresses=192.168.100.2 to-ports=8291

    o ping ta ok para as duas rbs, mas o redirecionamento nao vai nem com a poxa!!

    alguem podeme dar uma dica?

    Vlw.
    Última edição por wesleydialmeida; 04-01-2013 às 20:40.

  2. #2

    Padrão Re: Redirecionamento (regras corretas, mas nao funciona)

    Antes de me pronunciar, existe alguma rb de retaguarda?



  3. #3

    Padrão Re: Redirecionamento (regras corretas, mas nao funciona)

    Confesso que não tenho certeza de ter entendido bem a pergunta, mas tente determinar por qual interface vem as requisições acrescentando a sua regra o seguinte in-interface=etherX então determine qual a interface que irá receber a requisição, caso o ip seja estático você pode determinar o ip com dst-address=IP.

  4. #4

    Padrão Re: Redirecionamento (regras corretas, mas nao funciona)

    Citação Postado originalmente por wesleydialmeida Ver Post

    add action=dst-nat chain=dstnat comment="Red WINBOX p Servidor" disabled=yes
    dst-port=8292 protocol=tcp to-addresses=192.168.100.2 to-ports=8291


    Vlw.
    lí direitinho su regra pelo que vi está desabilitada! teria que ser disabled=no
    Dá uma olhadinha em Ip> Firewall>Nat e veja se sua regra está desabilitada mesmo!



  5. #5

    Padrão Re: Redirecionamento (regras corretas, mas nao funciona)

    Citação Postado originalmente por hodesanionetx Ver Post
    Antes de me pronunciar, existe alguma rb de retaguarda?
    nao existe, to quase pra resetar o servidor, ou entao arrumar outra rb pra teste no lugar do server.

  6. #6

    Padrão Re: Redirecionamento (regras corretas, mas nao funciona)

    Citação Postado originalmente por farias Ver Post
    Confesso que não tenho certeza de ter entendido bem a pergunta, mas tente determinar por qual interface vem as requisições acrescentando a sua regra o seguinte in-interface=etherX então determine qual a interface que irá receber a requisição, caso o ip seja estático você pode determinar o ip com dst-address=IP.
    pois e farias tambem ja fiz esse tipo de apontamento de diversas formas, e como se algo na rb do server estivesse bloqueando o acesso, sendo que ja desabilitei todo filter e mangle.



  7. #7

    Padrão Re: Redirecionamento (regras corretas, mas nao funciona)

    Citação Postado originalmente por hodesanionetx Ver Post
    lí direitinho su regra pelo que vi está desabilitada! teria que ser disabled=no
    Dá uma olhadinha em Ip> Firewall>Nat e veja se sua regra está desabilitada mesmo!
    na verdade eu exportei depois de desabilitar, mas ja testei de todas as formas possiveis. to achando que trata-se de algum impecilio no server.

  8. #8

    Padrão Re: Redirecionamento (regras corretas, mas nao funciona)

    Se a origem da requisição vier da mesma rede, este redirecionamento não irá funcionar, já que a os pacotes não irão passar pelo router. Você precisa definir uma outra rede para este servidor, adicione uma outra rede à interface, de preferencia um /30, e faça o redirecionamento para esse ip, ai vai funcionar !!!