+ Responder ao Tópico



  1. #1

    Padrão Redirecionar porta 80 para servidor Apache

    Pessoal possuo um servidor linux rodando um LAMP
    prém, qndo faço um DST-NAT da porta 80 para a porta 80 do meu servidor, todos os hosts da minha rede
    ao acessar qualquer site cai no meu servidor....

    Como resolvo isso?


    Desde já agradeço

  2. #2

    Padrão Re: Redirecionar porta 80 para servidor Apache

    Você está fazendo esse redirecionamento no mikrotik ou iptables?
    O que você quer é acessar seu site no servidor interno a partir da Internet estou certo?



  3. #3

    Padrão Re: Redirecionar porta 80 para servidor Apache

    Isso, eu estou montando um servidor Apache com um site, e este servidor está atraz de um mikrotik, na opção Firewall da RB foi que eu fiz a configuração do DST-NAT.

    Porem nao funcionou

  4. #4

    Padrão Re: Redirecionar porta 80 para servidor Apache

    Usas pppoe ou ip-addres no link que saí para Internet
    Poste a saída de:
    Código :
    /ip firewall nat export
    se quiser poste só a parte que configuraste.



  5. #5
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão Re: Redirecionar porta 80 para servidor Apache

    Citação Postado originalmente por marcosvinicius1221 Ver Post
    Pessoal possuo um servidor linux rodando um LAMP
    prém, qndo faço um DST-NAT da porta 80 para a porta 80 do meu servidor, todos os hosts da minha rede
    ao acessar qualquer site cai no meu servidor....

    Como resolvo isso?


    Desde já agradeço

    Boa tarde amigo,


    tem como vc postar como esta ligado sua rede, por onde entra o link e que posicao esta ligado seu servidor linux em relacao ao mikrotik, onde vc esta fazendo o direcionamento, por que a porta 80 e a porta usanda pelos sites http se vc direcionar a porta 80 de entrada da sua rede todo trafico enviado para a porta 80 da sua caisa no servidor, entao se possivel amigo apresente um esquema de ligacao da rede para nos entender e auxiliar com claresa sem ficar especulando.



    abraco

  6. #6

    Padrão Re: Redirecionar porta 80 para servidor Apache

    LINK - 20MB Dedicado
    |
    |
    RB----Servidor LAMP
    |
    |
    |
    Usuarios

    Regras do NAT


    add action=masquerade chain=srcnat comment="default configuration" disabled=no
    add action=dst-nat chain=dstnat comment="Nat para SSH servidor" disabled=no dst-port=3030 protocol=tcp to-addresses=192.168.19.252 to-ports=22
    add action=dst-nat chain=dstnat comment="NAT Servidor FTP" disabled=no dst-port=3032 protocol=tcp to-addresses=192.168.19.252 to-ports=21
    add action=dst-nat chain=dstnat comment="NAT Servidor APACHE porta 80" disable=no dst-port=80 protocol=tcp
    to-address=192.168.19.252 to-ports=80



  7. #7
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão Re: Redirecionar porta 80 para servidor Apache

    Citação Postado originalmente por marcosvinicius1221 Ver Post
    LINK - 20MB Dedicado
    |
    |
    RB----Servidor LAMP
    |
    |
    |
    Usuarios

    Regras do NAT


    add action=masquerade chain=srcnat comment="default configuration" disabled=no
    add action=dst-nat chain=dstnat comment="Nat para SSH servidor" disabled=no dst-port=3030 protocol=tcp to-addresses=192.168.19.252 to-ports=22
    add action=dst-nat chain=dstnat comment="NAT Servidor FTP" disabled=no dst-port=3032 protocol=tcp to-addresses=192.168.19.252 to-ports=21
    ate aqui esta funcionando ok?


    Citação Postado originalmente por marcosvinicius1221 Ver Post
    add action=dst-nat chain=dstnat comment="NAT Servidor APACHE porta 80" disable=no dst-port=80 protocol=tcp
    to-address=192.168.19.252 to-ports=80
    agora esta regra vc tem que dizer qual e a input interface erra direciobar, se nao qualquer eth ela resoponde e ai o erro

    exemplo:
    add chain=dstnat action=dst-nat to-addresses=192.168.2.252 comment="NAT Servidor APACHE porta 80" to-ports=80 protocol=tcp
    in-interface=ether1 dst-port=80 ( observer que o que entrar pela pela inface ether1 distino porta 80 sera direcionando para a o ip 192.168.2.252 porta 80

    acho que isto

    falou vou dormir

    abraco