Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Depois da atualização deles do dia 15, meus scripts do Mikrotik no ChangeIP deixaram de funcionar.

    Alguém sabe se isso é bug ou é necessária configuração diferente ?

  2. Ola irmao, eu uso ChangeIP e esta funcionando aqui comigo usando o codigo que colei abaixo para voce. Espero que te ajude.
    Código :
    :global ddnsuser "usuario"
    :global ddnspass "asenha"
    :global ddnshost "host.ddns.us"
    :global ddnsinterface "ether1-Link1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
     
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip
     
     
    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
     
     
    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
     
     
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
     
     
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
     
     
    } else={
     
     
      :if ($ddnsip != $ddnslastip) do={
     
     
        :log info "DDNS: Sending UPDATE!"
        :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global ddnslastip $ddnsip
     
     
      } else={ 
     
     
        :log info "DDNS: No changes necessary."
     
     
      }
     
     
    }
     
     
    # END OF SCRIPT
    }
     
     
    :log info "DDNS: End"



  3. mas para que versao do mkt é esse script rodar ?


    Citação Postado originalmente por leoservice Ver Post
    Ola irmao, eu uso ChangeIP e esta funcionando aqui comigo usando o codigo que colei abaixo para voce. Espero que te ajude.
    Código :
    :global ddnsuser "usuario"
    :global ddnspass "asenha"
    :global ddnshost "host.ddns.us"
    :global ddnsinterface "ether1-Link1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
     
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip
     
     
    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
     
     
    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
     
     
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
     
     
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
     
     
    } else={
     
     
      :if ($ddnsip != $ddnslastip) do={
     
     
        :log info "DDNS: Sending UPDATE!"
        :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global ddnslastip $ddnsip
     
     
      } else={ 
     
     
        :log info "DDNS: No changes necessary."
     
     
      }
     
     
    }
     
     
    # END OF SCRIPT
    }
     
     
    :log info "DDNS: End"

  4. Citação Postado originalmente por silviola Ver Post
    Depois da atualização deles do dia 15, meus scripts do Mikrotik no ChangeIP deixaram de funcionar.

    Alguém sabe se isso é bug ou é necessária configuração diferente ?
    olá bom dia e ai conseguiu resolver?



  5. Recém recebi aviso de resposta nesta mensagem... a tarde já vou tentar e a noite posto o resultado.

    Edit: na madrugada o script atualizou, de repente está voltando ao normal. Eu até enviei um Ticket pra eles há uns 2 dias, de repente poderia ser problema na minha conta.

    Meu script acredito inclusive que era identico ao postado aqui, mas se der zica nas próximas atualizações, eu venho aqui e testo este e relato.






Tópicos Similares

  1. KERNEL PANIC no 2.6.12 "uname to mount root fs...."
    Por perilampo no fórum Servidores de Rede
    Respostas: 4
    Último Post: 14-07-2005, 19:11
  2. Servidor SAMBA - "Existe um nome duplicado na rede"
    Por Gustavo_DF no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-05-2005, 12:13
  3. quote site exec xxxx
    Por papaleguas no fórum Servidores de Rede
    Respostas: 0
    Último Post: 13-04-2004, 17:27
  4. quote / antivirus / spam / webmail
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-12-2003, 19:38
  5. Respostas: 0
    Último Post: 05-08-2003, 20:47

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L