Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Problema com controle de banda na mikrotik

    Olá amigos peço mais vez a ajuda de voces numa duvida tenho um servidor hotspot num mikrotik,e olhando o consumo dos clientes percebi que alguns passam da taxa da velocidade do profile e do queque,alguem me ajude sera que to com virus na rede ou é so questao de configuraçoes mesmo,tanto o profile quanto o queque ta o mesmo valor e mesmo assim eles ultrapassam a velocidade determinada que é de 500k.

    Clique na imagem para uma versão maior

Nome:	         Rb.jpg
Visualizações:	814
Tamanho: 	170,7 KB
ID:      	42415
    Alguem me de uma luz.

  2. #2

    Padrão Re: Problema com controle de banda no MikroTik RouterOS

    Citação Postado originalmente por jacjunior21 Ver Post
    Olá amigos peço mais vez a ajuda de voces...
    ...Alguem me de uma luz.
    Boa noite.

    Pela imagem, vejo que você está usando o MikroTik RouterOS 5.21. Recomendo a atualização para MikroTik RouterOS 5.23, versão mais recente, nesse momento. Atualize também o firmware. Para RB600A, a versão atual é 2.27.

    Depois de atualizado, monitore se o problema persiste.

    Saudações,

    Trober



  3. #3

    Padrão Re: Problema com controle de banda na mikrotik

    Só fazendo um aporte. Eu tive problemas com o 5.23, minha RB450G ficava reiniciando com freqüencia, coisa que com o 5.20 que estava antes nao ocorria, fiz o downgrade de 5.23 para o 5.22 e ficou estável. Se por algum motivo ao atualizar para a 5.23 e ficar reiniciando, volte para a 5.22

  4. #4

    Padrão Re: Problema com controle de banda no MikroTik

    Citação Postado originalmente por EribertoTorres Ver Post
    Só fazendo um aporte. Eu tive problemas com o 5.23, minha RB450G ficava reiniciando com freqüencia, coisa que com o 5.20 que estava antes nao ocorria, fiz o downgrade de 5.23 para o 5.22 e ficou estável. Se por algum motivo ao atualizar para a 5.23 e ficar reiniciando, volte para a 5.22
    Oi Eriberto. Presenciei situações parecidas, em que algumas Routerboards reiniciavam aleatoriamente, com a mensagem "kernel failure", depois da atualização para MikroTik RouterOS 5.23. A solução veio com a elevação da corrente da fonte de alimentação.

    O que vou dizer agora é totalmente empírico (para não dizer absurdo), mas é como se o MikroTik RouterOS 5.23 fosse mais sedento por tensão e corrente, hehe.

    Resumindo, nos casos que tive esse problema, troquei a fonte, e solucionou

    Para fins de complementação, os novos valores de tensão e corrente são, respectivamente, 24v e 10A. O problema só se apresentou nas Routerboards de série 400, 600 e 800. Não tive qualquer problema com outras séries (300, 700, 1000).

    Sim, concordo que é insano uma Routerboard precisar de 240 watts, mas foi o que solucionou, e até agora não deu problema.

    Saudações,

    Trober



  5. #5

    Padrão Re: Problema com controle de banda na mikrotik

    Trober, quando li o inicio do post pensei: mas minha fonte é para notebok, tem corrente e voltagem suficiente, ai quando vi a especificacao completa da tua 20 V x 10 A desisti de por a culpa na fonte hehe.

    Houve uma versao do Kernel do Linux que saiu com um certo problema sim, o qual fazia aumentar o consumo de energia, pois elevava e muito o processamento. Como já faz um tempo, nao lembro qual versao do Kernel, e como o RouterOS é baseado no Kernel do Linux, pode ser que tenha algo a ver ai sim, e bate com o que você falou: RB série 400.

    Vamos aguardar o próximo changelog e ver onde está o erro rss.

  6. #6

    Padrão Re: Problema com controle de banda na mikrotik

    Na simple queue o hotspot cria uma regra dinâmica que deve sempre ficar na última linha .. hs-<hotspot1> Unlimited em tx e rx.

    Se esta regra saltar lá para o meio, por exemplo, todos que estiverem abaixo da regra estarão sem controle de banda.

    Dá uma conferida nisso.



  7. #7

    Padrão Re: Problema com controle de banda na mikrotik

    Citação Postado originalmente por 1929 Ver Post
    Na simple queue o hotspot cria uma regra dinâmica que deve sempre ficar na última linha .. hs-<hotspot1> Unlimited em tx e rx.

    Se esta regra saltar lá para o meio, por exemplo, todos que estiverem abaixo da regra estarão sem controle de banda.

    Dá uma conferida nisso.
    Ok amigo vo dar uma olhada .

  8. #8

    Padrão Re: Problema com controle de banda na mikrotik

    Citação Postado originalmente por jacjunior21 Ver Post
    Olá amigos peço mais vez a ajuda de voces numa duvida tenho um servidor hotspot num mikrotik,e olhando o consumo dos clientes percebi que alguns passam da taxa da velocidade do profile e do queque,alguem me ajude sera que to com virus na rede ou é so questao de configuraçoes mesmo,tanto o profile quanto o queque ta o mesmo valor e mesmo assim eles ultrapassam a velocidade determinada que é de 500k.

    Clique na imagem para uma versão maior

Nome:	         Rb.jpg
Visualizações:	814
Tamanho: 	170,7 KB
ID:      	42415
    Alguem me de uma luz.
    cara recentemente tive o mesmo problema relatei em outro topico e ate elogiei um outro companheiro mas foi em vao nao resolveu. o que ta acalsionando pode ser amesma coisa que aqui. no meu e o youtube quando abro ele vai por fora do controle de banda. tente ver se pode ser isto tanbem



  9. #9

    Padrão Re: Problema com controle de banda na mikrotik

    Amigo sua rede esta em bridge, se sim se pode estar com broadcast rodando em sua rede

  10. #10

    Padrão Re: Problema com controle de banda na mikrotik

    Citação Postado originalmente por jacjunior21 Ver Post
    Ok amigo vo dar uma olhada .
    Veja aí o que eu quis dizer
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         tela-winbox.jpg
Visualizações:	260
Tamanho: 	124,5 KB
ID:      	42433  



  11. #11

    Padrão Re: Problema com controle de banda na mikrotik

    no meu nao ta asim nao.

  12. #12

    Padrão Re: Problema com controle de banda na mikrotik

    Usa algum cache???



  13. #13

    Padrão Re: Problema com controle de banda na mikrotik

    Amigo voce tem alguma regra do Queue Tree?
    Exemplo regras de P2P ou cache ou até mesmo liberando banda para algun site como youtube?

    Se sua resposta for sim ai esta sua resposta.

    Quando voce tem um cliente com limite de 512Kbps e voce tem uma regra no QUEUE TREE de P2P de 2Mbps por exemplo, o mesmo cliente pode usar os 512Kbps dele e ainda usar 1Mbps do sua regra de QUEUE TREE. Ai la no hotspot voce vai ver o cara baixando a 1,5Kbps e vai achar estranho rs.

    Desabilite as regras e vc vai ver como para tudo isso.

  14. #14

    Padrão Re: Problema com controle de banda na mikrotik

    Citação Postado originalmente por salvato Ver Post
    Amigo voce tem alguma regra do Queue Tree?
    Exemplo regras de P2P ou cache ou até mesmo liberando banda para algun site como youtube?

    Se sua resposta for sim ai esta sua resposta.

    Quando voce tem um cliente com limite de 512Kbps e voce tem uma regra no QUEUE TREE de P2P de 2Mbps por exemplo, o mesmo cliente pode usar os 512Kbps dele e ainda usar 1Mbps do sua regra de QUEUE TREE. Ai la no hotspot voce vai ver o cara baixando a 1,5Kbps e vai achar estranho rs.

    Desabilite as regras e vc vai ver como para tudo isso.
    regra de QUEUE TREE so a do cache full. regra para P2P nao tenho. agora o detalhe e serto ele abre o youtube na velocidade do cache full.(2m)



  15. #15

    Padrão Re: Problema com controle de banda na mikrotik

    Citação Postado originalmente por isaquias Ver Post

    regra de QUEUE TREE so a do cache full. regra para P2P nao tenho. agora o detalhe e serto ele abre o youtube na velocidade do cache full.(2m)
    Ta ai sua resposta.
    Quando o cliente esta sugando os 2Mbps do cache e usando outra coisa ele soma com o limite dele no simple queue.

    Eu tive muita experiencia com cache, e acho que cache full é bobeira. Voce deve aproveitar o desempenho so seu cache para vender planos maiores com valores diferentes.

    Agora se voce cobra por um plano e acaba enviando o dobro o cliente vicia, pior ele acostuma baixar videos rapidos e quando ele não pega um video do cache e o mesmo vem em sua velocidade contratada é capaz dele te ligar e dizer que a internet esta lenta.

  16. #16

    Padrão Re: Problema com controle de banda na mikrotik

    Detale, nao e que ele some alguma coisa do cache e sua bamda. so asistindo video do youtube sem abrir nada mais ele ja vai para os 2mg e so com o youtube. com video tipo globo ou ate xvideos e etc... nao acontece



  17. #17

    Padrão Re: Problema com controle de banda na mikrotik

    Citação Postado originalmente por salvato Ver Post
    Amigo voce tem alguma regra do Queue Tree?
    Exemplo regras de P2P ou cache ou até mesmo liberando banda para algun site como youtube?

    Se sua resposta for sim ai esta sua resposta.

    Quando voce tem um cliente com limite de 512Kbps e voce tem uma regra no QUEUE TREE de P2P de 2Mbps por exemplo, o mesmo cliente pode usar os 512Kbps dele e ainda usar 1Mbps do sua regra de QUEUE TREE. Ai la no hotspot voce vai ver o cara baixando a 1,5Kbps e vai achar estranho rs.

    Desabilite as regras e vc vai ver como para tudo isso.
    Tenho esta regra aqui e esta funcionando no ares e bittorrent, que e o mais popular entre os clientes aqui na rede.

    Limita em 64k de up e down.

    Copiar e colar no terminal:

    /ip firewall layer7-protocol
    add name=bittorrent regexp="^(\13bittorrent protocol|azver\01\$|get/scrape\\\?info_hash=)|d1:ad2:id20:|\08'7P\\)[RP]"
    add name=ares regexp="^\03[]Z].\?.\?\05\$"

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN Ares disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT Ares disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN Bittorrent disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT Bittorrent disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=64k name=p2p_in packet-mark=p2p_in parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=64k name=p2p_out packet-mark=p2p_out parent=global-out priority=\
    8 queue=default

    Agora tem que ser na unha,pois sou leigo e não sei fazer a regra pelo terminal:

    vai em ip/firewall/mangle 2 cliques na regra P2P_IN Ares,na aba advanced localize a opção Layer7 protocol selecione "ares" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_OUT Ares,na aba advanced localize a opção Layer7 protocol selecione "ares" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_IN Bittorrent,na aba advanced localize a opção Layer7 protocol selecione "bittorrent" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_OUT Bittorrent,na aba advanced localize a opção Layer7 protocol selecione "bittorrent" e clique em apply.

    *Não alterar a regra mark packet,somente mark connection.

    Pronto!

  18. #18

    Padrão Re: Problema com controle de banda na mikrotik

    Testei aqui mais não funcionou não, o Utorrent tava baixando a 90kbps, posta um print de sua aba layer 7 pra eu ver como ficou. Pois acho que aqui a regra ficou com erro, dá uma olhada....

    Clique na imagem para uma versão maior

Nome:	         Layer7.jpg
Visualizações:	116
Tamanho: 	39,8 KB
ID:      	43619
    Última edição por BitPC; 23-08-2015 às 14:59.



  19. #19

    Padrão Re: Problema com controle de banda na mikrotik

    Citação Postado originalmente por BitPC Ver Post
    Testei aqui mais não funcionou não, o Utorrent tava baixando a 90kbps, posta um printo de sua aba layer 7 pra eu ver como ficou. Pois acho que aqui a regra ficou com erro, dá uma olhada....

    Clique na imagem para uma versão maior

Nome:	         Layer7.jpg
Visualizações:	116
Tamanho: 	39,8 KB
ID:      	43619
    Segue o print do layer 7

    Clique na imagem para uma versão maior

Nome:	         Captura de tela de 2013-03-25 23:54:46.jpg
Visualizações:	94
Tamanho: 	124,3 KB
ID:      	43622Clique na imagem para uma versão maior

Nome:	         Captura de tela de 2013-03-25 23:49:30.jpg
Visualizações:	96
Tamanho: 	111,1 KB
ID:      	43623
    A regra esta assim:
    ^(bittorrent protocol|azver$|get/scrape\?info_hash=)|d1:ad2:id20:|'7P\)[RP]

    Dei uma olhada e realmente alguns torrents não são controlados(é o tal do magnet link),caso queira bloquear tudo esta regra funciona por enquanto:

    1 –

    /ip firewall layer7-protocol
    add name=teamspeak regexp="^\F4\BE\03.*teamspeak"
    add name=worldofwarcraft regexp="^\06\EC\01"
    add name=ventrilo regexp="^..\?v\\\$\CF"
    add name=edonkey regexp="^[\C5\D4\E3-\E5].\?.\?.\?.\?([\01\02\05\14\15\16\18\19\1A\1B\1C [email protected][`\81\82\90\91\93\96\97\98\99\9A\9B\9C\9E\A0\A1\A2\A3\
    \A4]|Y................\?[ -~]|\96....\$)"
    add name=goboogy regexp="<peerplat>|^get /getfilebyhash\\.cgi\\\?|^get /queue_register\\.cgi\\\?|^get /getupdowninfo\\.cgi\\\?"
    add name=soribada regexp="^GETMP3\r\
    \nFilename|^\01.\?.\?.\?(Q:\\+|Q2|^\10[\14-\16]\10[\15-\17].\?.\?.\?.\?\$"
    add name=rdp regexp=rdpdr.*cliprdr.*rdpsnd
    add name=gnutella regexp="^(gnd[\01\02]\?.\?.\?\01|gnutella connect/[012]\\.[0-9]\r\
    \n|get /uri-res/n2r\\\?urn:sha1:|get /.*user-agent: (gtk-gnutella|bearshare|mactella|gnucleus|gnotella|limewire|imesh)|get /.*content-type: application/x-gnutella-packe\
    ts|giv [0-9]*:[0-9a-f]*/|queue [0-9a-f]* [1-9][0-9]\?[0-9]\?\\.[1-9][0-9]\?[0-9]\?\\.[1-9][0-9]\?[0-9]\?\\.[1-9][0-9]\?[0-9]\?:[1-9][0-9]\?[0-9]\?[0-9]\?|gnutella.*cont\
    ent-type: application/x-gnutella|...................\?lime)"
    add name=bittorrent regexp="^(\13bittorrent protocol|azver\01\$|get/scrape\\\?info_hash=)|d1:ad2:id20:|\08'7P\\)[RP]"
    add name=ares regexp="^\03[]Z].\?.\?\05\$"
    add name=fasttrack regexp="^get (/.download/[ -~]*|/.supernode[ -~]|/.status[ -~]|/.network[ -~]*|/.files|/.hash=[0-9a-f]*/[ -~]*) http/1.1|user-agent: kazaa|x-kazaa(-usern\
    ame|-network|-ip|-supernodeip|-xferid|-xferuid|tag)|^give [0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9]\?[0-9]\?[0-9]\?"
    add name=100bao regexp="^\01\01\05\
    \n"
    add name=torrent-wwws regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|\
    btbot|fenopy|gpirate|commonbits).*\$"
    add name=torrent-dns regexp="^.+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy\
    |gpirate|commonbits).*\$"

    2 –

    /ip firewall filter
    add action=drop chain=forward comment=p2p disabled=no layer7-protocol=ares
    add action=drop chain=forward disabled=no layer7-protocol=bittorrent
    add action=drop chain=forward disabled=no layer7-protocol=edonkey
    add action=drop chain=forward disabled=no layer7-protocol=counterstrike-source
    add action=drop chain=forward disabled=no layer7-protocol=100bao
    add action=drop chain=forward comment="block torrent wwws" disabled=no layer7-protocol=torrent-wwws
    add action=drop chain=forward comment="block torrent dns" disabled=no dst-port=53 layer7-protocol=torrent-dns protocol=udp


    3 -

    /ip firewall filter
    add chain=forward action=drop p2p=all-p2p comment="BLOQUEIO DO P2P"

  20. #20

    Angry Re: Problema com controle de banda na mikrotik

    Ola pessoal, tenho pouquíssima experiência com Mikrotik. Estou com uma RB 450g, servindo como gateway. Está com DHCP server ativado, e eu gostaria que cada máquina que recebeba um ip do DHCP server tenha 512 de down e 64 de up. Sem necessidade de hotspot ou IP amarrado ao MAC. Internet liberada, mas com velocidade limitada. Tentei no queue mas apenas consegui limitar a rede inteira fazendo com que os IP's comparilhassem a velocidade da rede. Alguém pode sugerir algo ? Grato