+ Responder ao Tópico



  1. #1

    Padrão Problema ao acessar api mikrotik

    Bom pessoal mais uma vez estou a procura de ajuda.

    Tenho um servidor slackware 11 instaldo com apache2.2+php 5.5 + postgresql 7.x, tudo instalado via compilação de codigo fonte.
    e tudo funciona perfeitamente, criei uma pasta no servidor apache e coloquei la o class api da mikrotik e criei uma pagina padrao chamada teste.php com o seguinte codigo que peguei no wiki da mikrotik:

    <?php require('routeros_api.class.php'); ?>
    <?php
    $API = new routeros_api();
    $API->debug = true;
    if ($API->connect('192.168.2.200', 'teste', 'teste')) {
    $API->write('/interface/getall');
    $READ = $API->read(false);
    $ARRAY = $API->parse_response($READ);
    print_r($ARRAY);
    $API->disconnect();
    }
    ?>

    nesse ip tenho uma routerboard 450G versão 6.0rc7, com /ip/services api ativado.

    quando executo o php -f teste.php ele para em
    <<< [6] /login
    >>> [5/5] bytes read.
    >>> [5, 39]!done
    >>> [37/37] bytes read.
    >>> [37, 1]=ret=ba113a4f3df29a6da28dd72c2e51bea0

    e nao sai, independentemente se coloco a senha correta ou a senha errada, ele fica parado ai, se coloco o ip errado ai sim da erro.

    pra tentar achar o problema coloquei os mesmos arquivos em um outro server com slackware+ mysql+php e a a surpresa o script funcionou sem problemas.

    resumindo acho que ta faltando alguma configuração no meu php ou apache que nao esta deixando eu executar a função, mas nao consegui achar onde comparei os arquivos de configuração dos 2 server e nao achei nada.

    será que alguem ja passou por isso ou tem alguma dica, não achei nada na internet.


    desde já agradeço a ajuda.

  2. #2

    Padrão Re: Problema ao acessar api mikrotik

    Esse script no outro server aponta para a mesma RB?
    Verifique se não há restrição de quem pode acessar (ip) na RB.



  3. #3

    Padrão Re: Problema ao acessar api mikrotik

    Bom agradeço mas resolvi o problema, o erro estava na versão do php, o php pra rodar a api tem que ser acima de 5.3


    Desde já agradeço a todos.