Quantcast
Como definir que um determinado site saia sempre pelo mesmo link no PCC

Visite: BR-Linux ·  VivaOLinux ·  LinuxSecurity ·  Dicas-L ·  NoticiasLinux ·  SoftwareLivre.org

+ Responder ao Tópico

  1. Amigos como posso definir um determinado site para sair sempre pelo mesmo link no pcc, pois estou tendo problemas com um cliente com um site que ao mudar de ip ele perde a conexão com o site.


  2.    Publicidade


  3. Citação Postado originalmente por NTurbo Ver Post
    Amigos como posso definir um determinado site para sair sempre pelo mesmo link no pcc, pois estou tendo problemas com um cliente com um site que ao mudar de ip ele perde a conexão com o site.
    Procure por loopback no balance!!

  4. Teste ai amigo

    /ip firewall layer7-protocol
    add name=ig regexp=ig.com.br


    /ip firewall filter
    add action=add-dst-to-address-list address-list=ig address-list-timeout=0s chain=forward disabled=no layer7-protocol=ig


    /ip firewall mangle
    add action=mark-routing chain=prerouting dst-address-list=ig new-routing-mark=ig passthrough=no

    ============================= OU



    Defina as rotas:


    /ip route add comment="Rota p/ Link Dedicado" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=dedicado scope=30 target-scope=10


    /ip route add comment="Rota p/ Link ADSL" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=adsl scope=30 target-scope=10


    Com as rotas criadas é só você direcionar os clientes para os links através do mangle:


    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=dedicado passthrough=no dst-address=ip do site


    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=adsl passthrough=no dst-address=ip do site


    Atenção: Não se esqueça de que é necessário deixar a rota padrão, e as regras do mangle devem preceder outras regras de redirecionamento.
    mude ai os ip dos gateway..

  5. Se der certo naum esqueça estrelinha garoto.. abraço

    Citação Postado originalmente por Samuelwduarte Ver Post
    Teste ai amigo

    /ip firewall layer7-protocol
    add name=ig regexp=ig.com.br


    /ip firewall filter
    add action=add-dst-to-address-list address-list=ig address-list-timeout=0s chain=forward disabled=no layer7-protocol=ig


    /ip firewall mangle
    add action=mark-routing chain=prerouting dst-address-list=ig new-routing-mark=ig passthrough=no

    ============================= OU



    Defina as rotas:


    /ip route add comment="Rota p/ Link Dedicado" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=dedicado scope=30 target-scope=10


    /ip route add comment="Rota p/ Link ADSL" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=adsl scope=30 target-scope=10


    Com as rotas criadas é só você direcionar os clientes para os links através do mangle:


    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=dedicado passthrough=no dst-address=ip do site


    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=adsl passthrough=no dst-address=ip do site


    Atenção: Não se esqueça de que é necessário deixar a rota padrão, e as regras do mangle devem preceder outras regras de redirecionamento.
    mude ai os ip dos gateway..


  6.    Publicidade




Tópicos Similares

  1. Respostas: 21
    Último Post: 02-12-2011, 11:03
  2. Respostas: 5
    Último Post: 26-11-2007, 04:11
  3. Respostas: 3
    Último Post: 14-01-2007, 23:27
  4. Decepção em um determinado site linux, SPAM!
    Por meraki no fórum Serviços
    Respostas: 6
    Último Post: 01-12-2005, 08:23
  5. Acesso somente a um determinado site
    Por MiddleEarth no fórum Serviços
    Respostas: 4
    Último Post: 21-02-2003, 08:18