Visite: BR-Linux ·  VivaOLinux ·  Dicas-L ·  SoftwareLivre.org


+ Responder ao Tópico

  1. #1
    Avatar de thiagokjf
    Data de Ingresso
    Jan 2011
    Localização
    rio de janeiro
    Posts
    22
    Reputação
    163

    Smile BGP Mikrotik

    Pessoal, preciso de um help, pois, meu conhecimento de BGP é muito fraco.

    Tenho 3 operadoras, ( operadora A, B e C), preciso fazer o seguinte:

    Declarar que a preferência de saída de uma rede /23 é pela operadora A outra na B e outra na C.

    ex: 10.10.26.0/23 tem preferência de saída pela operadora A
    10.10.28.0/23 tem preferência de saída pela operadora B
    10.10.30.0/23 tem preferência de saída pela operadora C

    Preciso muito mesmo dessa força, grato pela atenção de todos.


  2.    Publicidade


  3. #2
    Avatar de ixcsoft
    Data de Ingresso
    Jun 2012
    Localização
    São Lourenço do Oeste
    Posts
    96
    Reputação
    940

    Padrão Re: BGP Mikrotik

    acompanhando...

  4. #3

    Padrão Re: BGP Mikrotik

    Infelizmente não posso te ajudar nisto mas fica a dica. Não use mikrotik na borda possui muitos bugs com BGP que o pessoal não corrige deste a versão 4. Procure por bird em bsd e seja feliz.

  5. #4
    Avatar de wildes
    Data de Ingresso
    Jan 2007
    Localização
    Rio de Janeiro, Rio de Janeiro, Brazil
    Posts
    73
    Reputação
    352

    Padrão Re: BGP Mikrotik

    descordo com o amigo, sinto algumas deficiencias sim no mikrotik, mais com relação a algumas questões mais que são relevantes desde que voce nao administre muita banda, espero ter melhores referencias com este novo hardware, ccr 1036
    .
    mais respondendo sua pergunta, voce quer balancear anuncios entre duas operadoras .


    o primeiro passo é voce entender um pouco de como se funciona os filtros, vou esplicar de forma resumida .
    com os filtros voce manipula o formato de entrada e saida do seu roteador, mais todo efeito é correlacionado do que entra na caixa, e do que sai da caixa, ex .
    se voce colocar um filtro de entrada é possivel voce filtrar o que será anunciado na sua tabela fib .
    se voce colocar um filtro de saida voce manipula tudo que vai sair da sua tabela fib.
    dessa forma voce só manipula o download nao manipula o upload, e ja te digo que na forma que voce pediu voce perde a redundancia, se um cair ele somente vai cair e voce vai perder a rota .


    /routing bgp peer
    add address-families=ip as-override=no default-originate=never disabled=no \
    hold-time=3m in-filter="" instance=default multihop=no name=peer1 \
    nexthop-choice=default out-filter=operadoraAout passive=no \
    remote-address=1.1.1.1 remote-as=23456 remove-private-as=no \
    route-reflect=no tcp-md5-key="" ttl=default use-bfd=no
    add address-families=ip as-override=no default-originate=never disabled=no \
    hold-time=3m in-filter="" instance=default multihop=no name=peer2 \
    nexthop-choice=default out-filter=operadoraBout passive=no \
    remote-address=2.2.2.2 remote-as=23457 remove-private-as=no \
    route-reflect=no tcp-md5-key="" ttl=default use-bfd=no
    add address-families=ip as-override=no default-originate=never disabled=no \
    hold-time=3m in-filter="" instance=default multihop=no name=peer3 \
    nexthop-choice=default out-filter=operadoraCout passive=no \
    remote-address=3.3.3.3 remote-as=23458 remove-private-as=no \
    route-reflect=no tcp-md5-key="" ttl=default use-bfd=no

    agora os filtros .


    /routing filter
    add action=accept chain=operadoraAout disabled=no invert-match=no prefix=\
    10.10.26.0/23 set-bgp-prepend-path=""
    add action=discard chain=operadoraAout disabled=no invert-match=no \
    set-bgp-prepend-path=""
    add action=accept chain=operadoraBout disabled=no invert-match=no prefix=\
    10.10.28.0/23 set-bgp-prepend-path=""
    add action=discard chain=operadoraBout disabled=no invert-match=no \
    set-bgp-prepend-path=""
    add action=accept chain=operadoraCout disabled=no invert-match=no prefix=\
    10.10.30.0/23 set-bgp-prepend-path=""
    add action=discard chain=operadoraCout disabled=no invert-match=no \
    set-bgp-prepend-path=""

    porem da forma que o amigo pediu acima o amigo perde a redundancia .

    existe forma de engenharia de trafego da qual voce pode usar formas de manipular o download e upload sem perder a redundancia .


    mais vou deixar pra proxima vez porque hoje nao estou muito legal de saude . ou qualquer coisa me liga .

    ps . os comandos acima estao somente relacionados aos filtros, nao foram colocadas configuraçoes sobre a sessao bgp, os asn colocados só foram para dar exemplo .

    21 77808274
    wildes@netspeed.net.br

  6. #5

    Padrão Re: BGP Mikrotik

    Adquiri uma CCR-1016 para colocar meu BGP com as operadoras, como ja disseram, configura tudo certinho recebe e anuncia as rotas, mas os filters não funcionam direito na versão 6, existe muito bug no BGP, as interfaces não conversam facilmente com outros equipamentos.
    Ultimamente tenho ficado muito decepcionado com a Mikrotik, não adianta ter um equipamento maravilhoso em processamento se o software não ajudar..
    Entra e sai versão e as falhas principalmente em BGP e OSPF continuam

  7. #6
    Moderador Avatar de gamineiro
    Data de Ingresso
    Jan 2008
    Localização
    RS
    Posts
    416
    Posts de Blog
    2
    Reputação
    2571

    Padrão Re: BGP Mikrotik

    Bom dia,

    Com o exemplo do nosso amigo @wildes, você realmente não terá redundância, pois simplesmente está aceitando ou descartando o anúncio, não determinando a "preferência" como foi solicitado.

    Segue um exemplo onde você irá "piorar" as rotas por 2 operadoras, para que a preferência fiquei na terceira operadora:

    /route filters
    add action=accept chain=OUT-FILTERS-A prefix=200.200.1.0/21 prefix-length=21-24 set-bgp-prepend=3
    add action=accept chain=OUT-FILTERS-B prefix=200.200.1.0/21 prefix-length=21-24 set-bgp-prepend=3
    add action=accept chain=OUT-FILTERS-C prefix=200.200.1.0/21 prefix-length=21-24

    Esse filtro está adicionando 3 vezes o seu AS no AS-PATH da rota. Como o MENOR AS-PATH tem preferência no BGP, logo estamos "piorando" as rotas da operadora A e B.

    No terceiro filtro, não declaramos o atributo bgp-prepend, sendo assim, essa será a melhor rota.

    Todos esses filtros devem ser aplicados em OUT FILTER, na configuração do peer.

    OBS.: Outros filtros são necessários, seguindo as boas práticas do BGP, mas não foram abordados por não fazer parte do escopo do tópico.

    Boa sorte com os testes,

    Abraço

  8. #7
    Avatar de wildes
    Data de Ingresso
    Jan 2007
    Localização
    Rio de Janeiro, Rio de Janeiro, Brazil
    Posts
    73
    Reputação
    352

    Padrão Re: BGP Mikrotik

    desse mal eu nao passo mais .

    da uma olhada no meu album, foto tiradas do meu core do rio de janeiro .

    https://www.facebook.com/media/set/?...7262579&type=3

  9. #8
    Avatar de wildes
    Data de Ingresso
    Jan 2007
    Localização
    Rio de Janeiro, Rio de Janeiro, Brazil
    Posts
    73
    Reputação
    352

    Padrão Re: BGP Mikrotik

    o prepend só pra voce entender ele vai prolongar o seu salto de as .


    ou seja na tabela bgp ele vai replicar seu asn .. 23456, 23456, 23456, asn da operadora

    quando voce olhar no lg do bgp ele vai esta disposto dessa forma
    com isso voce vai almentar os saltos de asn, a tabela do bgp vai achar que voce esta mais distante,
    manipulando assim a escolha de menor rota aquela que tiver com o menor salto de aspath, ou seja a rota cujo filtro
    voce nao colocou prepend .
    alguns recursos sao ultilizados para manipular o upload entre elas local preference,weight .
    algumas sao recursivas e outras nao,
    no mikrotik é possivel fazer isso por filtro, no cisco por routemap, existem algumas limitaçoes entre um e outro, mais nao vem ao caso detalhar isso ja que sua pergunta é voltada somente para mikrotik .

  10. #9

    Padrão Re: BGP Mikrotik

    Estou em duvida sobre prefix length.
    vejo em alguns casos 21-32 e outros 23, e outros 21-22.

    O que seria o prefix-length ?


    Citação Postado originalmente por wildes Ver Post
    o prepend só pra voce entender ele vai prolongar o seu salto de as .


    ou seja na tabela bgp ele vai replicar seu asn .. 23456, 23456, 23456, asn da operadora

    quando voce olhar no lg do bgp ele vai esta disposto dessa forma
    com isso voce vai almentar os saltos de asn, a tabela do bgp vai achar que voce esta mais distante,
    manipulando assim a escolha de menor rota aquela que tiver com o menor salto de aspath, ou seja a rota cujo filtro
    voce nao colocou prepend .
    alguns recursos sao ultilizados para manipular o upload entre elas local preference,weight .
    algumas sao recursivas e outras nao,
    no mikrotik é possivel fazer isso por filtro, no cisco por routemap, existem algumas limitaçoes entre um e outro, mais nao vem ao caso detalhar isso ja que sua pergunta é voltada somente para mikrotik .

  11. #10
    Avatar de wildes
    Data de Ingresso
    Jan 2007
    Localização
    Rio de Janeiro, Rio de Janeiro, Brazil
    Posts
    73
    Reputação
    352

    Padrão Re: BGP Mikrotik

    Citação Postado originalmente por flon Ver Post
    Estou em duvida sobre prefix length.
    vejo em alguns casos 21-32 e outros 23, e outros 21-22.

    O que seria o prefix-length ?
    com relação aos filtros voce só tem que mentalizar que se refere tudo que a caixa vai receber e tudo que a caixa vai anunciar, e tem diversas formas de serem feitos, claro que o principio basico é voce conhecer bem de camada osi, o prefix length especifica a quantidade de bits ativos baseado na cidr que voce colocou, voce vai entender bem mesmo depois que voce pegar detonar a camada 3 do modelo osi, infelismente é nescessário voce ter expertize nessa matéria, na verdade meus caros amigos tudo relacionado a tabela de roteamento voce tem que ter um amplo conhecimento em camada 3, pois se não estudarem isso nunca vão compreender muita coisa relacionada ao bgp e tambem a outros protocolos de roteamento, no prefix length voce delimita a forma minima até a maxima de bits ativos baseada na cidr que esta sendo filtrado essa é a resposta mais correta e qualquer outro termo que fique fora disso esta incorreto .

  12. #11

    Padrão Re: BGP Mikrotik

    Citação Postado originalmente por wildes Ver Post
    com relação aos filtros voce só tem que mentalizar que se refere tudo que a caixa vai receber e tudo que a caixa vai anunciar, e tem diversas formas de serem feitos, claro que o principio basico é voce conhecer bem de camada osi, o prefix length especifica a quantidade de bits ativos baseado na cidr que voce colocou, voce vai entender bem mesmo depois que voce pegar detonar a camada 3 do modelo osi, infelismente é nescessário voce ter expertize nessa matéria, na verdade meus caros amigos tudo relacionado a tabela de roteamento voce tem que ter um amplo conhecimento em camada 3, pois se não estudarem isso nunca vão compreender muita coisa relacionada ao bgp e tambem a outros protocolos de roteamento, no prefix length voce delimita a forma minima até a maxima de bits ativos baseada na cidr que esta sendo filtrado essa é a resposta mais correta e qualquer outro termo que fique fora disso esta incorreto .

    Entendi.
    Obrigado


  13.    Publicidade




Tópicos Similares

  1. Mikrotik BGP IPv6
    Por islan no fórum Redes
    Respostas: 11
    Último Post: 16-07-2014, 14:52
  2. Mikrotik BGP Duvidas e Prepend
    Por msantoro no fórum Redes
    Respostas: 3
    Último Post: 18-05-2013, 17:50
  3. Configurando BGP no Mikrotik ROS
    Por fabriciodantas no fórum Redes
    Respostas: 1
    Último Post: 11-02-2012, 00:28
  4. BGP com Mikrotik.
    Por Gilmar no fórum Redes
    Respostas: 4
    Último Post: 11-04-2009, 15:39
  5. BGP com Mikrotik - AS, aguardo propostas.
    Por FEenuX no fórum Redes
    Respostas: 3
    Último Post: 03-02-2009, 13:12