Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Exclamation Rota estatica para repassar ip fixo para cliente

    Alguem sabe onde errei?

    Estou com a seguinte tarefa

    Router com OSPF ativado

    Crio os ips validos normalmente

    Gostaria de colocar um roteador cisco 1841 no cliente entregar um 1 /30 na Wan e 1 /29 na Lan

    Fiz a rota estática no router OSPF
    Router Ospf
    interface fa0/1.1020
    encaps dotq 1020
    ip addres 186.196.182.1 255.255.255.252
    ip ospf area 0
    ip ospf cost 1

    ip route 186.196.190.0 255.255.255.248 186.196.182.2

    Router cliente 1841
    Wan = 186.196.182.2 255.255.255.252

    Lan 186.196.190.1 255.255.255.248

    o pc que conecta na lan se comunica com os dois router mas não tem acesso externo e o router 1841 tem acesso externo, creio que falta algo nesta configuração mas não estou encontrando a solução

    poderia me ajudar?

  2. #2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Seria melhor vc usar BGP



  3. #3

    Arrow Re: Rota estatica para repassar ip fixo para cliente

    Na realidade minha topologia esta assim

    Router com BGP AS

    RODANDO OSPF PARA OUTROS DOIS SWITCHS LAYER3

    nesses switchs consigo criar qualquer range de ip valido

    a ideia é colocar um roteador em um cliente final e ele receber 1 ip valido na WAN 255.255.255.252 e na receber outro range com ip 255.255.255.248

    so que nao queria rodar OSPF NESSE CLIENTE FINAL, POIS ELE PODERIA QUEBRAR A SENHA E DESCOBRIR MINHA REDE, REGRAS ETC...

    alguem tem ideia de como prosseguir??

  4. #4

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Não conheço muito desse tipo de layout pois minha rede é bridge ainda, mas creio que com rotas estaticas vai.

    Só uma tentativa de lhe ajudar.

    Ivan Galves



  5. #5

    Angry Re: Rota estatica para repassar ip fixo para cliente

    O Problema é que eu ja fiz a rota estática.

    pelo router do cliente que é o 1841

    com o ip valido que configurei, consigo pingar o gateway da Wan do 1841

    mas não tem acesso para internet / externo .. alguem sabe oque esta faltando?

  6. #6
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Citação Postado originalmente por Leandro Galvao Ver Post
    Alguem sabe onde errei?
    Bom dia,

    Pelo que observei, você já corrigiu o problema? Poderia nos dizer o que estava errado?

    Abraço



  7. #7

    Angry Re: Rota estatica para repassar ip fixo para cliente

    Na realidade não corrigi, só consigo chegar até a gateway da WAN do router 1841, porem nao tem navegacao com a internet e nem acesso externo...

    ainda nao resolvi

  8. #8
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Bom dia,

    Eu consigo fazer um ping para o IP 186.196.190.2, porém com latência de 600ms e perde muitos pacotes.

    Você poderia fazer um desenho simples da sua topologia, colocando os IPs nas interfaces?

    Abraço



  9. #9

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Na realidade este endereco 186.196.190.2 não é do meu AS, foi só um exemplo de IP

    Na realidade, esta assim

    Router 2800 cisco fazendo BGP com a VIVO E OSPF para minha rede de clientes

    ROUTER DELL OSPF ativado consigo criar os RANGE DE IP REAL

    outro ROUTER DELL OSPF em um centro de distribuição proximo de MEU CORE

    tambem consigo criar os IPs VALIDOS TUDO COM OSPF ATÉ AQUI

    eu faria um enlace por Radio para o cliente e nesse cliente eu usaria um Router 1841 para ter gerencia desse Radio e do Router

    o cliente "1841" reberia 1 ip real /30 na porta FA0/0 e 5 IPs para uso na LAN que seria a porta FA0/1

    pois este cliente precisa de ip Valido.

    Só que nesse router do cliente 1841 eu não gostaria de ativar o OSPF, pois se ele quebrar a senha e ver meu script, ele pode usar um Range maior de IP, pois possuo um range com 4096 IPs.

    Existe a maneira de enviar esses IPs por rota estatica, ou POR OSPF mesmo, mais só permitindo a passagem dos ranges que eu desejar para este roteador 1841??

    Obrigado desde ja


    Citação Postado originalmente por gamineiro Ver Post
    Bom dia,

    Eu consigo fazer um ping para o IP 186.196.190.2, porém com latência de 600ms e perde muitos pacotes.

    Você poderia fazer um desenho simples da sua topologia, colocando os IPs nas interfaces?

    Abraço

  10. #10
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Entendi.

    Você precisa fazer uma rota estática para a rede do cliente, direcionada para a WAN do 1841.

    Para isso, verifique se você está distribuindo rotas estáticas no OSPF.

    Abraço



  11. #11

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    EM MEU CISCO 2800 ESTA CONFIGURADO
    router ospf 15
    router-id 186.xxx.xxx.xxx
    log-adjacency-changes
    redistribute connected
    redistribute static
    network 186.xxx.xxx.xxx 0.0.0.15 area 0
    default-information originate always
    distribute-list OSPFout out connected
    !

    Citação Postado originalmente por gamineiro Ver Post
    Entendi.

    Você precisa fazer uma rota estática para a rede do cliente, direcionada para a WAN do 1841.

    Para isso, verifique se você está distribuindo rotas estáticas no OSPF.

    Abraço

  12. #12
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Está OK.

    Mande a configuração do 1841 agora.



  13. #13

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    interface FastEthernet0/1
    ip address 186.1.2.1 255.255.255.252
    ip ospf cost 1
    ip ospf 16 area 0
    duplex auto
    speed auto
    !
    interface Serial0/1/0
    no ip address
    shutdown
    clock rate 2000000
    !
    router ospf 16
    router-id 186.xxx.xxx.xxx
    log-adjacency-changes
    network 186.xxx.xxx.xxx 0.0.0.15 area 0
    !
    ip forward-protocol nd
    ip route 186.1.1.0 255.255.255.248 186.1.2.2 aqui eu joguei a rota para que o range que passarei para o cliente sair para o ip da wan do router 1841


    1841

    WAN 186.1.2.2 255.255.255.252 fa0/0 conectado ao fa0/1 186.1.2.1
    ip route 0.0.0.0 0.0.0.0 186.1.1.1

    LAN fa0/1
    ip address 186.1.1.1 255.255.255.248



    Citação Postado originalmente por gamineiro Ver Post
    Está OK.

    Mande a configuração do 1841 agora.

  14. #14
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Citação Postado originalmente por Leandro Galvao Ver Post
    interface FastEthernet0/1
    ip address 186.1.2.1 255.255.255.252
    ip ospf cost 1
    ip ospf 16 area 0
    duplex auto
    speed auto
    !
    interface Serial0/1/0
    no ip address
    shutdown
    clock rate 2000000
    !
    router ospf 16
    router-id 186.xxx.xxx.xxx
    log-adjacency-changes
    network 186.xxx.xxx.xxx 0.0.0.15 area 0
    !
    ip forward-protocol nd
    ip route 186.1.1.0 255.255.255.248 186.1.2.2 aqui eu joguei a rota para que o range que passarei para o cliente sair para o ip da wan do router 1841


    1841

    WAN 186.1.2.2 255.255.255.252 fa0/0 conectado ao fa0/1 186.1.2.1
    ip route 0.0.0.0 0.0.0.0 186.1.1.1

    LAN fa0/1
    ip address 186.1.1.1 255.255.255.248
    Destaquei em vermelho o que está errado. O Gateway do 1841 tem que ser o IP da LAN do router em que ele está conectado.

    Veja se realmente está correto.



  15. #15

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Enviei os numeros errados ...

    a rota default estou colocando para o gateway da Wan do 1841 que por sua vez é o ip da lan do outro equipamento

    estou conseguindo pingar

    a LAN DO OUTRO ROUTER

    A WAN DO 1841

    MAIS NAO TEM ACESSO A INTERNET NA LAN DO 1841

    mais pelo terminal dentro do 1841 estou tendo acesso externo.


    Citação Postado originalmente por gamineiro Ver Post
    Destaquei em vermelho o que está errado. O Gateway do 1841 tem que ser o IP da LAN do router em que ele está conectado.

    Veja se realmente está correto.

  16. #16
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Então a rota estática não está sendo propagada para o Router de Borda, creio eu.

    Vejo se na FIB do Router BGP existe a rota para a rede do cliente. Caso não exista, crie ela manualmente para testar, apontando para o próximo router, que fica antes do 1841.



  17. #17

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Router de borda bgp ativado ospf

    1 switch layer 3 ospf ativado tambem

    router 1841 do cliente sem ospf

    crio a rota em todos os equipamentos ou somento no router de borda??

    Citação Postado originalmente por gamineiro Ver Post
    então a rota estática não está sendo propagada para o router de borda, creio eu.

    Vejo se na fib do router bgp existe a rota para a rede do cliente. Caso não exista, crie ela manualmente para testar, apontando para o próximo router, que fica antes do 1841.

  18. #18
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Citação Postado originalmente por Leandro Galvao Ver Post
    Router de borda bgp ativado ospf

    1 switch layer 3 ospf ativado tambem

    router 1841 do cliente sem ospf

    crio a rota em todos os equipamentos ou somento no router de borda??
    Tem que ir olhando na linha de roteamento, onde está faltando a rota. Comece pela lado do cliente, e vá indo em direção à borda.



  19. #19

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Consegui, colocando o redistribute static metric 200 subnets no roteador que esta conectado para o 1841 do cliente

    o 200 subnets seria oque na realidade?

    Obrigado pelo ajuda

    Citação Postado originalmente por gamineiro Ver Post
    Tem que ir olhando na linha de roteamento, onde está faltando a rota. Comece pela lado do cliente, e vá indo em direção à borda.

  20. #20
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Rota estatica para repassar ip fixo para cliente

    Que bom que conseguiu.

    Esse roteador seria o Switch Layer 3?

    Acredito que seja para ajustar as métricas.

    Abraço