+ Responder ao Tópico



  1. Galera,

    Bom dia!

    Possuo um ambiente com uma RB450G e 3 VDSLs da GVT. Gostaria de monitar quando a conexão do modem cair. Para isso criei um script que acompanha o status da interface. Para isso, renomiei a interface de pppout-01 para GVT01 e assim por diante. Mas estou com o seguinte problema. O script roda, mas não envia o e-mail.

    Outra coisa, gostaria de adicionar no corpo/body do e-mail a lista de interface/ips. Como faço?

    Segue o script informado:

    =-=-=-=-=-=-=-

    :global dia ([ick [/system clock get date] 4 6])
    :global mes ([ick [/system clock get date] 0 3])
    :global ano ([ick [/system clock get date] 7 11])
    :gl hora [/sys cl get time]
    :global rb [/system id get name]

    :log info "checando interface GVT03"
    /interface pppoe-client monitor GVT03 once do={
    :if ($status != "connected") do={
    :log info "LINK GVT03 DOWN - $rb - $dia-$mes-$ano-$hora"
    /tool e-mail send from="email@email.com" to="email@email.com" subject="Host: $rb - LINK GVT03 DOWN - $dia-$mes-$ano-$hora" tls=yes
    }
    }

    Fico no aguardo de sugestões!

    Att

    Rodrigo Gomes

  2. Citação Postado originalmente por roliveiragomes Ver Post
    Galera,

    Bom dia!

    Possuo um ambiente com uma RB450G e 3 VDSLs da GVT. Gostaria de monitar quando a conexão do modem cair. Para isso criei um script que acompanha o status da interface. Para isso, renomiei a interface de pppout-01 para GVT01 e assim por diante. Mas estou com o seguinte problema. O script roda, mas não envia o e-mail.

    Outra coisa, gostaria de adicionar no corpo/body do e-mail a lista de interface/ips. Como faço?

    Segue o script informado:

    =-=-=-=-=-=-=-

    :global dia ([ick [/system clock get date] 4 6])
    :global mes ([ick [/system clock get date] 0 3])
    :global ano ([ick [/system clock get date] 7 11])
    :gl hora [/sys cl get time]
    :global rb [/system id get name]

    :log info "checando interface GVT03"
    /interface pppoe-client monitor GVT03 once do={
    :if ($status != "connected") do={
    :log info "LINK GVT03 DOWN - $rb - $dia-$mes-$ano-$hora"
    /tool e-mail send from="email@email.com" to="email@email.com" subject="Host: $rb - LINK GVT03 DOWN - $dia-$mes-$ano-$hora" tls=yes
    }
    }

    Fico no aguardo de sugestões!

    Att

    Rodrigo Gomes
    Tenho um link GVT e outro 3g, meu failover funciona pelo Route, com distancia 1 para GVT e 2 para 3g.
    O monitoramento é feito com os seguintes scripts:

    pingpppoe:

    # Armazena nas variaveis o estado de cada link
    :local a ([/ping 8.8.8.8 count=1 interface=pppoe-out1]=1);
    :if ($a =true) do={log info "Verificando Links GVT: link GVT Ativo";/system scheduler disable ping-pppoe;/system scheduler enable ping-3g;/tool e-mail send to="fulano@fulano.com.br" body="GVT Ativo" subject="Atenção: Usando Internet GVT" tls=yes}


    ping3G

    # Armazena nas variaveis o estado de cada link
    :local b ([/ping 8.8.8.8 count=1 interface=ether1]=1);
    :if ($b =true) do={log info "Verificando Links 3G: Ling 3G Ativo";/system scheduler enable ping-pppoe;/system scheduler disable ping-3g;/tool e-mail send to="fulano@fulano.com.br" body="3G Ativo" subject="Atenção: Usando Internet 3G" tls=yes}

    No schedule esses scripts rodam a cada 5 minutos, mas observe que um desativa o outro, para que não fique mandando email a todo momento e sim quando houver alteração nos links.
    Talvez possa adaptar para sua necessidade.






Tópicos Similares

  1. Respostas: 78
    Último Post: 06-05-2017, 08:23
  2. Script Failover - PCC
    Por roliveiragomes no fórum Redes
    Respostas: 9
    Último Post: 17-08-2015, 05:19
  3. Respostas: 4
    Último Post: 26-06-2015, 09:17
  4. Respostas: 2
    Último Post: 26-11-2014, 20:31
  5. problemas com conexão pppoe
    Por studioweb no fórum Servidores de Rede
    Respostas: 10
    Último Post: 05-07-2007, 17:15

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L