+ Responder ao Tópico



  1. Boa noite caros amigos.

    Peço desculpas pelo o assunto não ser 100 porcento mikrotik, mas acredito que tem gente aqui que pode me ajudar pois já trabalharam com isso mesmo não tendo muito a ver com o Mikrotik.


    É o seguinte, estou desenvolvendo uma aplicação para o gerenciamento do mikrotik e clientes em Delphi.
    Eu estou usando comunicação API, até ai sem problemas. Só que preciso gerar gráficos em tempo real dos usuários, logo tenho que ir pro SNMP.
    Aqui que entra a parte OFF, com o Mikrotik não há problemas, em sofwares consigo navegar pelo mikrotik acessando as MIBS/OIDS e obtendo os valores que quero. Até ai perfeito.
    Eu estou desenvolvendo no Delphi 2010, tentei usar dois componentes. O indy e o pacote Synapse.
    Ambos consigo conectar e fazer gráficos de interface dentre outras coisas entrando via API e printando os valores referentes a OID.
    Só que o problema está justamente os valores bytes-in / out da simple queues, os valores que são retornados não correspondem a realidade. Quando tento obter esses dados é me retornado caracteres estranhos.
    E repetindo, isso só acontece com os bytes-in e out do simple queue, o resto funciona normalmente.
    Pesquisei muito sobre o assunto, cheguei ao ponto de ler documentações em Vietnamita (que acredite se quiser, do google inteiro, foi o que mais me ajudou mesmo).
    Já vi vários projetos aqui no forum em delphi, então imagino que alguns possam saber o que pode está acontecendo.

    (foto abaixo com o próprio demo do synapse)
    Clique na imagem para uma versão maior

Nome:	         TESTEE.jpg
Visualizações:	151
Tamanho: 	73,2 KB
ID:      	43367
    Tentei ver com o pessoal que meche com delphi, mas não tive muito sucesso pois é mais voltado a parte de redes.
    Desde já muito grato.


    ------------------------------------------------------
    RESOLVIDO: Os componentes não suportam o tipo de dado Counter64. A solução foi decodificar de ASN1 pra INT64.
    Última edição por GNTptc; 15-03-2013 às 12:01.

  2. Olá GNTptc bom dia, procure pegar o retorno pelo linux e veja se o mesmo ocorre.
    Isso te ajudaria a identificar onde estaria o problema de fato.



  3. Citação Postado originalmente por GNTptc Ver Post
    Boa noite caros amigos.

    Peço desculpas pelo o assunto não ser 100 porcento mikrotik, mas acredito que tem gente aqui que pode me ajudar pois já trabalharam com isso mesmo não tendo muito a ver com o Mikrotik.


    É o seguinte, estou desenvolvendo uma aplicação para o gerenciamento do mikrotik e clientes em Delphi.
    Eu estou usando comunicação API, até ai sem problemas. Só que preciso gerar gráficos em tempo real dos usuários, logo tenho que ir pro SNMP.

    já procurei muito isso tb e não conseguir descobrir o que significa esses caracteres...

  4. Então, quero primeiramente agradecer o interesse dos amigos em ajudar, alem da rapidez.
    Mas finalmente depois de longas semanas e buscas no google em tudo que é idioma descobri o que era.

    Citação Postado originalmente por minelli Ver Post
    Olá GNTptc bom dia, procure pegar o retorno pelo linux e veja se o mesmo ocorre.
    Isso te ajudaria a identificar onde estaria o problema de fato.
    Obrigado pela sugestão, eu tinha feito teste em outros softwares e linux e o retorno tava normal.

    Citação Postado originalmente por pedrovigia Ver Post
    já procurei muito isso tb e não conseguir descobrir o que significa esses caracteres...
    O problema é praticamente do Delphi e os componentes.
    Acontece que tanto o Indy quanto o Synapse retorna o valor em codificação ASN quando na verdade deveria retornar em Int64 (counter64)
    Lembrando que o Bytes-in e out são justamente dados desse tipo. E também que Counter64 é apenas compativel com SNMP V2 e 3.

    Mas mesmo os dois componentes suportando SNMP V2 e 3 os dados desse tipo não são suportados nativamente como eu constatei.
    Minha solução pra isso foi DECODIFICAR byte por byte da resposta transformando em Int64.

    Se alguém precisar da rotina de decodificação é só mandar MP.

    Assunto resolvido.



  5. Bom que achou a solução estando o tópico resolvido então irei fecha-lo.






Tópicos Similares

  1. Gerenciando Clientes com Simple Queue + PCQ
    Por mayconff22 no fórum Mikrotik
    Respostas: 4
    Último Post: 28-02-2016, 00:12
  2. Por favor ajudem problema com ppoe/queues
    Por eduardonwt no fórum Redes
    Respostas: 4
    Último Post: 21-11-2014, 14:31
  3. Problema na Simple Queues
    Por eijiyasue no fórum Redes
    Respostas: 5
    Último Post: 24-09-2012, 12:57
  4. Problemas no simple queues
    Por virtuainf no fórum Redes
    Respostas: 4
    Último Post: 11-02-2009, 13:34
  5. Respostas: 4
    Último Post: 07-07-2008, 16:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L