Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Passo a Passo
    Mikrotik e ThunderCache em Paralelo

    Usaremos seguinte conf.
    No ThunderCache
    IP Address = 192.168.2.240
    Subnet Mask = 255.255.255.0
    Default Router = 192.168.2.1

    No Mikrotik
    Interface ligada ao Thunder = ether2
    IP da ether2 = 192.168.2.1/24
    Interface ligada ao Link = ether1
    Interface ligada aos Clientes = ether3
    Range de IP dos Clientes = 10.0.0.0/8


    1° Passo
    Marcar os pacotes que serão enviados para o cache.

    /ip firewall mangle
    add action=mark-routing chain=prerouting src-address=10.0.0.0/8 dst-address-list=!Site_fora_do_cache src-address-list=!Cliente_fora_do_cache in-interface=!ether2 comment=THUNDER disabled=yes protocol=tcp dst-port=80 new-routing-mark=to_cache passthrough=yes


    2° Passo
    Criar a rota que enviará os pacotes marcados ao Thunder

    /ip route
    add comment=ROTA-THUNDER disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.240 routing-mark=to_cache scope=30 target-scope=10


    3° Passo
    Iremos aqui criar duas listas.
    A dos clientes que não passarão pelo cache e a dos sites que será entregue ao cliente sem passar pelo cache.

    /ip firewall address-list
    add address=192.168.2.240 list=Cliente_fora_do_cache comment="Cliente Fora do Cache" disabled=no
    add address=192.168.2.240 list=Site_fora_do_cache comment="Site Fora do Cache" disabled=no


    4° Passo
    Redirecionando porta para acesso externo ao servidor ThunderCache, e criando uma nat de saída.

    /ip firewall nat
    add action=dst-nat chain=dstnat dst-port=2200 protocol=tcp to-addresses=192.168.2.240 to-ports=22 comment=SSH_Thunder disabled=no
    add action=dst-nat chain=dstnat dst-port=82 protocol=tcp to-addresses=192.168.2.240 to-ports=82 comment=WEBADMIN_Thunder disabled=no
    add action=masquerade chain=srcnat out-interface=ether1 src-address=192.168.2.0/24 comment="NAT_Thunder" disabled=no


    Opcional
    Seu Mikrotik pode ser o servidor dns do Thunder e de seus Clientes, basta aponta-los para o ip de seu Mikrotik e executar esse comando para ativar o recurso.

    /ip dns set servers=8.8.8.8,8.8.4.4 cache-size=4096 allow-remote-requests=yes



    Configuração do Thunder.
    Após todos redirecionamentos e configuração do mikrotik, vamos a alguns detalhes que são necessários para que seu Thunder possa responder as requisições vindas de seus clientes.

    Configuração de Rede > Configuração IP
    o ponto importante nessa configuração é o dns, pois IPs você já configurou na instalação e pode remover o dns e adicionar um novo. É muito importante que todos clientes e inclusive seu thunder, aponte para o mesmo dns, sugiro que utilize um servidor interno, ou até mesmo o próprio thunder ou a RB de Borda para clientes com pouca requisições.

    Configuração de Rede > Firewall
    Vejo muita gente fazer essa parte errada. Aqui você vai colocar o range de ips que entrega a seus clientes, ou seja, 10.0.0.0/8 ou 192.168.0.0/16 ou 172.16.0.0/12, lembre-se qualquer ip que não esteja nesses tres range que citei, são publicos, então só utilize se realmente a operadora lhes forneceu. E caso isso aconteça, você deverá configurar em modo TProxy, "não falerei sobre ele, hoje".

    Gerenciamento de Discos
    Recomendo que utilize HDs de 1TB SATA III com 64MB de Buffer e 7200 RPM e também que sejam do mesmo tamanho. Atenção jamais utilize HD de 5400 RPM, seja qual for!
    Formate e monte seus discos.
    Fique atento aos avisos e monitoramento de seus HDs, e habilite na BIOS o suporte AHCI, isso vai melhorar o desempenho de seu HD.

    Monitoramento > Arquivos de Log
    Não deixe de acompanhar seus logs, muitos problemas de HD pode ser vistos aqui, e claro muitos outros erros.

    ThunderCache > Licença do ThunderCache
    Aqui você vai entrar em contato com um dos parceiros para adquirir sua licença, caso queira contratar comigo, me e-mail é fariasbsd@gmail.com

    Reinicie seu servidor e mantenha-o sempre atualizado.

  2. Muito boa sua explicação! Nem mesmo o pessoal desenvolvedor do thunder tem uma explicação tão bem elaborada!
    Obrigado!



  3. MUITO BOA EXPLICAÇÃO, PARABENS!

    Porem uma duvida para leigos, ThunderCache é um concorrente do Squid, certo ? ou seja, na minha rede, tenho de escolher um ou o outro, correto ? ou eles tem papeis de cache diferente, fazendo ser possivel ter os 2 em rede e funcionando juntos ?

    grato.

  4. Citação Postado originalmente por 2fast4youbr Ver Post
    MUITO BOA EXPLICAÇÃO, PARABENS!

    Porem uma duvida para leigos, ThunderCache é um concorrente do Squid, certo ? ou seja, na minha rede, tenho de escolher um ou o outro, correto ? ou eles tem papeis de cache diferente, fazendo ser possivel ter os 2 em rede e funcionando juntos ?

    grato.

    Não posso dizer concorrente por que Squid é um projeto open source.
    Já Thunder é outro projeto, é um sistema pago.

    O Thunder fará todo cache, pois é muito mais robusto e funcional, você pode quebrar um galho com squid mas cache mesmo é com Thunder.



  5. Bom dia pessoal,


    Recentemente com intenção de agilizar meu trabalho e facilitar a vida de muitos iniciantes e experientes também, criei uma ferramenta que gera as regras utilizadas no mikrotik para uso do ThunderCache em paralelo.


    Conto com as sugestões de todos que acharem interessante, assim podemos aprimorar mais a ferramenta, inserindo cada vez mais recursos.


    Acessem pelo link abaixo
    http://goo.gl/e2pZn




    Espero que seja útil, até mais....






Tópicos Similares

  1. Respostas: 132
    Último Post: 30-06-2009, 23:17
  2. Respostas: 15
    Último Post: 07-05-2009, 10:29
  3. Respostas: 3
    Último Post: 26-10-2008, 11:01
  4. Proxy em paralelo com Mikrotik
    Por juderlan no fórum Redes
    Respostas: 13
    Último Post: 13-07-2008, 11:53
  5. Proxy em paralelo com o mikrotik
    Por diegovilela01 no fórum Redes
    Respostas: 29
    Último Post: 24-06-2008, 23:50

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L