Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21
    Deus acima de tudo!
    Ingresso
    Jul 2009
    Localização
    Paulista - Pernambuco
    Posts
    414

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    Aqui funcionou perfeitamente

  2. #22

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    Citação Postado originalmente por flaviolrf Ver Post
    Prezados,

    Após muita leitura sobre o assunto e inúmeras tentativas, cheguei a uma configuração de firewall capaz de bloquear (até o momento) a utilização de Ultrasurf na rede com eficiência. Segue:

    1. Criei uma Address List (UltraSurfServers) com 2 das faixas de IP`s mais utilizadas pelo Ultrasurf.

    /ip firewall address-list

    add address=65.49.0.0/17 disabled=no list=UltraSurfServers
    add address=204.107.140.0/24 disabled=no list=UltraSurfServers

    2. Detectei IP`s da rede interna que tentaram realizar algum tipo de conexão com essas faixas, e adicionei esses IP`s numa nova Address List (UltraSurfUsers) por 5min.

    /ip firewall mangle
    add action=add-src-to-address-list address-list=UltraSurfUsers \
    address-list-timeout=5m chain=prerouting comment=UltraSurfUsers disabled=\
    no dst-address-list=UltraSurfServers in-interface=Interface-LAN

    3. Criei mais uma Address List (UltraSurfProxies) e passei a adicionar nela, também por 5min, todos os IP`s destino que as máquinas listadas em UltraSurfUsers tentaram acessar.

    /ip firewall mangle
    add action=add-dst-to-address-list address-list=UltraSurfProxies \
    address-list-timeout=5m chain=prerouting comment=UltraSurfProxies \
    disabled=no in-interface=Interface-LAN src-address-list=UltraSurfUsers

    4. Marquei todas as conexões realizadas entre UltraSurfUsers e UltraSurfProxies com porta diferente de 80.

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=UltraSurf disabled=no \
    dst-address-list=UltraSurfProxies new-connection-mark=UltraSurf \
    passthrough=yes port=!80 protocol=tcp src-address-list=UltraSurfUsers

    5. Passei então a marcar todos os pacotes trafegados nessas conexões.

    /ip firewall mangle
    add action=mark-packet chain=prerouting connection-mark=UltraSurf disabled=no \
    new-packet-mark=Ultrasurf passthrough=yes

    6. Realizei o bloqueio desses pacotes na rede.

    /ip firewall filter
    add action=drop chain=forward comment=Bloq_Ultrasurf disabled=no packet-mark=Ultrasurf

    --------------//--------------

    O aplicativo (Ultrasurf) até consegue se conectar com seus servers, mas assim que o usuário começa a navegar, as regras entram em ação e ele perde a navegação. Fechando o aplicativo (UltraSurf), tudo volta ao normal para o usuário após 5min.

    Espero ter ajudado.
    http://wiki.mikrotik.com/wiki/How_to...rogram_traffic

    Esse método não funciona legal com a ultima versão (do ultrasurf, não do mikrotik), só com as antigas.



  3. #23
    Deus acima de tudo!
    Ingresso
    Jul 2009
    Localização
    Paulista - Pernambuco
    Posts
    414

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    Citação Postado originalmente por int21 Ver Post
    http://wiki.mikrotik.com/wiki/How_to...rogram_traffic

    Esse método não funciona legal com a ultima versão, só com as antigas.
    Aqui roda na v5.26 em uma RB750

  4. #24

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    Não funfa com a versão u1405



  5. #25

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    Eu simplifiquei a regra. E agora funciona com qualquer versão, seja do MK, seja do Ultrasurf.

    Primeiramente eu criei uma address-list contendo 2 das principais faixas de IP utilizadas pelo Ultrasurf. Independentemente dele poder utilizar infinitos IP`s, ele sempre consulta essas faixas. Então quando essas faixa são consultadas, eu já sei que ele foi ativado na rede.

    /ip firewall address-list
    add address=204.107.140.0/24 comment=UltraSurf list=UltraSurfServers
    add address=65.49.0.0/17 comment=UltraSurf list=UltraSurfServers

    Em seguida eu identifico o computador da rede que abriu o ultrasurf e coloco ele numa address list dinâmica com por 5min.


    /ip firewall mangle
    add action=add-src-to-address-list address-list=UltraSurfUsers \
    address-list-timeout=5m chain=prerouting comment=\
    "Ultrasurf Users na Rede" dst-address-list=UltraSurfServers \
    in-interface=Interface-RedeInterna src-address-list="!DNS Servers"


    Agora bloqueio todo mundo que foi inserido na address-list dinâmica


    /ip firewall filter
    add action=drop chain=forward comment="Ultrasurf na Rede" \
    in-interface=Interface-RedeInterna src-address-list=UltraSurfUsers

    Resumindo, quem abrir o ultrasurf fica sem conexão. Após fechar o Ultrasurf, a conexão é reestabelecida automaticamente após 5min. Se o usuário não fechar o Ultrasurf, ele é re-inserido na address-lit dinâmica por mais 5min, e assim por diante até que ele feche o Ultrasurf.

  6. #26

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    Para os adeptos do Ctrl+c Ctrl +v , Tirem "in-interface=Interface-RedeInterna" ou substitua pelo nome da sua interface ^^'

    Flavio Obrigado por compartilhar , nem sei se tenho clientes que utilizam deste aplicativo , vou monitorar a partir de agora



  7. #27

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    Cara funciona em partes @flaviolrf nos teste que eu fiz só amenizou melhor que nada, fiz uns testes mais avançados e eu consegui bular.

  8. #28

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    Pode citar os testes que fez @wld.net1? Nas redes que administro funciona sem falhas.

    Uma coisa que não comentei foi "src-address-list="!DNS Servers". Eu tenho uma address-lis chamada DNS Servers contendo os IP`s dos servidores DNS (internos) da rede. Isso evita que o servidor DNS da rede seja bloqueado, já que ele fará a consulta.



  9. #29

    Padrão Re: Bloqueio de UltraSurf via Mikrotik (funcionando)

    testa essa ai

    /ip firewall filter
    add action=drop chain=forward comment="Block UltraSurf" disabled=no dst-port=443 protocol=tcp src-address-list=UltraSurfUsers

    /ip firewall mangle
    add action=add-src-to-address-list address-list=UltraSurfUsers address-list-timeout=1d chain=prerouting comment="UltraSurfUsers" disabled=no dst-address-list=UltraSurfServers dst-port=443 protocol=tcp

    /ip firewall address-list
    add address=65.49.0.0/17 comment="" disabled=no list=UltraSurfServers
    add address=204.107.140.0/24 comment="" disabled=no list=UltraSurfServers

    /ip firewall filter
    add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.194.50 dst-port=53 protocol=tcp
    add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.194.50 dst-port=53 protocol=udp
    add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.192.50 dst-port=53 protocol=tcp
    add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.192.50 dst-port=53 protocol=udp
    add action=drop chain=forward comment=DNS disabled=no dst-port=53 protocol=tcp
    add action=drop chain=forward comment=DNS disabled=no dst-port=53 protocol=udp