+ Responder ao Tópico



  1. #1

    Padrão Problema de dns com cliente wisp e servidor mk hotspot

    Amigos, de um tempo pra ca tenho visto um problema um tanto quanto estranho, clientes ligão reclamando que seus computadores estão aparecendo um erro com DNS, outros navegão as vezes e as vezes não, na casa deles uso ap configurado como cliente wisp, com o ip setado a ele no servidor, dns e tudo blz. Meu servidor tem dns-cache do mikrotik mesmo, o meio de autenticação é via hotspot.
    O chato do negocio é que pra resolver o problema temos que colocar o dns do servidor dns-cache na placa de rede do cliente, e pronto, funciona tudo normal.

    Desde já obrigado.

  2. #2

    Padrão Re: Problema de dns com cliente wisp e servidor mk hotspot

    Amigo estava com esse problema tb, atualizei pra versão acima de 5.20 e parou ( ou raramente acontece). Eu uso outra forma; em pront no windows , digito ipconfig /all flushdns, e volta a funcionar. Assim o cliente mesmo pode efetuar ou se preferir use ele ai, bastando executar.
    Sucesso ai... Flushdns.zip

    Fonte do Comando: Outro usuário desse Forun.



  3. #3

    Padrão Re: Problema de dns com cliente wisp e servidor mk hotspot

    Aqui tive esse mesmo lance após uma queda dos dns a operadora e pra não sair de liente em cliente criei um dhcp e pronto.. cliente pega ip automático e recebe como dns primário o ip do servidor mikrotik

  4. #4

    Thumbs up Re: Problema de dns com cliente wisp e servidor mk hotspot

    Citação Postado originalmente por maxibelo Ver Post
    Amigo estava com esse problema tb, atualizei pra versão acima de 5.20 e parou ( ou raramente acontece). Eu uso outra forma; em pront no windows , digito ipconfig /all flushdns, e volta a funcionar. Assim o cliente mesmo pode efetuar ou se preferir use ele ai, bastando executar.
    Sucesso ai... Flushdns.zip

    Fonte do Comando: Outro usuário desse Forun.
    Então Maxibelo, o fato é que minha rb 1100 que trabalha como servidor ja esta com a ultima versão a 5.24, atualizei pra ver se resolvia o problema, e não resolveu, estranho ne. No radio do cliente esta setado os dns do servidor, cheguei ate a setar dns externos pra ver se resolvia, mas não resolve, tem que por o dns na placa de rede do cliente.

    - - - Atualizado - - -

    Citação Postado originalmente por BitPC Ver Post
    Aqui tive esse mesmo lance após uma queda dos dns a operadora e pra não sair de liente em cliente criei um dhcp e pronto.. cliente pega ip automático e recebe como dns primário o ip do servidor mikrotik
    Obrigado pela dica, mas aqui não posso usar dhcp, a rede ta grande, e ja tive problemas com isto no passado



  5. #5

    Padrão Re: Problema de dns com cliente wisp e servidor mk hotspot

    Netuai, aqui sofri uns 6 meses com esse problema. Procurei em tudo que é lugar uma solução pra isso. Ajustei MTU, MSS, adicionei regras, alterei configurações em rádios dos clientes, enfim: nada funcionou!


    Até que graças a Deus, achei o problema e tenho certeza que vai funcionar com você. O problema está no DNS! Você vai pensar, já alterei o DNS e não resolveu. Pois é, mas agora vai resolver! Faça o seguinte:


    Altere os DNS's do cliente manualmente para os DNS da Google: 8.8.8.8 e 8.8.4.4


    Em seguida, ainda no computador do cliente, vá em Iniciar e Executar e digite ipconfig /flushdns
    Vai aparecer rapidamente uma tela preta (DOS) e fechar em seguida. Isso elimina o cache de DNS do computador do usuário.


    Abra o navegador do cliente e exclua todo o histórico de navegação, incluindo o cache do navegador. Em seguida, feche o navegador e abra ele novamente.


    PRONTO! Facebook, orkut, yahoo, youtube, tudo funcionando 100%!


    Mas porque isso ocorre? Vamos a explicação: O que acontece é que quando usamos rádios e cpes, e eles estão roteados, a maioria desses aparelhos informa ao computador do usuário através do servidor DHCP, o DNS primário como sendo o próprio rádio, por exemplo: 192.168.0.1.


    Até aí não há problema, desde que o rádio funcione bem como servidor DNS. O problema é que ele NÃO FUNCIONA BEM como servidor DNS e por essa razão algumas páginas não abrem corretamente.


    Isto não ocorre com adaptadores USB's e placas PCI's, pois o servidor DHCP nesses casos será o próprio Mikrotik ou algum outro configurado por você na sua rede, afinal, não há como rotear adaptadores USB's e placas PCI's.


    Uma solução melhor do que alterar manualmente o DNS no computador do usuário é configurar o servidor DHCP do rádio do cliente para informar outros DNS's que não sejam o do gateway, ou seja, ele próprio. Como fazer isso?


    Acesse o rádio do cliente, e no menu Configurações TCP/IP -> Interface WAN, defina os DNS's manualmente, usando os do Google (8.8.8.8 e 8.8.4.4) ou outros de sua preferencia. Não se esqueça de aplicar as configurações. É óbvio que os menus podem ter outros nomes, pois isso varia de rádio para rádio, mas na sua grande maioria essa opção fica onde disse acima.


    Depois, execute o ipconfig /flushdns e exclua o cache do navegador no computador do cliente para que o problema seja definitivamente solucionado.


    Enfim, teste e terá uma grata surpresa! Espero que tenha ajudado!


    Abraços,
    Jonas Lima