Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Bloquear sites e enviar aviso de site bloqueado e possível?

    Olá amigos do under gostaria de bloquear alguns sites usando o firewall do mikrotik e enviar mensagem de acesso negado, to bloqueando sites pelo layer7 só que quando tento acessar o site da pagina não encontrada e toda hora um me fala que ta sem internet o controle e feito por ip e mac e só na empresa msm teria como eu colocar para aparecer essa mensagem?
    Clique na imagem para uma versão maior

Nome:	         errologin.jpg
Visualizações:	10139
Tamanho: 	106,1 KB
ID:      	43629
    Gostaria da ajuda de todos vocês

  2. #2

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Olha possível é porém vc vai ter que arranjar um servidor web á parte, pra fazer isso, disso não tem escapatória rsrs.



  3. #3

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por hodesanionetx Ver Post
    Olha possível é porém vc vai ter que arranjar um servidor web á parte, pra fazer isso, disso não tem escapatória rsrs.
    serto o imageshark ou o imagebam não dá? vc tem um tutorial de como fazer isso pra me passar por gentileza?

  4. #4
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Parceiro, o que nosso amigo Pegazus falou é que você vai ter que montar um servidor de proxy para monitorar e filtrar todos acesso que passar. Vejo o pessoal indicar muito o squid, procure aqui mesmo no forum sobre proxy e bloqueio de sites que vai achar um monte material... No MK você pode até bloquear pelo filter, mas não tem como enviar a página informando esse bloqueio ou pelo menos nunca vi ninguém fazer isso. Boa Sorte!



  5. #5

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por paullsoftware Ver Post
    Parceiro, o que nosso amigo Pegazus falou é que você vai ter que montar um servidor de proxy para monitorar e filtrar todos acesso que passar. Vejo o pessoal indicar muito o squid, procure aqui mesmo no forum sobre proxy e bloqueio de sites que vai achar um monte material... No MK você pode até bloquear pelo filter, mas não tem como enviar a página informando esse bloqueio ou pelo menos nunca vi ninguém fazer isso. Boa Sorte!
    atá intendi vlw pela força vcs dois vou dar uma vasculhada.

  6. #6

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por claudinhohw Ver Post
    Olá amigos do under gostaria de bloquear alguns sites usando o firewall do mikrotik e enviar mensagem de acesso negado, to bloqueando sites pelo layer7 só que quando tento acessar o site da pagina não encontrada e toda hora um me fala que ta sem internet o controle e feito por ip e mac e só na empresa msm teria como eu colocar para aparecer essa mensagem?
    Clique na imagem para uma versão maior

Nome:	         errologin.jpg
Visualizações:	10139
Tamanho: 	106,1 KB
ID:      	43629
    Gostaria da ajuda de todos vocês
    1 configurar web-proxy.
    2 criar uma lista com tudo que pode e nao pode e quem pode
    3 criar um regra nat de redirecionar todas as portas de todos ips que estara no address list com nome de blqueado para a porta do proxy
    4 criar uma lista de ip com nome de bloqueado no address list do nat
    5 adicionar as permiçoes no access do proxy, podera redirecionar cada usuario para uma pagina que podera conter algum tipo de aviso escrito para que possa entender que esta agindo de forma incorreta e que esta sendo monitorado.
    regras abaixo para proxy funcionar
    #
    /ip firewall nat
    add action=redirect chain=dstnat comment="webproxy pppoe" disabled=no dst-port=80 in-interface=ether2 protocol=tcp src-address=192.168.6.0/24 to-ports=8080
    add action=redirect chain=dstnat comment="webproxy hotspot" disabled=no dst-port=80 in-interface=ether2 protocol=tcp src-address=10.5.50.0/24 to-ports=8080
    add action=redirect chain=dstnat comment="redireciona todas as portas para proxy" disabled=no protocol=tcp src-address-list=bloqueado to-ports=8080
    add action=masquerade chain=srcnat comment="masquerade pppoe" disabled=no src-address=192.168.6.0/24 to-addresses=0.0.0.0
    add action=masquerade chain=srcnat comment="masquerade hotspot" disabled=no src-address=10.5.50.0/24 to-addresses=0.0.0.0
    #
    /ip firewall address-list
    add address=192.168.1.20 comment=jose disabled=no list=bloqueado
    #
    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 \
    serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=allow disabled=no dst-host=www.bylltec.com.br dst-port=""
    add action=deny comment=jose disabled=no dst-port="" redirect-to=\
    "www.bylltec.com.br/site/gestorserver/avisos/aviso_bloqueado.php\?idaviso=2" src-address=192.168.1.20
    add action=allow comment=chefe disabled=no dst-host=www.facebook.com dst-port="" src-address=192.168.1.25
    add action=deny disabled=no dst-host=www.facebook.com dst-port="" redirect-to=\
    "www.bylltec.com.br/site/gestorserver/avisos/aviso_bloqueado.php\?idaviso=2" src-address=192.168.1.0/24
    add action=deny disabled=no dst-host=:sexo dst-port="" redirect-to=\
    "www.bylltec.com.br/site/gestorserver/avisos/aviso_bloqueado.php\?idaviso=2"
    add action=deny disabled=no dst-port="" path=*.flv
    add action=deny disabled=no dst-port="" path=*.avi
    add action=deny disabled=no dst-port="" path=*.mp4
    add action=deny disabled=no dst-port="" path=*.mp3
    add action=deny disabled=no dst-port="" path=*.zip
    add action=deny disabled=no dst-port="" path=*.rar



  7. #7

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por deson00 Ver Post
    1 configurar web-proxy.
    2 criar uma lista com tudo que pode e nao pode e quem pode
    3 criar um regra nat de redirecionar todas as portas de todos ips que estara no address list com nome de blqueado para a porta do proxy
    4 criar uma lista de ip com nome de bloqueado no address list do nat
    5 adicionar as permiçoes no access do proxy, podera redirecionar cada usuario para uma pagina que podera conter algum tipo de aviso escrito para que possa entender que esta agindo de forma incorreta e que esta sendo monitorado.
    regras abaixo para proxy funcionar
    #
    /ip firewall nat
    add action=redirect chain=dstnat comment="webproxy pppoe" disabled=no dst-port=80 in-interface=ether2 protocol=tcp src-address=192.168.6.0/24 to-ports=8080
    add action=redirect chain=dstnat comment="webproxy hotspot" disabled=no dst-port=80 in-interface=ether2 protocol=tcp src-address=10.5.50.0/24 to-ports=8080
    add action=redirect chain=dstnat comment="redireciona todas as portas para proxy" disabled=no protocol=tcp src-address-list=bloqueado to-ports=8080
    add action=masquerade chain=srcnat comment="masquerade pppoe" disabled=no src-address=192.168.6.0/24 to-addresses=0.0.0.0
    add action=masquerade chain=srcnat comment="masquerade hotspot" disabled=no src-address=10.5.50.0/24 to-addresses=0.0.0.0
    #
    /ip firewall address-list
    add address=192.168.1.20 comment=jose disabled=no list=bloqueado
    #
    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 \
    serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=allow disabled=no dst-host=www.bylltec.com.br dst-port=""
    add action=deny comment=jose disabled=no dst-port="" redirect-to=\
    "www.bylltec.com.br/site/gestorserver/avisos/aviso_bloqueado.php\?idaviso=2" src-address=192.168.1.20
    add action=allow comment=chefe disabled=no dst-host=www.facebook.com dst-port="" src-address=192.168.1.25
    add action=deny disabled=no dst-host=www.facebook.com dst-port="" redirect-to=\
    "www.bylltec.com.br/site/gestorserver/avisos/aviso_bloqueado.php\?idaviso=2" src-address=192.168.1.0/24
    add action=deny disabled=no dst-host=:sexo dst-port="" redirect-to=\
    "www.bylltec.com.br/site/gestorserver/avisos/aviso_bloqueado.php\?idaviso=2"
    add action=deny disabled=no dst-port="" path=*.flv
    add action=deny disabled=no dst-port="" path=*.avi
    add action=deny disabled=no dst-port="" path=*.mp4
    add action=deny disabled=no dst-port="" path=*.mp3
    add action=deny disabled=no dst-port="" path=*.zip
    add action=deny disabled=no dst-port="" path=*.rar
    vlw pela dica mais esse vai vai funcionar no meu caso aki eu uso só arp amarrado ip ao mac com controle de banda, e a minha ranger é 10.1.1.1/24 só alterar as ranger?

  8. #8

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    O proxy e simples de montar.

    Vai em IP web Proxy clica em Enabled marca ele, na porta pode por Port:8080 em Max.Cache Size: Unlimited
    O restante pode deixar padrao como esta.

    Ai voce vai Na nat IP firewall Nat crie esta nova regra.

    Em chain coloca dstnat em protocol: 6(tcp) Dst. port: 80, vai na aba action em action: redirect to Ports:8080

    Lembre-se que esta regra tem que fica em sima de qual quer regra que voce tenha ai ate do masquerade

    Pronto ta montado seu proxy simples e rapido e assim que o meu aqui funciona.

    Para fazer o redirecionamento do site bloqueado e assim.

    voce vai em web proxy access crie uma nova regra

    em Src.Address coloqueo o ip do fulano bloqueado
    em DST.HOST o site que quera bloquear ex :facebook|orkut precisa do : no inicio e a | para separa um do outro
    em action: Deny
    No redirect To: a pagina da mazinha vermelha que voce quer como indicativo de site bloqueado.
    Espero ter ajudado ate mais



  9. #9

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por baleiro Ver Post
    O proxy e simples de montar.

    Vai em IP web Proxy clica em Enabled marca ele, na porta pode por Port:8080 em Max.Cache Size: Unlimited
    O restante pode deixar padrao como esta.

    Ai voce vai Na nat IP firewall Nat crie esta nova regra.

    Em chain coloca dstnat em protocol: 6(tcp) Dst. port: 80, vai na aba action em action: redirect to Ports:8080

    Lembre-se que esta regra tem que fica em sima de qual quer regra que voce tenha ai ate do masquerade

    Pronto ta montado seu proxy simples e rapido e assim que o meu aqui funciona.

    Para fazer o redirecionamento do site bloqueado e assim.

    voce vai em web proxy access crie uma nova regra

    em Src.Address coloqueo o ip do fulano bloqueado
    em DST.HOST o site que quera bloquear ex :facebook|orkut precisa do : no inicio e a | para separa um do outro
    em action: Deny
    No redirect To: a pagina da mazinha vermelha que voce quer como indicativo de site bloqueado.
    Espero ter ajudado ate mais
    opa vlw pela dica vou testar aki e vejo o que dá.

  10. #10

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por baleiro Ver Post
    O proxy e simples de montar.

    Vai em IP web Proxy clica em Enabled marca ele, na porta pode por Port:8080 em Max.Cache Size: Unlimited
    O restante pode deixar padrao como esta.

    Ai voce vai Na nat IP firewall Nat crie esta nova regra.

    Em chain coloca dstnat em protocol: 6(tcp) Dst. port: 80, vai na aba action em action: redirect to Ports:8080

    Lembre-se que esta regra tem que fica em sima de qual quer regra que voce tenha ai ate do masquerade

    Pronto ta montado seu proxy simples e rapido e assim que o meu aqui funciona.

    Para fazer o redirecionamento do site bloqueado e assim.

    voce vai em web proxy access crie uma nova regra

    em Src.Address coloqueo o ip do fulano bloqueado
    em DST.HOST o site que quera bloquear ex :facebook|orkut precisa do : no inicio e a | para separa um do outro
    em action: Deny
    No redirect To: a pagina da mazinha vermelha que voce quer como indicativo de site bloqueado.
    Espero ter ajudado ate mais

    excelente observação
    pode fazer que vai rolar



  11. #11

    Talking Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Poste para nos Se funcionar qual quer duvida estou a disposição

  12. #12

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    ok vou testa amanha sabado



  13. #13

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por baleiro Ver Post
    Poste para nos Se funcionar qual quer duvida estou a disposição
    fiz como no seu post acima mais não deu certo... o facebook continua abrindo coloquei |facebook e salvei e não deu e não mostro a pagina de direcionamento.

  14. #14

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Voce tem que colocar assim :facebook|orkut|terra|uol|
    primeira mente os dois pontos : para serar um do outro sem espaço voce coloca assim | = no exemplo a cima

    La na nat Esta tendo trafego na regra que voce criou???



  15. #15

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por baleiro Ver Post
    Voce tem que colocar assim :facebook|orkut|terra|uol|
    primeira mente os dois pontos : para serar um do outro sem espaço voce coloca assim | = no exemplo a cima

    La na nat Esta tendo trafego na regra que voce criou???
    sim em nat tem trafego no web-proxy não

  16. #16

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por baleiro Ver Post
    Voce tem que colocar assim :facebook|orkut|terra|uol|
    primeira mente os dois pontos : para serar um do outro sem espaço voce coloca assim | = no exemplo a cima

    La na nat Esta tendo trafego na regra que voce criou???
    vlw deu certinho, funcionando 100% agora uma pergunta é possivel eu bloquear toda uma ranger por exemplo 192.168.1.0/24 e liberar só o ip 192.168.1.12 por exemplo e deixar o restante bloqueado?



  17. #17

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Aqui na minha rede cada um dos IPs eu coloquei uma regra diferente intao eu nao sei se da para bloque uma ranger

  18. #18

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Aqui na minha rede eu montei um Cache full com O mkt e funciona perfeitamente se voce quiser posso te passar as regras tbm



  19. #19

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    a melhor ferramenta a se usar nestes casos seria layer 7

    porque dependendo da pagina se for HTTPS o proxy nao filtra senhores

  20. #20

    Padrão Re: Bloquear sites e enviar aviso de site bloqueado e possível?

    Citação Postado originalmente por flavioleonel Ver Post
    a melhor ferramenta a se usar nestes casos seria layer 7

    porque dependendo da pagina se for HTTPS o proxy nao filtra senhores
    já uso l7 porem não envia msg por isso que que to usando o webproxy como os amigos disseram... com layer7 não dá pra enviar msg so aparece pagina não pode ser encontrada...