Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal preciso da ajuda de vocês, usei o script abaixo que retirei do site wikimikrotik.com, justamente para modem roteado, funciona, porém caso haja uma queda no link, naturalmente o IP muda, e o script não atualiza no site changeip, aí não consigo mais acessar remotamente, até que manualmente eu faça a atualização. O que será que está errado?


    :local user "user"
    :local pass "pass"
    :local host "host"
    ##############
    ##############
    :global lastwanip;
    :if ([ :typeof $lastwanip ] = "nothing" ) do={ :global lastwanip 0.0.0.0 };
    :local wanip [:resolve $host];
    :if ( $wanip != $lastwanip ) do={
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :set lastwanip $currentIP;
    ut [/tool dns-update name=$host address=$currentIP key-name=$user key=$pass ]
    }

    * o primeiro ícone é ": pick" e o segundo é ": out" (sem as aspas e sem espaços)
    Última edição por Claudioanjos; 18-04-2013 às 15:18.

  2. Citação Postado originalmente por Claudioanjos Ver Post
    Pessoal preciso da ajuda de vocês, usei o script abaixo que retirei do site wikimikrotik.com, justamente para modem roteado, funciona, porém caso haja uma queda no link, naturalmente o IP muda, e o script não atualiza no site changeip, aí não consigo mais acessar remotamente, até que manualmente eu faça a atualização. O que será que está errado?


    :local user "user"
    :local pass "pass"
    :local host "host"
    ##############
    ##############
    :global lastwanip;
    :if ([ :typeof $lastwanip ] = "nothing" ) do={ :global lastwanip 0.0.0.0 };
    :local wanip [:resolve $host];
    :if ( $wanip != $lastwanip ) do={
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :set lastwanip $currentIP;
    ut [/tool dns-update name=$host address=$currentIP key-name=$user key=$pass ]
    }

    * o primeiro ícone é ": pick" e o segundo é ": out" (sem as aspas e sem espaços)



    Segue este aqui

    /tool dns-update name=seudominioddns address=127.0.0.255 key-name=seulogin changeip key=suasenha

    logo em seguida vá em

    /system/scheduler/ adicione

    /system script run dns

    coloque pra 5 minutos



  3. Citação Postado originalmente por Acronimo Ver Post
    Segue este aqui

    /tool dns-update name=seudominioddns address=127.0.0.255 key-name=seulogin changeip key=suasenha

    logo em seguida vá em

    /system/scheduler/ adicione

    /system script run dns

    coloque pra 5 minutos
    Faço dessa forma e funciona blz, só essas opções que nunca sei qual desmarcar, ja vi varios scripts diferentes.

    reboot read
    write policy
    test password
    sniff sensitive

  4. Citação Postado originalmente por Acronimo Ver Post
    Segue este aqui

    /tool dns-update name=seudominioddns address=127.0.0.255 key-name=seulogin changeip key=suasenha

    logo em seguida vá em

    /system/scheduler/ adicione

    /system script run dns

    coloque pra 5 minutos
    tenho uma RB750 e nela não tem essa opção dns-update, segue imagem
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         RB750.jpg
Visualizações:	89
Tamanho: 	33,1 KB
ID:      	44045  



  5. Citação Postado originalmente por Claudioanjos Ver Post
    tenho uma RB750 e nela não tem essa opção dns-update, segue imagem
    O dns-update em questão não é da rb750 e sim do script que foi colocada nela.






Tópicos Similares

  1. Respostas: 6
    Último Post: 02-12-2011, 22:14
  2. Respostas: 2
    Último Post: 09-11-2011, 09:18
  3. ddns + iptables acesso remoto não funciona
    Por lfernandosg no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-12-2010, 15:30
  4. Acesso romoto nao funciona?
    Por Good_speed no fórum Servidores de Rede
    Respostas: 4
    Último Post: 17-03-2009, 15:57
  5. Respostas: 3
    Último Post: 18-03-2007, 12:15

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L