+ Responder ao Tópico



  1. Consegui fazer o balanceamento, que quando um LINK cai o outro LINK assume, porem to com um problema, não ta somando os link, isso é usa apena um LINK.
    Veja abaixo a imagem
    Clique na imagem para uma versão maior

Nome:	         balanceamento.jpg
Visualizações:	41
Tamanho: 	152,1 KB
ID:      	45054

  2. poderia por as config de balanceamento?(pode usar o comando export para isso)
    e da aba conections (se nao tiver aparecendo nada, habilite a opção track)



  3. A minha configuração

    /ip firewall mangle
    add action=accept chain=prerouting comment=\
    "====================================================================" \
    disabled=no dst-address=192.168.1.0/30 src-address=192.168.1.0/30
    add action=accept chain=prerouting disabled=no dst-address=10.130.44.0/30 \
    src-address=192.168.1.0/30
    add action=accept chain=prerouting disabled=no dst-address=201.48.201.0/30 \
    src-address=192.168.1.0/30
    add action=mark-connection chain=prerouting comment=\
    "====================================================================" \
    connection-mark=no-mark disabled=no in-interface=ISP1 \
    new-connection-mark=ISP1_conn passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no in-interface=ISP2 new-connection-mark=ISP2_conn passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=ISP2_conn disabled=\
    no new-routing-mark=ISP2_trafic passthrough=yes src-address=\
    192.168.1.0/30
    add action=mark-routing chain=prerouting comment=\
    "====================================================================" \
    connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_trafic \
    passthrough=yes src-address=192.168.1.0/30
    add action=mark-routing chain=output comment=\
    "====================================================================" \
    connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_trafic \
    passthrough=yes
    add action=mark-routing chain=output connection-mark=ISP2_conn disabled=no \
    new-routing-mark=ISP2_trafic passthrough=yes
    add action=mark-connection chain=policy_router comment=\
    "====================================================================" \
    disabled=no dst-address-type=!local new-connection-mark=ISP1_conn \
    passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=policy_router disabled=no dst-address-type=\
    !local new-connection-mark=ISP2_conn passthrough=yes \
    per-connection-classifier=both-addresses:2/1

    /ip firewall nat
    add action=masquerade chain=srcnat disabled=no out-interface=ISP1
    add action=masquerade chain=srcnat disabled=no out-interface=ISP2 \
    to-addresses=0.0.0.0

    /ip route
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.48.201.1 \
    routing-mark=ISP2_trafic scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.130.44.1 \
    routing-mark=ISP1_trafic scope=30 target-scope=10
    add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.130.44.1 scope=30 \
    target-scope=10
    add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=201.48.201.1 scope=\
    30 target-scope=10



    Clique na imagem para uma versão maior

Nome:	         balanceamento2.jpg
Visualizações:	36
Tamanho: 	165,7 KB
ID:      	45091 foto da aba conections

  4. bem... seu balanceamento esta funcionando,
    mas o balanceamentos por mangle do MK, pelo que eu entendi(posso estar errado), faz balanceamento por conexão, isto é:
    a 1ª conexão vai para o isp1, a 2ª ->isp2, a 3ª ->isp1, 4ª ->isp2,...
    ele não verifica o uso do link.
    dai se vc tiver o azar de poe exemplo a 1ª e 3ª conexão serem downloads muito grandes vc vai sobrecarregar um link enquanto o outro fica ocioso.

    soluções:
    --fazer o balanceamento no braço com o uso de scritp( um script que monitora o uso do link de saida a cada tempo e altera o gateway padão)( eu chamaria isso de gambiarra braba, mas funcionaria )

    --balanceamento por protocolo de roteamentos(rip, ospf, bgp), este seria mais robusto, mas financeiramente mais custoso (vc precisa de um RB por link mais um centralizador) e trabalhoso de montar as regras.
    segue alguns links de material para estudo de como proceder:
    https://docs.google.com/file/d/0Bx7i...zY4/edit?pli=1 (otima teoria, mas a pratica é sobre equipamento cisco)
    http://wiki.mikrotik.com/wiki/Manual...ting_protocols
    http://wiki.mikrotik.com/wiki/Manual...two_interfaces
    http://wiki.mikrotik.com/wiki/Manual..._sharing_setup






Tópicos Similares

  1. Problemas com balanceamento de internet
    Por jvoiski no fórum Redes
    Respostas: 17
    Último Post: 15-03-2012, 11:48
  2. Problemas com Balanceamento!
    Por LitoralNet no fórum Redes
    Respostas: 11
    Último Post: 04-11-2010, 01:01
  3. Problema com Balanceamento utilizadando NTH
    Por henriquefr no fórum Redes
    Respostas: 1
    Último Post: 14-10-2008, 09:45
  4. Respostas: 0
    Último Post: 02-09-2008, 10:18
  5. Problemas com balanceamento de link
    Por leandro_ntc no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-07-2006, 08:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L