+ Responder ao Tópico



  1. #1

    Padrão Balance PCC

    Galera abaixo vou postar meu Balance pcc
    Os modens estão em bridge e a rb disca o Pppoe
    Ele ta funcionando legal, porém quando um link cai, o outro não assume o controle total a conexão termina ficando lenta
    meu link não são síncronos, é um de 35 e outro é de 15, Fiz teste desabilitando o de 35 e o de 15 não chega a puxa 6 mb

    Load_balance.txt

    outra coisa é são da mesma operadora e estão usando a mesma gateway.
    vai o print abaixo
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         print.jpg
Visualizações:	80
Tamanho: 	41,1 KB
ID:      	45680  

  2. #2

    Padrão Re: Balance PCC

    bem eu uso um script que monitora o balanceamento e que altera a conexão dos ppc no caso de ela cair.
    segui o script
    Código :
    :local linkstatus;
    :local classificadores;
    :local conexaoP
    :local rota
    :local conexaoB
    :local pingcount
    :set linkstatus false;
    :set rota "turbo-8M"
    :set classificadores ("both-addresses:4/0","both-addresses:4/2","both-addresses:4/3")
    :set conexaoP T8M_conn
    :set conexaoB datavag_conn
     
    while  ( true ) do={
        :set pingcount [/ping 8.8.8.8 count=5 routing-table=$rota]
     
        :if ( $pingcount < 2  and  $linkstatus ) do={
            :log  warning "oi down"
            :set linkstatus false
            :log  info "deixando o balanceamento para a datavag"
            :foreach classifica in=[$classificadores] do={
                /ip firewall mangle set [/ip firewall mangle find per-connection-classifier=$classifica] new-connection-mark=$conexaoB
            }
        }
    :if ( $pingcount = 5  and  !$linkstatus ) do={
            :log  warning "oi up"
            :set linkstatus true
            :log  info "voltando o balanceamento no link da oi "
            :foreach classifica in=[$classificadores] do={
                /ip firewall mangle set [/ip firewall mangle find per-connection-classifier=$classifica] new-connection-mark=$conexaoP
            }
        }
     
        :delay 30s
    }

    vc vai ter q fazer um desse script para cada conexão.
    vc tbm vai ter que ajustar as variaveis conforme a necessidade.
    classificadores é os valor dos per-connection-classifier das tuas regras.
    rota é o valor da marcaçao de rota que vc vai monitorar.
    conexaoP é a conexão monitorada
    conexãoB é a conexão backup.

    o delay esta config pra 30s o que faz com que leve até 1 min para perceber que a conexao esta up/down. vc pode setar conforme sua necessidade



  3. #3

    Padrão Re: Balance PCC

    Código :
    :local linkstatus;
    :local classificadores;
    :local conexaoP
    :local rota
    :local conexaoB
    :local pingcount
    :set linkstatus false;
    :set rota "ISP1_trafic"
    :set classificadores ("both-addresses:3/0","both-addresses:3/1","both-addresses:3/2")
    :set conexaoP ISP1_conn
    :set conexaoB ISP2_conn
     
    while  ( true ) do={
        :set pingcount [/ping 8.8.8.8 count=5 routing-table=$rota]
     
        :if ( $pingcount < 2  and  $linkstatus ) do={
            :log  warning "GVT_35 down"
            :set linkstatus false
            :log  info "deixando o balanceamento para a GVT_15"
            :foreach classifica in=[$classificadores] do={
                /ip firewall mangle set [/ip firewall mangle find per-connection-classifier=$classifica] new-connection-mark=$conexaoB
            }
        }
    :if ( $pingcount = 5  and  !$linkstatus ) do={
            :log  warning "GVT_35 up"
            :set linkstatus true
            :log  info "voltando o balanceamento no link da GVT_35 "
            :foreach classifica in=[$classificadores] do={
                /ip firewall mangle set [/ip firewall mangle find per-connection-classifier=$classifica] new-connection-mark=$conexaoP
            }
        }
     
        :delay 30s
    }

    Poderia verificar se Estar certo a adaptação ??

    obrigado
    Última edição por wagnersn; 04-06-2013 às 13:15.

  4. #4

    Padrão Re: Balance PCC

    Poderia verificar se Estar certo a adaptação ??
    +-
    agora que olhei tuas regras de balanceamnto, e ela está meio estranha.
    como esta as regras de rotas?

    pera ai, tu está usando 2 link do mesmo provedor? isso não é muito indicado, pois se o gatway cair ele vai cair para os 2 links.

    se não quiser postar teus ips ou coisa assim mande por mp



  5. #5

    Padrão Re: Balance PCC

    Sim são do mesmo provedor =[

    o gateway é o mesmo

  6. #6

    Padrão Re: Balance PCC

    não quero dizer nada, mas dai acho que vc não precisaria fazer regras para funcionar o balanceamento. não sei o comportamento do MK, quanto a isso.(queria saber por qual interface que é alcançável o gateway)

    alternativa seria colocar 1 dos modems sem ser bridge para que tenha 2 gateway.
    Código :
     
    add comment="rota ip datavag" distance=1 gateway=177.86.3.1 routing-mark=datavag
    add comment="rota brasil telecon 1" distance=10 gateway=200.203.98.9 routing-mark=brt-ip-valido-200.203.88.10
    add check-gateway=ping comment="rota adsl" distance=1 gateway=192.168.1.1 routing-mark=turbo-8M
    add check-gateway=ping comment="rota sem marcacao saindo por datavag" distance=1 gateway=177.86.3.1
    add check-gateway=ping comment="rota adsl sem marcacao" distance=1 gateway=192.168.1.1
    add comment="teste datavag" distance=1 gateway=177.86.3.1
    add comment="rota sem marcacao saindo por brt" disabled=yes distance=1 gateway=200.203.98.9
    add comment="rota ip datavag" disabled=yes distance=10 gateway=177.86.3.1