+ Responder ao Tópico



  1. Olá a todos, tenho um script de backup que funciona sem problemas, ele faz um simples backup de uma pasta inteira, ate ai tudo bem, só que todo dia aumenta o tamanho do backup, e gostaria de reduzir excluindo algumas pastas que não necessito de backup
    segue o atual script:
    Código :
    #!/bin/bash 
    year=`date +%Y`
    month=`date +%m`
    day=`date +%d`
    hour=`date +%H`
     
    cd /home/backup
     
    find /home/backup/* -mtime +5 -exec rm {} \;
     
    zip -9 -r $year.$month.$day.$hour.server.zip /home/servidor/

    bom dei uma pesquisada, mas fiquei meio que perdido como poderia fazer isso ate testei alguns mas só deu erro, se alguém puder me ajudar ficarei grato desde já.

    abraços a todos.

  2. Citação Postado originalmente por locgames Ver Post
    Olá a todos, tenho um script de backup que funciona sem problemas, ele faz um simples backup de uma pasta inteira, ate ai tudo bem, só que todo dia aumenta o tamanho do backup, e gostaria de reduzir excluindo algumas pastas que não necessito de backup
    segue o atual script:
    Código :
    #!/bin/bash 
    year=`date +%Y`
    month=`date +%m`
    day=`date +%d`
    hour=`date +%H`
     
    cd /home/backup
     
    find /home/backup/* -mtime +5 -exec rm {} \;
     
    zip -9 -r $year.$month.$day.$hour.server.zip /home/servidor/

    bom dei uma pesquisada, mas fiquei meio que perdido como poderia fazer isso ate testei alguns mas só deu erro, se alguém puder me ajudar ficarei grato desde já.

    abraços a todos.


    system/script

    crie o arquivo com o nome ENVIA EMAIL
    :log info message="ENVIANDO BACKUP POR EMAIL WBR TELECOM"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="SEU EMAIL" subject="NOME DA RB $data $hora" file=backup-mikrotik.backup tls=yes


    logo crie outro script com o nome SALVAR_BACKUP
    /system backup save name=backup-mikrotik.backup


    tools/email (exemplo utilizando o gmail)
    server:173.194.68.109
    Port:587
    From:conta@gmail.com
    User: usuario@gmail.com
    Password: sua senha de email

    Apos isso vá em system scheduler


    Crie sua rotina de backup acada 24 horas
    On Event
    SALVAR_BACKUP

    salva como nome salvar backup

    e faça a mesma coisa com o envio do backup


    todo dia vai um backup pro seu email



  3. opa, mas e se o backup dele for de 5Gb ou mais ?
    mandar para o e-mail acho que não seria interessante como citou nosso amigo Acronimo

    a não ser que tenha pouca coisa ai.
    ainda assim não aconselho utilizar o e-mail como "porta dados".

    Eu acredito que o ideal é utilizar o "rsync" e fazer de forma "incremental", assim só irá copiar os arquivos que foram modificados, economizando tempo, banda e espaço em disco.

    Att.

  4. Boa tarde.

    Adicione "!" no seu script para os diretórios que você deseja ignorar.

    Ex: find /home/backup/* \( ! -name dir01 -o ! -name dir02 -o ! dir03 \) -mtime +5 -exec rm {} \;
    "!" representa os padrões que devem ser ignorados, "-o" representa "ou" e "dir0X" representam os diretórios ignorados

    Atenciosamente.






Tópicos Similares

  1. ajuda com script de backup
    Por gabriel barreto no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 09-11-2013, 00:12
  2. Ajuda com script de usuário
    Por Shimanus no fórum Linguagens de Programação
    Respostas: 0
    Último Post: 13-05-2013, 21:01
  3. Ajuda com Script de Backup
    Por noir no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 08-01-2013, 17:09
  4. ajuda com script de backup
    Por edileyoliveira no fórum Linguagens de Programação
    Respostas: 5
    Último Post: 18-07-2008, 13:50
  5. Ajuda com script de firewall no fedora
    Por pearljam no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-09-2007, 08:45

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L