Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal do fórum, tranquilos!

    Tenho um pc c/ windows 7 32bits que roda o Apache 2.2.25. No Apache tá hospedado uma pagina de bloqueio p/ meus clientes. Em paralelo tenho um servidor mikrotik c/ as regras no NAT que redireciona as conexões (dos bloqueados), na porta 80 p/ o ip da maquina que tenho o apache, até ai tudo bem, funciona 100%.

    Porem, recentemente eu estava fazendo uns testes de rotina pra ver se estava tudo funcionando certinho, e notei que sites como o facebook, google, e outros que usam HTTPS não estavam sendo redirecionados p/ a pagina de bloqueio.

    Logo percebi que esses sites usam a porta 443, e a regra no meu NAT tá redirecionando conexões na porta 80. Mas pintou um problema, no mikrotik consegui redirecionar a porta 443 p/ o ip da maquina que tenho o Apache porem, a pagina de bloqueio não abre, dá um erro relacionado a SSL.

    O Apache que tenho instalado, também tem o OPENSSL, mas mesmo assim na porta 80 a pagina de bloqueio aparece certinho, já na porta 443 não abre.

    Agradeço a todos que tiverem alguma ideia ou sugestão p/ testar aqui.

    Abraço.

  2. Citação Postado originalmente por FabianoMartins2 Ver Post
    Olá pessoal do fórum, tranquilos!

    Tenho um pc c/ windows 7 32bits que roda o Apache 2.2.25. No Apache tá hospedado uma pagina de bloqueio p/ meus clientes. Em paralelo tenho um servidor mikrotik c/ as regras no NAT que redireciona as conexões (dos bloqueados), na porta 80 p/ o ip da maquina que tenho o apache, até ai tudo bem, funciona 100%.

    Porem, recentemente eu estava fazendo uns testes de rotina pra ver se estava tudo funcionando certinho, e notei que sites como o facebook, google, e outros que usam HTTPS não estavam sendo redirecionados p/ a pagina de bloqueio.

    Logo percebi que esses sites usam a porta 443, e a regra no meu NAT tá redirecionando conexões na porta 80. Mas pintou um problema, no mikrotik consegui redirecionar a porta 443 p/ o ip da maquina que tenho o Apache porem, a pagina de bloqueio não abre, dá um erro relacionado a SSL.

    O Apache que tenho instalado, também tem o OPENSSL, mas mesmo assim na porta 80 a pagina de bloqueio aparece certinho, já na porta 443 não abre.

    Agradeço a todos que tiverem alguma ideia ou sugestão p/ testar aqui.

    Abraço.
    Pior q não tem jeito mesmo amigo!!



  3. Citação Postado originalmente por rogeriodj Ver Post
    Pior q não tem jeito mesmo amigo!!
    kkkkkkkkkk
    Sério mesmo que não tem jeito!!!

  4. Galera do fórum, um servidor Linux resolveria esse meu problema ?



  5. Citação Postado originalmente por FabianoMartins2 Ver Post
    Galera do fórum, um servidor Linux resolveria esse meu problema ?
    Não resolve não, o problema é https...






Tópicos Similares

  1. Respostas: 46
    Último Post: 07-12-2017, 22:46
  2. Direcionar página de erro para formulário
    Por rndrama no fórum Servidores de Rede
    Respostas: 3
    Último Post: 03-02-2009, 10:45
  3. WebMiau para Windows
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-11-2003, 10:53
  4. Direcionar Pagina para outra maquina...
    Por Perdigao no fórum Servidores de Rede
    Respostas: 1
    Último Post: 27-05-2003, 12:25
  5. NTP cliente para windows 98
    Por Leyzem no fórum Servidores de Rede
    Respostas: 3
    Último Post: 07-03-2003, 22:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L