+ Responder ao Tópico



  1. #1

    Question Script não roda na versão 6XX do ROS

    Bom dia, amigos.

    Ao atualizar a versão do ROS para 6.2 notei que um script simples, que rodava em meu sistema, parou de funcionar.
    O script fazia alteração da velocidade do cliente a partir de uma determinada hora e depois retornava à velocidade contratada.
    Gostaria de saber dos amigos que já usam a versão 6.2, se estão encontrando problemas com a execução de seus scripts.
    Abaixo seguem as instruções que dou ao sistema, via script:

    /queue simple set [/queue simple find priority=7] max-limit=512000/1100000]" (Eleva a velocidade)

    /queue simple set [/queue simple find priority=7] max-limit=512000/1000000]" (Retorna ao valor contratado)

    Nenhum dos dois rodam mais na versão 6.2.

    Agradeço qualquer ajuda.

  2. #2
    Avatar de adrianoateky
    Ingresso
    Aug 2011
    Localização
    Braço do Norte - Santa Catarina
    Posts
    48

    Padrão Re: Script não roda na versão 6XX do ROS

    Ola,

    No meu caso, nao foi diferente, aconteceu erro de script a o enviar backup e log por email,

    se antes o script era: / tool e-mail send to = "email" subject = "Backup-mikrotik-Pop $ date $ time" file = backup-mikrotik.backup tls = yes

    depois de atualizar da v5.25 para v6.2 tambem parou de funcionar, o problema e que mudou varias linhas de comando com atualizaçao.


    o script agora ficou assim: / tool e-mail send to = "email" subject = "Backup-mikrotik-Pop $ date $ time" file = backup-mikrotik.backup star-tls = yes


    So mudou tls=yes

    Para start-tls=yes

    Dica copie e cole seu script no terminal e veja o que esta errado, foi assim que consegui verificar o que estava errado no meu.
    Última edição por adrianoateky; 27-08-2013 às 11:26.



  3. #3

    Thumbs up Re: Script não roda na versão 6XX do ROS

    Tente executar o comando via terminal, por ele você localiza o "erro" e corrige ou posta aqui para tentarmos ajudar a solucionar.

    Citação Postado originalmente por macewindu Ver Post
    Bom dia, amigos.

    Ao atualizar a versão do ROS para 6.2 notei que um script simples, que rodava em meu sistema, parou de funcionar.
    O script fazia alteração da velocidade do cliente a partir de uma determinada hora e depois retornava à velocidade contratada.
    Gostaria de saber dos amigos que já usam a versão 6.2, se estão encontrando problemas com a execução de seus scripts.
    Abaixo seguem as instruções que dou ao sistema, via script:

    /queue simple set [/queue simple find priority=7] max-limit=512000/1100000]" (Eleva a velocidade)

    /queue simple set [/queue simple find priority=7] max-limit=512000/1000000]" (Retorna ao valor contratado)

    Nenhum dos dois rodam mais na versão 6.2.

    Agradeço qualquer ajuda.

  4. #4

    Padrão Re: Script não roda na versão 6XX do ROS

    Citação Postado originalmente por adrianoateky Ver Post
    Ola,

    No meu caso, nao foi diferente, aconteceu erro de script a o enviar backup e log por email,

    se antes o script era: / tool e-mail send to = "email" subject = "Backup-mikrotik-Pop $ date $ time" file = backup-mikrotik.backup tls = yes

    depois de atualizar da v5.25 para v6.2 tambem parou de funcionar, o problema e que mudou varias linhas de comando com atualizaçao.


    o script agora ficou assim: / tool e-mail send to = "email" subject = "Backup-mikrotik-Pop $ date $ time" file = backup-mikrotik.backup star-tls = yes


    So mudou tls=yes

    Para start-tls=yes

    Dica copie e cole seu script no terminal e veja o que esta errado, foi assim que consegui verificar o que estava errado no meu.
    Olá, boa iniciativa brother! Então, no meu caso aqui, até aparece no log "enviando backup por e-mail", porém não chega no meu e-mail, nem no lixo eletronico, nada.

    To usando hotmail, setei o ip dele lá em tool>email

    Tem algum sugestão do que pode ser ?

    Segue o meu script:
    :log info message="enviando backup por email"
    :global date [/system clock get date]
    :global time [/system clock get time]
    /tools e-mail send to="e-mail" subject="bkp-mk-concentrador $date $time" file=bkp-mk-concentrador.backup start-tls=yes;

    Abraço.



  5. #5

    Padrão Re: Script não roda na versão 6XX do ROS

    Olá !

    Fiz a tentativa pelo terminal e dei add no script.
    O resultado retornado foi : expected value of download-priority (line 1 column 49)Então entrei e editei a linha. Passei de priority para download-priority=5.
    Agora quando mando executar ele não me dá mais erro, porém a palavra download fica em vermelho e o scritp não roda.
    Alguma idéia ?





    Citação Postado originalmente por adrianoateky Ver Post
    Ola,

    No meu caso, nao foi diferente, aconteceu erro de script a o enviar backup e log por email,

    se antes o script era: / tool e-mail send to = "email" subject = "Backup-mikrotik-Pop $ date $ time" file = backup-mikrotik.backup tls = yes

    depois de atualizar da v5.25 para v6.2 tambem parou de funcionar, o problema e que mudou varias linhas de comando com atualizaçao.


    o script agora ficou assim: / tool e-mail send to = "email" subject = "Backup-mikrotik-Pop $ date $ time" file = backup-mikrotik.backup star-tls = yes


    So mudou tls=yes

    Para start-tls=yes

    Dica copie e cole seu script no terminal e veja o que esta errado, foi assim que consegui verificar o que estava errado no meu.

  6. #6

    Padrão Re: Script não roda na versão 6XX do ROS

    Caros colegas,
    Alguns comandos básicos do mikrotik mudaram, no só agora como em outras versões anteriores, por isso vcs estão tendo problemas.
    geralmente esses scripts usam linha de comando, então a melhor maneira de achar o erro é fazer como o amigo de cima ja havia sugerido.
    Abra o newterminal e copie os comandos para identificar o erro. Geralmente é coisa bem simples
    ex1, queues tree:
    #################################################################
    /queue tree
    # versao 5.9 -
    add name=voipin packet-mark=Voip parent=global-in priority=1 queue=default
    #versao6.0 +
    add name=voip packet-mark=Voip parent=global priority=1 queue=default
    #################################################################
    No ex. acima o parent global-in e global-out não existem mais e agora é so global
    vários outros comandos tb tiveram alterações assim, simples não?

    outra coisa é: Muito cuidado ao enviar backups para emails de terceiros(yahoo,gmail,hotmail,etc), pois o arquivo de backup contem as senhas de acesso e se alguém pegar esse arquivo saberá todos os dados do seu equipamento.
    Talvez uma opicao mais segura seja um exporte, ele só exporta as linhas de comando das configurações.

    aki estou usando assim:

    ##############################################################
    ############Script p/ backup##################################
    /system script
    add name=backup_mail policy=ftp,reboot,read,write,policy,test,winbox,password,sensitive,api source="/export file=[/system identity get value-name=name ]\r\
    \n\r\
    \n/tool e-mail send file=([/system identity get value-name=name ].src) to=\"[email protected]\" body=(\"Responsavel:[email protected] \\n\\r\\ Nome=\".[/system identity get name].\"\\n\\r\\ Ende\
    reco=\".[/ip address get value-name=address number=0].\"\\n\\r\\ Versao=\".[/system package get value-name=version system]) subject=([/system identity get name] . \" - \" .[/system clock get date])"
    ##############################################################
    Os emails que recebo ficam assim:

    Responsavel:[email protected]
    Nome=PSF_Vista-Alegre
    Endereco=10.64.154.57/32
    Versao=5.24