+ Responder ao Tópico



  1. #1

    Thumbs up Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Boa tarde,

    Alguem ja conseguiu redirecionar o trafego da porta 80 para o cache através de um mikrotik utilizando roteamento OSPF+MPLS e entregando Ips validos via VPLS?

    Ether4 > Rede Clientes
    Ether6 > Thunder cache
    Ether5 > Saída Internet

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=Ida disabled=yes dst-port=80 in-interface=!ether6 new-routing-mark=thunder-route protocol=tcp
    add action=mark-routing chain=prerouting comment=Volta disabled=yes in-interface=ether5 new-routing-mark=thunder-route protocol=tcp src-port=80


    /ip route
    add distance=1 gateway=IP_THUNDERCACHE routing-mark=thunder-route

    simplesmente os pacotes não sao enviados ao cache...

  2. #2

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Desde que o Thunder tenha uma interface só ligada a um gateway que tenha as rotas OSPF, não faz diferença nas regras.

    Use a forma de redirecionamento mostrada nesse vídeo: . São 3 regras pra fazer o redirecionamento e a volta, porém marcando a conexão com um DSCP do Thunder, pra evitar problemas de volta de conexão que não foram originadas pelo Thunder.

    Qualquer dúvida estamos a disposição.



  3. #3

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Boa tarde Mario,

    fiz as regras conforme video e não passa por nenhuma das regras....

  4. #4

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Citação Postado originalmente por alissonx Ver Post
    Boa tarde Mario,

    fiz as regras conforme video e não passa por nenhuma das regras....
    Vc deve estar com a configuração de rede não adequada, pois uso aqui OSPF e funciona perfeito.



  5. #5

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Voce utiliza MPLS entregando IP Valido via VPLS para o POP?

    acho que isso está atrapalhando o forward...

  6. #6

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Citação Postado originalmente por rogeriodj Ver Post
    Vc deve estar com a configuração de rede não adequada, pois uso aqui OSPF e funciona perfeito.
    Voce utiliza MPLS entregando IP Valido via VPLS para o POP?

    acho que isso está atrapalhando o forward...



  7. #7

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Citação Postado originalmente por alissonx Ver Post
    Voce utiliza MPLS entregando IP Valido via VPLS para o POP?

    acho que isso está atrapalhando o forward...
    Como eu disse, não faz diferença o modo de entrega de IP pro cliente, pois as regras somente utilizam a interface do Thunder (negando a primeira e a terceira regras e com match na segunda regra).

    A BM Software tem uma equipe de suporte com contato via email ([email protected]), skype (bmsoftware.sistemas), fórum (www.overnix.com) e pelo telefone (54) 3316-0809. Entre em contato que verificam isso pra você.

  8. #8

    Thumbs up Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Citação Postado originalmente por mjr88 Ver Post
    Como eu disse, não faz diferença o modo de entrega de IP pro cliente, pois as regras somente utilizam a interface do Thunder (negando a primeira e a terceira regras e com match na segunda regra).

    A BM Software tem uma equipe de suporte com contato via email ([email protected]), skype (bmsoftware.sistemas), fórum (www.overnix.com) e pelo telefone (54) 3316-0809. Entre em contato que verificam isso pra você.
    Boa tarde Mario,

    em contato com o pessoal da bmsoftware via skype conseguimos resolver o problema retirando a vpls...

    os pacotes estavam passando diretamente da ether do cliente para internet e nem passava pelo cache...

    tem que fazer algo no mangle para que funcione com mpls e vpls?



  9. #9

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Citação Postado originalmente por alissonx Ver Post
    Boa tarde Mario,

    em contato com o pessoal da bmsoftware via skype conseguimos resolver o problema retirando a vpls...

    os pacotes estavam passando diretamente da ether do cliente para internet e nem passava pelo cache...

    tem que fazer algo no mangle para que funcione com mpls e vpls?
    Dr, não que eu saiba.

    A VPLS é um ponto-multiponto na rede MPLS, que deve ser entre esse roteador que o Thunder está e a parte interna da sua rede. O pacote chegando na VPLS desse roteador, ele deveria ser tratado normalmente pelo firewall e redirecionamento pelo roteamento no mangle.

    Note que o que digo aqui é puramente teórico, não temos isso em produção ainda, então não posso afirmar. Mas envia acesso a esse roteador no meu email que assim que der olho e te dou um retorno (estou trabalhando numa funcionalidade nova no Thunder e não sei se consigo olhar hoje, mas vou fazer o possível).

    Fico no aguardo.

    Abraço.

  10. #10

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Testa essas regras ai e ver se resolve.

    add address=172.16.0.1/30 comment=THUNDERCACHE interface=thundercache network=\
    172.16.0.0


    add action=mark-routing chain=prerouting comment=\
    "REDIRECIONAMENTO THUNDERCACHE" dst-port=80 in-interface=!thundercache \
    new-routing-mark=rota_thunder passthrough=no protocol=tcp src-mac-address=\
    !50:46:5D:CE:78:EE


    add action=mark-packet chain=postrouting comment="CACHE FULL" dscp=18 \
    new-packet-mark="CACHE FULL"


    /ip route
    add distance=1 gateway=172.16.0.2 routing-mark=rota_thunder



  11. #11

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Citação Postado originalmente por mjr88 Ver Post
    Dr, não que eu saiba.

    A VPLS é um ponto-multiponto na rede MPLS, que deve ser entre esse roteador que o Thunder está e a parte interna da sua rede. O pacote chegando na VPLS desse roteador, ele deveria ser tratado normalmente pelo firewall e redirecionamento pelo roteamento no mangle.

    Note que o que digo aqui é puramente teórico, não temos isso em produção ainda, então não posso afirmar. Mas envia acesso a esse roteador no meu email que assim que der olho e te dou um retorno (estou trabalhando numa funcionalidade nova no Thunder e não sei se consigo olhar hoje, mas vou fazer o possível).

    Fico no aguardo.

    Abraço.

    Boa tarde Mario,

    enviei em seu e-mail... fico no aguardo

    obrigado
    abraço

  12. #12

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Citação Postado originalmente por adrianoateky Ver Post
    Acompanhando!

    Saudações amigo,

    irei te dar um super dica para que não gere frames,utilize a ferramenta de acompanhamento do tópico conforme imagem abaixo,


    um abraço!

    Clique na imagem para uma versão maior

Nome:	         under.jpg
Visualizações:	138
Tamanho: 	49,4 KB
ID:      	47818



  13. #13

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    boa noite, foi mal ressuscitar o tópico mas estou com o mesmo problema do amigo com o cache e VPLS, alguém pode me ajudar?

    Obs1: Estou usando o thundercache:
    obs2: Faço da mesma forma que o 4networks citou recebo os ips validos e os repasso com VPLS para cada POP (cada pop possui um autenticador PPPoE);
    Obs3: já tentei todas essas regras que tem por ai, a questão é a mesma levantada pelo 4networks os pacotes não passam pelo cache.

    Obrigado pela ajuda.
    Última edição por Guilherme46664; 28-09-2015 às 21:48.

  14. #14

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Citação Postado originalmente por Guilherme46664 Ver Post
    boa noite, foi mal ressuscitar o tópico mas estou com o mesmo problema do amigo com o cache e VPLS, alguém pode me ajudar?

    Obs1: Estou usando o thundercache:
    obs2: Faço da mesma forma que o 4networks citou recebo os ips validos e os repasso com VPLS para cada POP (cada pop possui um autenticador PPPoE);
    Obs3: já tentei todas essas regras que tem por ai, a questão é a mesma levantada pelo 4networks os pacotes não passam pelo cache.

    Obrigado pela ajuda.
    eu uso e nao tem nenhuma configuracao espacial para isso.



  15. #15

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    Pirigoso,
    Vou expor melhor meu senário, seguinte eu recebo link em uma RB na ether1 com ip 172.27.2.116 (Gateway 172.27.2.113) ai eu recebo um /28 (200.x.x96/28) em uma Bridge que denominei BridgeVpls (IP: 200.x.x.97/28) na qual eu tenho todas as portas vpls que vão para os pops, ai então nos pops eu coloco o address 200.x.x.98..99..100 assim por diante com gateway 200.x.x.97. Assim que estou usando o VPLs.
    Agora para os clientes navegarem pelos IPs validos eu fiz uma marcação nessa RB que recebo o link que são essas:

    3 chain=prerouting action=mark-connection new-connection-mark=ip
    passthrough=yes src-address=200.215.160.96/29


    4 chain=prerouting action=mark-routing new-routing-mark=IpValidoClientes
    passthrough=yes src-address=200.215.160.96/29 connection-mark=ip

    depois criei uma rota no IP/Routes com dst Address 0.0.0.0/0 gateway 172.27.2.113 e RoutingMak IpValidoClientes


    Beleza agora o meu problema não sei oque coloco como ip na marcação do scr Address do thunder para ele fazer o cache.... se eu colocar os ips validos dos clientes 200.x.x.96/28 o thunder fica com mais de 30000 threds e o trafego dele não chega a 20Mb....

    se alguém puder ajudar agradeço, ou ainda se ficou meio confuso me perguntem que tento explicar melhor.

    Obrigado.

  16. #16

    Padrão Re: Rede Mikrotik - OSPF-MPLS-VPLS -> Redirecionar para Thunder Cache

    ninguem?? estou disposto a pagar se alguem conseguir resolver pra mim