+ Responder ao Tópico



  1. Alguém pode me ajudar nesse problema do nagios.
    o nagios foi instalando sem problema.
    ja o plugin não consigo instalar.
    OS Debian
    #########################################
    ./configure --prefix=/usr/local/nagios --with-nagios-user=nagios --with-nagios-group=nagios

    --with-apt-get-command: /usr/bin/apt-get
    --with-ping6-command: /bin/ping6 -n -U -w %d -c %d %s
    --with-ping-command: /bin/ping -n -U -w %d -c %d %s
    --with-ipv6: yes
    --with-mysql: no
    --with-openssl: yes
    --with-gnutls: no
    --enable-extra-opts: no
    --with-perl: /usr/bin/perl
    --enable-perl-modules: no
    --with-cgiurl: /nagios/cgi-bin
    --with-trusted-path: /bin:/sbin:/usr/bin:/usr/sbin
    --enable-libtap: no
    #################################################

    #make

    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14/plugins'
    Making all in plugins-scripts
    make[2]: Entrando no diretório `/dados/nagios-plugins-1.4.14/plugins-scripts'
    make[2]: Nada a ser feito para `all'.
    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14/plugins-scripts'
    Making all in plugins-root
    make[2]: Entrando no diretório `/dados/nagios-plugins-1.4.14/plugins-root'
    gcc -DLOCALEDIR=\"/usr/local/nagios/share/locale\" -DHAVE_CONFIG_H -I. -I.. -I.. -I../lib -I../gl -I../intl -I../plugins -I/usr/include -DNP_VERSION='"1.4.14"' -g -O2 -MT check_dhcp.o -MD -MP -MF .deps/check_dhcp.Tpo -c -o check_dhcp.o check_dhcp.c
    mv -f .deps/check_dhcp.Tpo .deps/check_dhcp.Po
    /bin/bash ../libtool --tag=CC --mode=link gcc -DNP_VERSION='"1.4.14"' -g -O2 -L. -o check_dhcp check_dhcp.o ../plugins/netutils.o ../plugins/utils.o ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lpthread -ldl
    gcc -DNP_VERSION=\"1.4.14\" -g -O2 -o check_dhcp check_dhcp.o ../plugins/netutils.o ../plugins/utils.o -L/dados/nagios-plugins-1.4.14/plugins-root ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lpthread -ldl
    gcc -DLOCALEDIR=\"/usr/local/nagios/share/locale\" -DHAVE_CONFIG_H -I. -I.. -I.. -I../lib -I../gl -I../intl -I../plugins -I/usr/include -DNP_VERSION='"1.4.14"' -g -O2 -MT check_icmp.o -MD -MP -MF .deps/check_icmp.Tpo -c -o check_icmp.o check_icmp.c
    mv -f .deps/check_icmp.Tpo .deps/check_icmp.Po
    /bin/bash ../libtool --tag=CC --mode=link gcc -DNP_VERSION='"1.4.14"' -g -O2 -L. -o check_icmp check_icmp.o ../plugins/netutils.o ../plugins/utils.o ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lnsl -lresolv -lpthread -ldl
    gcc -DNP_VERSION=\"1.4.14\" -g -O2 -o check_icmp check_icmp.o ../plugins/netutils.o ../plugins/utils.o -L/dados/nagios-plugins-1.4.14/plugins-root ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lpthread -ldl
    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14/plugins-root'
    Making all in po
    make[2]: Entrando no diretório `/dados/nagios-plugins-1.4.14/po'
    make[2]: Nada a ser feito para `all'.
    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14/po'
    make[2]: Entrando no diretório `/dados/nagios-plugins-1.4.14'
    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14'
    make[1]: Saindo do diretório `/dados/nagios-plugins-1.4.14'

  2. Citação Postado originalmente por fsoaress76 Ver Post
    Alguém pode me ajudar nesse problema do nagios.
    o nagios foi instalando sem problema.
    ja o plugin não consigo instalar.
    OS Debian
    #########################################
    ./configure --prefix=/usr/local/nagios --with-nagios-user=nagios --with-nagios-group=nagios

    --with-apt-get-command: /usr/bin/apt-get
    --with-ping6-command: /bin/ping6 -n -U -w %d -c %d %s
    --with-ping-command: /bin/ping -n -U -w %d -c %d %s
    --with-ipv6: yes
    --with-mysql: no
    --with-openssl: yes
    --with-gnutls: no
    --enable-extra-opts: no
    --with-perl: /usr/bin/perl
    --enable-perl-modules: no
    --with-cgiurl: /nagios/cgi-bin
    --with-trusted-path: /bin:/sbin:/usr/bin:/usr/sbin
    --enable-libtap: no
    #################################################

    #make

    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14/plugins'
    Making all in plugins-scripts
    make[2]: Entrando no diretório `/dados/nagios-plugins-1.4.14/plugins-scripts'
    make[2]: Nada a ser feito para `all'.
    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14/plugins-scripts'
    Making all in plugins-root
    make[2]: Entrando no diretório `/dados/nagios-plugins-1.4.14/plugins-root'
    gcc -DLOCALEDIR=\"/usr/local/nagios/share/locale\" -DHAVE_CONFIG_H -I. -I.. -I.. -I../lib -I../gl -I../intl -I../plugins -I/usr/include -DNP_VERSION='"1.4.14"' -g -O2 -MT check_dhcp.o -MD -MP -MF .deps/check_dhcp.Tpo -c -o check_dhcp.o check_dhcp.c
    mv -f .deps/check_dhcp.Tpo .deps/check_dhcp.Po
    /bin/bash ../libtool --tag=CC --mode=link gcc -DNP_VERSION='"1.4.14"' -g -O2 -L. -o check_dhcp check_dhcp.o ../plugins/netutils.o ../plugins/utils.o ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lpthread -ldl
    gcc -DNP_VERSION=\"1.4.14\" -g -O2 -o check_dhcp check_dhcp.o ../plugins/netutils.o ../plugins/utils.o -L/dados/nagios-plugins-1.4.14/plugins-root ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lpthread -ldl
    gcc -DLOCALEDIR=\"/usr/local/nagios/share/locale\" -DHAVE_CONFIG_H -I. -I.. -I.. -I../lib -I../gl -I../intl -I../plugins -I/usr/include -DNP_VERSION='"1.4.14"' -g -O2 -MT check_icmp.o -MD -MP -MF .deps/check_icmp.Tpo -c -o check_icmp.o check_icmp.c
    mv -f .deps/check_icmp.Tpo .deps/check_icmp.Po
    /bin/bash ../libtool --tag=CC --mode=link gcc -DNP_VERSION='"1.4.14"' -g -O2 -L. -o check_icmp check_icmp.o ../plugins/netutils.o ../plugins/utils.o ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lnsl -lresolv -lpthread -ldl
    gcc -DNP_VERSION=\"1.4.14\" -g -O2 -o check_icmp check_icmp.o ../plugins/netutils.o ../plugins/utils.o -L/dados/nagios-plugins-1.4.14/plugins-root ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lpthread -ldl
    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14/plugins-root'
    Making all in po
    make[2]: Entrando no diretório `/dados/nagios-plugins-1.4.14/po'
    make[2]: Nada a ser feito para `all'.
    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14/po'
    make[2]: Entrando no diretório `/dados/nagios-plugins-1.4.14'
    make[2]: Saindo do diretório `/dados/nagios-plugins-1.4.14'
    make[1]: Saindo do diretório `/dados/nagios-plugins-1.4.14'
    Tenta somente

    ./configure --with-nagios-user=nagios --with-nagios-group=nagios



  3. Tenta somente

    ./configure --with-nagios-user=nagios --with-nagios-group=nagios

  4. Obrigado pessoal!

    resolvido...






Tópicos Similares

  1. Ajuda para instalar o softmodem netodragon no fedora core 4
    Por dangsantos no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 08-10-2005, 18:02
  2. preciso de ajuda para instalar o java ....
    Por andreasn no fórum Servidores de Rede
    Respostas: 42
    Último Post: 13-07-2005, 12:48
  3. Ajuda para instalar o bichano no servidor
    Por Luzumba no fórum Servidores de Rede
    Respostas: 5
    Último Post: 01-07-2005, 09:10
  4. Preciso de ajuda para instalar Kopete 0.82 no mandrake 9.1
    Por fabioi2 no fórum Servidores de Rede
    Respostas: 7
    Último Post: 24-06-2004, 10:26
  5. Ajuda para instalar programas.
    Por meraki no fórum Servidores de Rede
    Respostas: 5
    Último Post: 25-05-2004, 21:40

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L