Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá amigos do underlinux, venho aqui pedir a ajudar de vcs.
    Tenho 3 LoadBalance na minha rede
    1 Load Balance: 3 ADSL RB750g
    2 Load Balance: 4 ADSL RB1100
    3 Load Balance: É a entradas dos 2 link RB750g, RB1100

    Bem coloco o script pra rodar no 1 load balance, roda perfeito, porem quando ele muda de ip ele ja pega o ip da rede 2 Load Balance, sendo q quando ele muda de ip nao consigo mais acessar o load balance 1 e sim o load balance 2 e assim vice verso.
    Como posso fazer para que o script rodando em apenas um load balance, pode me dar acesso a toda rede tanto um como o outro mesmo mudando o ip.

    # Dynamic DNS Update / Simple Edition
    # Written by Sam Norris, ChangeIP.com
    # Copyright ChangeIP.com 2009-2010
    # For support send mail to Support@ChangeIP.com
    #
    # 2009-06-22 RouterOS 3.25 Tested
    # 2009-10-05 RouterOS 4.01rc1 Tested
    #
    # OVERVIEW: %
    # This script will update a ChangeIP.com dynamic dns hostname
    # with an ip address located directly on an interface.
    # %
    # NOTES: %
    # IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT
    # AGAIN. THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you
    # have created this script and tested that it works by running it
    # manually you can schedule it to run every few minutes.
    # %
    # CONFIGURATION FIELD DEFINITIONS:
    # ddnsuser: Enter your ChangeIP.com user id.
    # ddnspass: Enter your ChangeIP.com password.
    # ddnshost: Enter the hostname (www.example.com) to update.
    # ddnsinterface: Enter an interface name - case sensative.
    # %
    # %
    # %
    # %
    # % % %
    # % % %
    # % % %
    # %
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser ""
    :global ddnspass ""
    :global ddnshost ""
    :global ddnsinterface "pppoe-out1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip

    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }

    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = "nothing" ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={

    :log info "DDNS: No changes necessary."

    }

    }

    # END OF SCRIPT

  2. Código :
    /system script
    add name=DDNSC policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
        source="/tool dns-update name=SEU HOST address=127.0.0.255 key-\
        name=LOGIN key=\"SENHA\""

    Coloque na RB que disca o pppoe e depois faça o redirecionamento de porta, apenas alterando as portas do winbox, assim com apenas 1 DNS você acessa sua rede toda, uso aqui assim e funciona de boas.

    OBS: Não esqueça do scheduler.



  3. coloquei os dois porem só da user e senha errada no logo e antes funcionava será q é pq o site atualizou?

  4. aqui ja esta funcionando normal, acho q era apenas atualizaçao deles!



  5. Sim, o script já voltou a funcionar.

    Porem uma coisa impressionante é o suporte deles, você envia um ticket e em menos de 5hrs eles já responde, muito bacana, quando vencer minha licença do DynDNS, irei migrar para o plano PRO do ChangeIP.






Tópicos Similares

  1. Script para alteração de IP .
    Por fhpn no fórum Mikrotik
    Respostas: 18
    Último Post: 07-02-2017, 08:28
  2. Script para bloqueio de ips
    Por nilmar1105 no fórum Redes
    Respostas: 2
    Último Post: 18-12-2013, 12:18
  3. Respostas: 0
    Último Post: 12-07-2012, 17:10
  4. Bloquear Pacotes de IP´s específicos
    Por Hawthorn no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-11-2002, 16:03
  5. Monitoração de IPs para Acessos, Downloads, Uploads.....
    Por soyeu no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-11-2002, 12:24

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L