+ Responder ao Tópico



  1. #1

    Padrão Redundancia de link so funciona na mao, na marra, pq nao consigo fazer nenhum script / sheduler funciionar

    /ip adress
    eth1 - 192.168.5.1/24 - rede interna
    eth2 - 10.0.0.2/24 - link velox (link velox - com o modem fazendo a discagem - ip 10.0.0.1)
    eth3 - 201.200.200.24 - (link embratel - reserva)

    / ip firewall nat
    add chain=srcnat out-interface=VELOX action=masquerade
    add chain=srcnat out-interface=EMBRATEL action=masquerade


    /ip firewall > mangle
    add chain=input in-interface=VELOX action=mark-connection new-connection-mark=VELOX_conn
    add chain=input in-interface=EMBRATEL action=mark-connection new-connection-mark=EMBRATEL_conn
    add chain=output connection-mark=VELOX_conn action=mark-routing new-routing-mark=to_VELOX
    add chain=output connection-mark=EMBRATEL_conn action=mark-routing new-routing-mark=to_EMBRATEL

    ja usei tbm o netwatch e nada...


    /ip > dns
    200.222.145.85 / 200.222.123.101 - velox
    200.255.255.65 / 200.255.255.70 - embratel


    / ip route
    add dst-address=0.0.0.0/0 gateway=10.0.0.1 check-gateway=ping (link velox - com o modem fazendo a discagem)
    add dst-address=0.0.0.0/0 gateway=201.200.200.24 check-gateway=ping (link embratel - reserva)


    PRECISO DE UM SCRIPT / SHEDULER

    QUE FACA A MUDANCA DO LINK SOZINHO, POIS, TENHO QUE FAZER MANUALMENTE, ACESSANDO A MIKROTIK E DESATIVANDO O ROUTES DO LINK Q CAIU, E DESFAZENDO QUANDO VOLTAR, JA USEI VARIOS SCRIPTS E NAO CONSEGUI FAZER FUNCIONAR, JA LI O FAILOVER-TUTORIAL, NAO VOU MENTIR A VCS JA ESTOU CANSADO...
    E OUVINDO RECLAMACAO DO MEU PATRAO, FINAL DE SEMANA PASSADO, O LINK VELOX CAIU TIVE Q VIAJAR 50KM SO PARA ATIVAR NA MAO A OUTRA ROTA, ME AJUDEM...

    DEUS ABENCOE A TODOS VCS

  2. #2

    Padrão Re: Redundancia de link so funciona na mao, na marra, pq nao consigo fazer nenhum script / sheduler funciionar

    Citação Postado originalmente por robsonccav Ver Post
    /ip adress
    eth1 - 192.168.5.1/24 - rede interna
    eth2 - 10.0.0.2/24 - link velox (link velox - com o modem fazendo a discagem - ip 10.0.0.1)
    eth3 - 201.200.200.24 - (link embratel - reserva)

    / ip firewall nat
    add chain=srcnat out-interface=VELOX action=masquerade
    add chain=srcnat out-interface=EMBRATEL action=masquerade


    /ip firewall > mangle
    add chain=input in-interface=VELOX action=mark-connection new-connection-mark=VELOX_conn
    add chain=input in-interface=EMBRATEL action=mark-connection new-connection-mark=EMBRATEL_conn
    add chain=output connection-mark=VELOX_conn action=mark-routing new-routing-mark=to_VELOX
    add chain=output connection-mark=EMBRATEL_conn action=mark-routing new-routing-mark=to_EMBRATEL

    ja usei tbm o netwatch e nada...


    /ip > dns
    200.222.145.85 / 200.222.123.101 - velox
    200.255.255.65 / 200.255.255.70 - embratel


    / ip route
    add dst-address=0.0.0.0/0 gateway=10.0.0.1 check-gateway=ping (link velox - com o modem fazendo a discagem)
    add dst-address=0.0.0.0/0 gateway=201.200.200.24 check-gateway=ping (link embratel - reserva)


    PRECISO DE UM SCRIPT / SHEDULER

    QUE FACA A MUDANCA DO LINK SOZINHO, POIS, TENHO QUE FAZER MANUALMENTE, ACESSANDO A MIKROTIK E DESATIVANDO O ROUTES DO LINK Q CAIU, E DESFAZENDO QUANDO VOLTAR, JA USEI VARIOS SCRIPTS E NAO CONSEGUI FAZER FUNCIONAR, JA LI O FAILOVER-TUTORIAL, NAO VOU MENTIR A VCS JA ESTOU CANSADO...
    E OUVINDO RECLAMACAO DO MEU PATRAO, FINAL DE SEMANA PASSADO, O LINK VELOX CAIU TIVE Q VIAJAR 50KM SO PARA ATIVAR NA MAO A OUTRA ROTA, ME AJUDEM...

    DEUS ABENCOE A TODOS VCS
    Não seria hora de contratar um profissional capacitado para lhe prestar esse serviço?



  3. #3

    Padrão Re: Redundancia de link so funciona na mao, na marra, pq nao consigo fazer nenhum script / sheduler funciionar

    Citação Postado originalmente por rogeriodj Ver Post
    não seria hora de contratar um profissional capacitado para lhe prestar esse serviço?

    so estou precisando de um script / sheduler / netwatch, alguem poderia me ajudar, eu sei q estou no caminho certo, so preciso de uma ajuda, compratilhamento de conhcimento, pq sei que estou no lugar certo para tirar esta duvida

  4. #4
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão Re: Redundancia de link so funciona na mao, na marra, pq nao consigo fazer nenhum script / sheduler funciionar

    Boa Noite, me add no skype te. ajudo e depois vc. posta aqui o resultado por que teria q veer estas sua regrasd

    skype : rrodriguesmattos



  5. #5

    Padrão Re: Redundancia de link so funciona na mao, na marra, pq nao consigo fazer nenhum script / sheduler funciionar

    Citação Postado originalmente por demattos Ver Post
    Boa Noite, me add no skype te. ajudo e depois vc. posta aqui o resultado por que teria q veer estas sua regrasd

    skype : rrodriguesmattos


    ja te mandei o convite, ok

  6. #6

    Padrão Re: Redundancia de link so funciona na mao, na marra, pq nao consigo fazer nenhum script / sheduler funciionar

    Citação Postado originalmente por robsonccav Ver Post
    ja te mandei o convite, ok
    Meu caro, nao estou vendo os pesos das rotas. Para se fazer faillover nao precisa de script.

    Da uma olha neste link da mikrotik: http://wiki.mikrotik.com/wiki/Manual:IP/Route



  7. #7

    Padrão Re: Redundancia de link so funciona na mao, na marra, pq nao consigo fazer nenhum script / sheduler funciionar

    Citação Postado originalmente por valdineiq Ver Post
    Meu caro, nao estou vendo os pesos das rotas. Para se fazer faillover nao precisa de script.

    Da uma olha neste link da mikrotik: http://wiki.mikrotik.com/wiki/Manual:IP/Route


    Como podemos fazer fallover sem script? Seria adicionando peso nas rotas?

    Já tentei adicionando peso às rotas, mas somente consegui fazer que um deles seja o default, mas nao consegui fazer ele identificar quando o linkl default cai.

  8. #8

    Padrão Re: Redundancia de link so funciona na mao, na marra, pq nao consigo fazer nenhum script / sheduler funciionar

    Citação Postado originalmente por SantiagoMG Ver Post
    Como podemos fazer fallover sem script? Seria adicionando peso nas rotas?

    Já tentei adicionando peso às rotas, mas somente consegui fazer que um deles seja o default, mas nao consegui fazer ele identificar quando o linkl default cai.


    Usando sua configuração ficaria assim:

    /ip address
    eth1 - 192.168.5.1/24 - rede interna
    eth2 - 10.0.0.2/24 - link velox (default)
    eth3 - 201.200.200.24 - link embratel

    / ip firewall nat
    add chain=srcnat out-interface=VELOX action=masquerade
    add chain=srcnat out-interface=EMBRATEL action=masquerade


    /ip firewall > mangle
    add chain=input in-interface=VELOX action=mark-connection new-connection-mark=VELOX_conn
    add chain=input in-interface=EMBRATEL action=mark-connection new-connection-mark=EMBRATEL_conn
    add chain=output connection-mark=VELOX_conn action=mark-routing new-routing-mark=to_VELOX
    add chain=output connection-mark=EMBRATEL_conn action=mark-routing new-routing-mark=to_EMBRATEL


    Ate aqui é o que voce ja fez. O que mudaria é se voce quer somente failover ou loadbalace com failover


    ### loadbalace com failover
    #
    # estou imaginando que voce esta usando 2 link iguais de capacidade.
    # o trafego fai sair pelos dois e se um cair o outro assume
    #
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.0.0.1,201.200.200.24 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.0.1 check-gateway=ping routing-mark=to_velox
    add dst-address=0.0.0.0/0 gateway=201.200.200.24 check-gateway=ping routing-mark=to_EMBRATEL



    ## OU ASSIM PARA FAILOVER SOMENTE SEM LOADBALACE
    #
    # Nesta opção voce so seta a distancia diferentes na rota que quando uma cair a outra assume
    #
    add dst-address=0.0.0.0/0 gateway=10.0.0.1 check-gateway=ping distance=1
    add dst-address=0.0.0.0/0 gateway=201.200.200.24 check-gateway=ping distance=10

    # repare que para somente failover é colocado os pesos e retirado a primeira rota default que tem os 2 gateway