+ Responder ao Tópico



  1. olá pessoa boa noite,

    é o seguinte: meu modem está em bridge com o mikrotik discando.

    tenho uma conta no no-ip premium..

    criei meu noip para acessar minha rb remotamente, porém acessa hoje e quando vou acessar amanhã nao funciona,

    o erro sei que está na seguinte parte,, o ip da interface pppoe sempre está mudando,

    ex: 177.175.10.104 quando vou olhar la no NO-IP. está diferente, ou seja , nao está atualizando.

    como fazer? pois tentei fazer aqui e nao conseguir,.,..,

  2. Citação Postado originalmente por ruanserver Ver Post
    olá pessoa boa noite,

    é o seguinte: meu modem está em bridge com o mikrotik discando.

    tenho uma conta no no-ip premium..

    criei meu noip para acessar minha rb remotamente, porém acessa hoje e quando vou acessar amanhã nao funciona,

    o erro sei que está na seguinte parte,, o ip da interface pppoe sempre está mudando,

    ex: 177.175.10.104 quando vou olhar la no NO-IP. está diferente, ou seja , nao está atualizando.

    como fazer? pois tentei fazer aqui e nao conseguir,.,..,
    O seu script para atualizar o noip não esta funcionando!



  3. é isso, tentei por o script aqui do forum porém nao estou obtendo exito,,,,,
    Última edição por ruanserver; 21-09-2013 às 22:43.

  4. conseguir,,, a solução usada foi essa aqui,

    # No-IP automatic Dynamic DNS update


    #--------------- Change Values in this section to match your setup ------------------


    # No-IP User account info
    :local noipuser "teste.no-ip.info"
    :local noippass "1234567890"


    # Set the hostname or label of network to be updated.
    # Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
    # To specify multiple hosts, separate them with commas.
    :local noiphost "MINHARB.NO-IP.INFO"


    # Change to the name of interface that gets the dynamic IP address
    :local inetinterface "MINHAINTERFACE"


    # Addon by silviola ( for MK's v. 5.X without DNS configured )
    :local noipadr [:resolve dynupdate.no-ip.com server=8.8.4.4]


    #--------------- ---------------------------------------------------------------------
    # No more changes need


    :global previousIP


    :if ([/interface get $inetinterface value-name=running]) do={
    # Get the current IP on the interface
    :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]


    # Strip the net mask off the IP address
    :for i from=( [:len $currentIP] - 1) to=0 do={
    :if ( [ick $currentIP $i] = "/") do={
    :set currentIP [ick $currentIP 0 $i]
    }
    }


    :if ($currentIP != $previousIP) do={
    :log info "No-IP: IP Atual $currentIP diferente do anterior, atualizando"
    :set previousIP $currentIP


    # The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
    :local url "http://$noipadr/nic/update\3Fmyip=$currentIP"
    :local noiphostarray
    :set noiphostarray [:toarray $noiphost]
    :foreach host in=$noiphostarray do={
    :log info "No-IP: Requisitando atualizacao para $host"
    /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
    :log info "No-IP: IP do Host $host atualizado para $currentIP"
    }
    } else={
    :log info "No-IP: IP anterior $previousIP sem alteracao, atualizacao dispensada"
    }
    } else={
    :log info "No-IP: $inetinterface nao esta atualmente respondendo, logo, a atualizacao nao sera possivel."
    }



  5. pensei que tinha conseguido o meu acesso remoto através deste script, porém sem sucesso.

    aonde é que estou errando pessoal, so mudei apenas o que está em vermelho para os meus dados...






Tópicos Similares

  1. master port/bridge para de funcionar
    Por eduardomazolini no fórum Mikrotik
    Respostas: 2
    Último Post: 30-09-2016, 08:13
  2. Respostas: 6
    Último Post: 24-04-2014, 14:17
  3. Respostas: 8
    Último Post: 12-10-2011, 17:38
  4. Respostas: 4
    Último Post: 04-10-2007, 08:32
  5. Modem em Bridge e Mikrotik em Router. Como?
    Por Arcanjo_tc no fórum Redes
    Respostas: 13
    Último Post: 24-01-2007, 22:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L