+ Responder ao Tópico



  1. Gosto de trabalhar muito com mikrotik principalmente com regras de firewall e script, passei pra poucas pessoas algumas coisas que sei, claro que mikrotik cada vez mais você estuda mais você sabe que não sabe, tipo a bíblia cada vez que você ler mais você aprende e quando volta no mesmo assunto você descobre mais assim e o mikrotik. atualmente faço manutenções pra alguns provedores porte médio alto, só que quero estar passando um pouco a cada tempo do que seu sei ei estar ai as regras bem fácil de automatizar sua pagina de bloqueio sem bug.
    1ª a regra do nat todos já conhece ai estar ela só colocar o ip do seu MK-Auth, para melhor aproveitamento coloca regra do nat no topo.
    copie a regra para um bloco de nota coloca o ip do mk-auth depos copie no terminal do mikrotik. pronto
    /ip firewall nat
    add action=dst-nat chain=dstnat comment="=====================================\
    ====Manutencao-cleber-Mk-auth========================================" \
    disabled=yes dst-port=80 priority=1 protocol=tcp src-address=! IP-DO SERVIDOR MK-AUTH \
    to-addresses=IP-MK-AUTH to-ports=89
    2ª já estou mandando a regra do script prontinha pra você colar direto no terminal do seu mikrotik. Ctrl-c , Ctrl-V.
    a sim antes pra você saber mais sobre a regra abaixo, ela manda 20 pins pro dns da google caso falha os 20 pings em seguida ela ativa a regra do nat, assim faz que direcione pra pagina de manutenção, quando NORMALIZAR os pings a mesma regra desativa o comando de manutenção e tudo volta como era.

    /system script
    add name=Manutencao-cleber policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=":\
    local i [ping 8.8.8.8 count=20]; :if (\$i = 0) do={/ip firewall nat enable \
    [find comment=\"=========================================Manutencao-cleber-\
    Mk-auth========================================\"];} else={/ip firewall nat\
    \_disable [find comment=\"=========================================Manutenc\
    ao-cleber-Mk-auth========================================\"];};"

    3ª para todos os scripts precisamos de scheduler, essa regra também é só copiar e colar direto no terminal do mikrotik, ela manda o comando para o script de 2 em 2 minutos sem da LOG no seu sistema, faz em silêncio.
    /system scheduler
    add interval=2m name=Manutencao-cleber on-event=Manutencao-cleber policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive start-date=jan/01/1970 \
    start-time=00:00:00

    OBS: essas regras fiz na versão 6X do mikrotik, pela minha teoria eh só tirar a prioridade da regra do nat acima que funciona na versão 4 e 5X.
    (toda semana vou estar postando regras funcional)
    Quem entende um pouco de regras de mikrotik, pode mudar alguns detalhe de ex: o comentário.
    agradeço a todos desse fórum.
    curti no facebook: sosprovedor
    061-82108050
    Última edição por sosprovedor; 17-10-2013 às 11:32. Razão: correição de regra

  2. Olá, bom dia. Parabéns pela ótima iniciativa, será de grande ajuda!

    Eu uso aqui esse redirecionamento p/ pagina de manutenção, porém uso c/ netwatch, funciona bem. Como você citou que podemos dar sugestões as regras, vou citar o que uso aqui.

    Na regra do NAT, onde você citou src-address=0.0.0.0/0
    eu uso assim: src-address=!10.2.5.251 dessa forma a regra vale p/ todos da minha rede c/ exceção a minha conexão aqui do escritório, pois estou dentro da rede do provedor e dessa forma a pagina de manutenção não aparece pra mim e me possibilita acessar tudo dentro da rede, desde os enlaces até o meu balance que fica em outro ponto.

    Por exemplo: c/ a regra valendo p/ todos inclusive pra mim (src-address=0.0.0.0/0), eu não tenho acesso aos nanos dos enlaces que tenho pra estar verificando se algum caiu ou travou, ou coisas do tipo.

    Também uso dst-address=!172.31.255.2 assim também não perco o acesso ao mk-auth durante alguma falha da rede.

    Bom, é isso.

    Abraço.



  3. obrigado ótima observação.

  4. Citação Postado originalmente por sosprovedor Ver Post
    obrigado ótima observação.
    Blz, me adiciona no skype, vamos trocar umas ideias, abraço.

    Skype: fcmanutencao



  5. Blz

    Citação Postado originalmente por FabianoMartins2 Ver Post
    Blz, me adiciona no skype, vamos trocar umas ideias, abraço.

    Skype: fcmanutencao






Tópicos Similares

  1. Respostas: 8
    Último Post: 18-05-2013, 21:19
  2. Respostas: 111
    Último Post: 12-02-2013, 21:26
  3. Respostas: 15
    Último Post: 20-12-2010, 09:06
  4. Respostas: 17
    Último Post: 23-04-2010, 17:16
  5. como enviar uma pagina de corte
    Por wescleybueno1 no fórum Redes
    Respostas: 2
    Último Post: 31-03-2009, 06:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L