+ Responder ao Tópico



  1. #1
    Avatar de Tomasi
    Ingresso
    Aug 2011
    Localização
    São José do Rio Claro - MT
    Posts
    11

    Question Como entregar um IP público /30 para o cliente utilizando PPPoE?

    Bom dia,

    estou com a seguinte dificuldade:

    Meu servidor distribui 1 IP público para cada autenticação PPPoE. Na WAN o cliente possui um IP público e na LAN configuramos NAT para uma faixa local 192.168.x.x/24. Até aí tudo normal.

    Hoje preciso configurar de maneira diferente: meu cliente com roteador Aker não está estável utilizando PPPoE. Preciso então, autenticar PPPoE numa RB-450 (WAN com IP público) e entregar na LAN um IP público para ele (bloco /30), sem NAT.
    As rotas internas da rede estão configuradas.

    Verifiquei que, quando utilizo Ubiquiti essa técnica funciona normalmente.
    Quando utilizo Mikrotik na autenticação PPPoE, a navegação (porta 80) não funciona. (Winbox, Skype, VPN, ping funcionam normalmente)

    Em ambos os casos, utilizei MTU e MRU 1480.

    Alguma sugestão?

  2. #2

    Padrão Re: Como entregar um IP público /30 para o cliente utilizando PPPoE?

    Disca PPPoE na interface correta do Mikrotik (ether1 por exemplo).
    Marca para o PPPoE estabelecer a rota default.

    Estabelecendo o PPP seu Mikrotik deve estar navegando, correto (faz um teste de ping para fora da sua rede)?

    Coloque em outra interface de rede (ether2 por exemplo) o ip do /30 que será o gateway do cliente.
    Não habilite NAT. Habilite o Tracking (Ip->Firewall->Connections).

    E então ligue o cabo de rede na ether2 e coloque o ip do /30 que será utilizado pelo cliente.

    Lembre de colocar as mascaras e tudo certo.. lembrando do endereço de rede e broadcast.

    Após isso seu cliente deve estar pingando o seu gateway (Mikrotik).

    E no servidor deve estar feita a rota especificando atrás de qual ip de transporte está essa rede /30.. senão não funcionará.



  3. #3
    Avatar de Tomasi
    Ingresso
    Aug 2011
    Localização
    São José do Rio Claro - MT
    Posts
    11

    Question Re: Como entregar um IP público /30 para o cliente utilizando PPPoE?

    Certo, o PPPoE já está autenticando atráves de um túnel EoIP (a rede está roteada com OSPF).

    O primeiro IP (200.200.200.1/30, por exemplo) já está configurado na ether2 com máscara de rede apropriada (255.255.255.252). Não tem NAT configurada no roteador, a Conntrack está habilitada.

    As rotas no servidor e no roteador de borda já estão configuradas. (dst-address=200.200.200.0/30 gateway=201.201.201.201 reachable <[email protected]>

    O cliente está configurado com o segundo IP público na WAN (200.200.200.2/30, por exemplo). A partir do Aker ou notebook ele pinga a RB, o servidor e qualquer site. O problema é que apenas páginas web (http, porta 80) não carregam. Skype, VPN, Winbox estão funcionando perfeitamente

    E essa falha ocorre apenas com Mikrotik. Se eu utilizar Ubiquiti para autenticar PPPoE na WLAN e configurar IP público na LAN, funciona sem problemas.

  4. #4

    Padrão Re: Como entregar um IP público /30 para o cliente utilizando PPPoE?

    Citação Postado originalmente por Tomasi Ver Post
    Certo, o PPPoE já está autenticando atráves de um túnel EoIP (a rede está roteada com OSPF).

    O primeiro IP (200.200.200.1/30, por exemplo) já está configurado na ether2 com máscara de rede apropriada (255.255.255.252). Não tem NAT configurada no roteador, a Conntrack está habilitada.

    As rotas no servidor e no roteador de borda já estão configuradas. (dst-address=200.200.200.0/30 gateway=201.201.201.201 reachable <[email protected]>

    O cliente está configurado com o segundo IP público na WAN (200.200.200.2/30, por exemplo). A partir do Aker ou notebook ele pinga a RB, o servidor e qualquer site. O problema é que apenas páginas web (http, porta 80) não carregam. Skype, VPN, Winbox estão funcionando perfeitamente

    E essa falha ocorre apenas com Mikrotik. Se eu utilizar Ubiquiti para autenticar PPPoE na WLAN e configurar IP público na LAN, funciona sem problemas.
    Bem estranho.. eu utilizo dessa mesma maneira aqui.. (Só que com VPLS no lugar de EoIP)

    Se quiser posso dar uma olhada por teamviewer..



  5. #5
    Avatar de Tomasi
    Ingresso
    Aug 2011
    Localização
    São José do Rio Claro - MT
    Posts
    11

    Talking Re: Como entregar um IP público /30 para o cliente utilizando PPPoE?

    Bom dia,

    Consegui resolver o problema através de um procedimento simples > faltava rota para o bloco /30 do cliente no cache (que é o responsável por todos as solicitações à porta 80).

    Fica a dica para quem quiser entregar IP público utilizando PPPoE. Agora funcionou normalmente.