+ Responder ao Tópico



  1. Boa Tarde....
    O que seria Blackhole?
    Por que é interessante criar uma regra com o mesmo em ip route?

  2. Citação Postado originalmente por elmikrotik Ver Post
    O que seria Blackhole?
    Citação Postado originalmente por elmikrotik Ver Post
    Por que é interessante criar uma regra com o mesmo em ip route?
    Boa tarde.

    Um buraco negro (no inglês "black hole") é um área dentro das dimensões espaciais e temporais, em que nada dele escapa, mesmo sendo algo deslocando-se na velocidade da luz (a própria luz, inclusive). Analogicamente falando, no contexto computacional, podemos comparar black hole ao /dev/null.

    Encaminhar uma rota para um buraco negro, equivale a neutralizar o alcance, a partir do roteador no qual foi definida a regra.

    Há tópicos[1][2][3], aqui no Portal Under-Linux, que podem auxiliar sobre o conceito e utilização de black holes

    [1] https://under-linux.org/showthread.p...328#post597328
    [2] https://under-linux.org/showthread.p...730#post604730
    [3] https://under-linux.org/showthread.p...407#post586176



  3. Citação Postado originalmente por trober Ver Post
    Boa tarde.

    Um buraco negro (no inglês "black hole") é um área dentro das dimensões espaciais e temporais, em que nada dele escapa, mesmo sendo algo deslocando-se na velocidade da luz (a própria luz, inclusive). Analogicamente falando, no contexto computacional, podemos comparar black hole ao /dev/null.

    Encaminhar uma rota para um buraco negro, equivale a neutralizar o alcance, a partir do roteador no qual foi definida a regra.

    Há tópicos[1][2][3], aqui no Portal Under-Linux, que podem auxiliar sobre o conceito e utilização de black holes

    [1] https://under-linux.org/showthread.p...328#post597328
    [2] https://under-linux.org/showthread.p...730#post604730
    [3] https://under-linux.org/showthread.p...407#post586176


    Obrigado pela ajuda
    Entao se eu criar esta regra em meu roteador principal onde todos os outros roteadores estao conectados, em ip route o DST-Address meu AS e o Type Blackholes qual seria o efeito desta regra?

    Ela seria usada para negar um ataque dentro da rede interna, desculpe se estiver falando besteira, mas se puderem me ajudar a esclarecer desde ja agradeço.

  4. Citação Postado originalmente por elmikrotik Ver Post
    Entao se eu criar esta regra em meu roteador principal onde todos os outros roteadores estao conectados, em ip route o DST-Address meu AS e o Type Blackholes qual seria o efeito desta regra?
    O seu remote-peer ficará inalcançável.

    Citação Postado originalmente por elmikrotik Ver Post
    Ela seria usada para negar um ataque dentro da rede interna, desculpe se estiver falando besteira, mas se puderem me ajudar a esclarecer desde ja agradeço.
    Vamos considerar o seguinte cenário:

    [rtr-A]-----[rtr-B]-----[rtr-C]-----[rtr-D]-----[rtr-E]

    rtr-A é o roteador que está na borda da rede, sendo ou não sendo AS, sendo ou não sendo um simples NAT de uma rede SOHO.

    Então você adiciona, em rtr-A, a seguinte regra:

    Código :
    /ip route add dst-address=200.160.0.8 type=blackhole comment="black hole test"

    Como resultado, em todos os encaminhamentos, no qual rtr-A iria encaminhar para o gateway correspondente, e que tenha como destino o endereço (de exemplo) 200.160.0.8, será neutralizada a ação (de encaminhamento), sendo aplicável à todas as requisições encaminhadas em rtr-A (em qualquer direção).

    É bem menos penosa esta forma de "bloqueio", na perspectiva do custo computacional, do que filtrar usando regras de firewall

    Se você tem AS, pode usar communities para distribuir a regra de black hole, deixando (desejavelmente) mais próxima do ponto de origem de um ataque. Mais deixamos esta conversa para um outro momento.

    E sim, você pode (e deve) neutralizar ataques originados dentro de sua rede. Se conseguir neutralizar no ativo mais próximo da fonte do ataque, melhor. Serão menos ativos e circuitos degragados, e uma rede menos congestionada



  5. Citação Postado originalmente por trober Ver Post
    O seu remote-peer ficará inalcançável.



    Vamos considerar o seguinte cenário:

    [rtr-A]-----[rtr-B]-----[rtr-C]-----[rtr-D]-----[rtr-E]

    rtr-A é o roteador que está na borda da rede, sendo ou não sendo AS, sendo ou não sendo um simples NAT de uma rede SOHO.

    Então você adiciona, em rtr-A, a seguinte regra:

    Código :
    /ip route add dst-address=200.160.0.8 type=blackhole comment="black hole test"

    Como resultado, em todos os encaminhamentos, no qual rtr-A iria encaminhar para o gateway correspondente, e que tenha como destino o endereço (de exemplo) 200.160.0.8, será neutralizada a ação (de encaminhamento), sendo aplicável à todas as requisições encaminhadas em rtr-A (em qualquer direção).

    É bem menos penosa esta forma de "bloqueio", na perspectiva do custo computacional, do que filtrar usando regras de firewall

    Se você tem AS, pode usar communities para distribuir a regra de black hole, deixando (desejavelmente) mais próxima do ponto de origem de um ataque. Mais deixamos esta conversa para um outro momento.

    E sim, você pode (e deve) neutralizar ataques originados dentro de sua rede. Se conseguir neutralizar no ativo mais próximo da fonte do ataque, melhor. Serão menos ativos e circuitos degragados, e uma rede menos congestionada


    Desde ja agradeço pelos esclarecimentos e duvidas tiradas.
    Muito obrigado






Tópicos Similares

  1. BGP Blackhole
    Por mtrojahn no fórum Servidores de Rede
    Respostas: 1
    Último Post: 25-09-2008, 14:37
  2. Como remover meu ip da lista blackhole.securitysage.com
    Por alankreis no fórum Servidores de Rede
    Respostas: 0
    Último Post: 13-02-2008, 12:01
  3. Guerra Anti spam - usando lista blackholes.us
    Por Daniels no fórum Servidores de Rede
    Respostas: 6
    Último Post: 25-04-2005, 16:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L