Bom dia,

Com o aumento da rede vi a necessidade de realizar backup das informações periodicamente, então pesquisei alguns métodos e ajustei para o que realmente queria que fosse feito, então disponibilizo o script e o agendamento para quem quiser implementar em sua rede.
O backup é feito para um FTP enviando diretamente os arquivos para uma pasta respeitando o mês e o dia, portanto a data e hora devem estar corretas e sincronizadas.

OBS:
- Testado em versões 5.X e superiores.
- O script cria 4 arquivos, dos dados de IP ADDRESS, WIRELESS, NETWATCH e ROUTE, com o padrão de nomes identity_wireless.rsc e assim para os outros arquivos, então no system identity coloco a identificação da placa para ser fácil de localizar depois para uma eventual restauração, o que deve ser cuidado é a questão do nome utilizado no identity, que não deve conter espaços, deve ser preenchida por underline ( _ ), e não deve conter acentuação e caracteres especiais como / * - + . ? : ; > , < ~ ^ } { [ ] = - ) ( & % $ # @ ! ' " | \
- Os campos address, user e password devem ser substituídos pelos dados do FTP que será feita a conexão, deve ser retirado as "" (aspas), e lembrar que o usuário do FTP deve ter permissão de gravação.
- Após o upload dos arquivos o script remove automaticamente os arquivos criados do file no Mikrotik.
- IMPORTANTE: no FTP, na pasta raiz onde será enviado os arquivos, deve ser criado a árvore das pastas para que o script apenas envie o arquivo para a pasta certa, a regra para criação das pastas é mês é o diretório e dia é subdiretório do mês, mês é em inglês (respeitando a padrão do RouterOS), abreviado (3 letras) e letras em caixa baixa, dia deve ser numérico de 2 dígitos, exemplo (feb, mar, apr, 01, 02, 03, 31). A imagem ilustra como deve ser feito com todas as pastas.
Clique na imagem para uma versão maior

Nome:	         diretorios.jpg
Visualizações:	188
Tamanho: 	23,6 KB
ID:      	49158


Script
Código :
/system scriptadd name="Remover Arquivos de Backup" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/file remove ([/system identity get name].\"_ip.rsc\");\r\
    \n/file remove ([/system identity get name].\"_rotas.rsc\");\r\
    \n/file remove ([/system identity get name].\"_netwatch.rsc\");\r\
    \n/file remove ([/system identity get name].\"_wireless.rsc\");"
add name="Upload de Arquivos de Backup para FTP" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source=":global Date [/system clock get date];\r\
    \n/tool fetch address="ENDEREÇO DO SERVIDOR FTP" src-path=([/system identity get name].\
    \"_ip.rsc\") dst-path=([:pick \$Date 0 3].\"/\".[:pick \$Date 4 6].\"/\".[\
    /system identity get name].\"_ip.rsc\") mode=ftp user="USUÁRIO DO FTP" password="SENHA DO FTP" upload=yes;\r\
    \n/tool fetch address="ENDEREÇO DO SERVIDOR FTP" src-path=([/system identity get name].\
    \"_rotas.rsc\") dst-path=([:pick \$Date 0 3].\"/\".[:pick \$Date 4 6].\"/\
    \".[/system identity get name].\"_rotas.rsc\") mode=ftp user="USUÁRIO DO FTP" password="SENHA DO FTP" upload=yes;\r\
    \n/tool fetch address="ENDEREÇO DO SERVIDOR FTP" src-path=([/system identity get name].\
    \"_netwatch.rsc\") dst-path=([:pick \$Date 0 3].\"/\".[:pick \$Date 4 6].\
    \"/\".[/system identity get name].\"_netwatch.rsc\") mode=ftp user="USUÁRIO DO FTP" password="SENHA DO FTP" upload=yes;\r\
    \n/tool fetch address="ENDEREÇO DO SERVIDOR FTP" src-path=([/system identity get name].\
    \"_wireless.rsc\") dst-path=([:pick \$Date 0 3].\"/\".[:pick \$Date 4 6].\
    \"/\".[/system identity get name].\"_wireless.rsc\") mode=ftp user="USUÁRIO DO FTP" password="SENHA DO FTP" upload=yes;\r\
    \n"
    add name="Criar Arquivos de Backup" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/ip address export file=([/system identity get name].\"_ip.rsc\");\
    \r\
    \n/ip route export file=([/system identity get name].\"_rotas.rsc\");\r\
    \n/tool netwatch export file=([/system identity get name].\"_netwatch.rsc\
    \");\r\
    \n/interface wireless export file=([/system identity get name].\"_wireless\
    .rsc\");"

- O agendamento está configurado como diariamente as 12:00 horas, mas isso é configurável pela necessidade de cada um.
Scheduler
Código :
/system scheduler
add disabled=no interval=1d name="Criar Arquivos de Backup" on-event=\
    "Criar Arquivos de Backup" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-date=jun/25/2013 start-time=12:00:00
add disabled=no interval=1d name="Upload de Arquivos de Backup para FTP" \
    on-event="Upload de Arquivos de Backup para FTP" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-date=jun/25/2013 start-time=12:10:00
add disabled=no interval=1d name="Remover Arquivos de Backup" on-event=\
    "Remover Arquivos de Backup" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-date=jun/25/2013 start-time=12:20:00

Espero ter ajudado.
Atenciosamente.