+ Responder ao Tópico



  1. #1

    Padrão Mpls/vpls mtu

    Bom dia amigos.

    No nosso provedor temos um anel redundante com 6 pontos e um autenticador PPPoE no meio centralizando tudo. Esse anel centraliza as redes utp próximas e leva tudo pro concentrador dentro do CPD. Hoje usamos RSTP+VLAN porem estou estudando a implementação de OSPF+MPLS+VPLS pois o tempo de convergência em caso de falha é muito menor.

    Em bancada, refiz o cenário e configurei roteador por roteador na unha, tudo funcionando perfeitamente e os backups prontos para serem restaurados nos roteadores que estão em produção porem surgiu um problema.

    Entre os nós na rede, usamos conversores giga/fast ethernet e fibra ótica entre os pontos, mas, os conversores só suportam um MTU de 1504. E agora, o que fazer ? Não vai dar ? Deixo fragmentar ?

    Agradeço sugestões desde já.

  2. #2

    Padrão Re: Mpls/vpls mtu

    Pq vc quer mtu maior que 1504?



  3. #3

    Padrão Re: Mpls/vpls mtu

    As interfaces LDP que eu seto no MPLS tem que transportar um MTU de 1508, estou certo ?

  4. #4

    Padrão Re: Mpls/vpls mtu

    O valor que tu seta na ldp eh o valor maximo. Eu rodo pppoe aqui usando 1488. Se tu usar mais que 1488 no pppoe nao vai funcionar, pq somado aos bits a mais que sao acrescentados no pacote passa de 1508.



  5. #5

    Padrão Re: Mpls/vpls mtu

    Uso 1480 no PPP, então com 1500 de MTU nas interfaces consigo rodar o ospf+mpls+vpls pra centralizar o pppoe tranquilo ?

  6. #6

    Padrão Re: Mpls/vpls mtu

    Sim... Mas tu pode deixar com 1508.



  7. #7

    Padrão Re: Mpls/vpls mtu

    Fiz o seguinte cenário pra teste.

    Router A > Conversor A > Coversor B > Router B.

    Entre os 2 existe o OSPF e o MPLS, com um tunel VPLS.

    Se eu plugo o cabo no Router B, na interface com o tunel VPLS e tento acessar o Router A não acessa.
    Se eu plugo o cabo no Router B, na interface com o tunel VPLS e tento acessar o Router A sem o conversor no meio acessa normal.

    Se eu plugo o cabo no Router A, em uma interface qualquer com IP e tento acessar o router B por fora do tunel, acessa.

    Sera que o conversor não consegue transportar os pacotes do tunel vpls ?

    PS: Mtu de todas as interfaces em 1500

  8. #8

    Padrão Re: Mpls/vpls mtu

    Cara, tem que colocar a interface de rede e o tunel vpls numa bridge.



  9. #9

    Padrão Re: Mpls/vpls mtu

    Sim, eu sei disso.

    Tanto é que, sem o conversor no meio eu consigo chegar do outro lado do tunel e acessar o Router A normal. Mas com o conversor no meio não.

    Esses conversores... :/

    Citação Postado originalmente por achiodi Ver Post
    Cara, tem que colocar a interface de rede e o tunel vpls numa bridge.

  10. #10

    Padrão Re: Mpls/vpls mtu

    Eu tive um problema assim no inicio e era o mtu. O conversor eh apenas um dispositivo em bridge nao? pq se for tem que passar.



  11. #11

    Padrão Re: Mpls/vpls mtu

    O engraçado é que, o MTU ta 1500 em todas as interfaces. E com o conversor no meio ele não passa, sem o conversor no meio funciona normalmente.

    Se eu tento acessar o roteador por fora do tunel ( em uma interface com ip qualquer, o ospf distribui a rota para o outro roteador, então o acesso é feito pelo roteamento dinamico e não pelo vpls ) funciona normal. Da a entender que o tunel vpls não passa pelo conversor, mas... não tem lógica, uma vez que pelo cabo funciona normal e o conversor é um dispositivo "bridge". A unica limitação do conversor é o MTU de 1504, mas, as interfaces estão todas em 1500.

  12. #12

    Padrão Re: Mpls/vpls mtu

    O PPPoE esta passando?



  13. #13

    Padrão Re: Mpls/vpls mtu

    Não testei, irei testar.

  14. #14

    Padrão Re: Mpls/vpls mtu

    PPPoE conecta mas não navega, ping ok mas, se tento navegar não vai. Sem o conversor no meio funciona normalmente.



  15. #15

    Padrão Re: Mpls/vpls mtu

    É tamanho de mtu entao.

  16. #16

    Padrão Re: Mpls/vpls mtu

    Fiz o teste do mesmo jeito porem troquei os conversores por 2 /100 que eu tinha aqui, funcionou perfeito, com os conversores gigabit não vai. Fiz o teste com outros 2 gigabit que eu tinha aqui e da a mesma coisa, no /100 vai normal.

    Mandei email para a fabricante desses conversores, sem resposta por enquanto :/



  17. #17

    Padrão Re: Mpls/vpls mtu

    Seta dentro do menu MPLS onde tem a configuração de MTU, por padrão ela vem com interface:

    All : 1508
    Muda para:
    All : 1500

    Nos 2 routers.
    E testa..

  18. #18

    Padrão Re: Mpls/vpls mtu

    Citação Postado originalmente por klabundee Ver Post
    Seta dentro do menu MPLS onde tem a configuração de MTU, por padrão ela vem com interface:

    All : 1508
    Muda para:
    All : 1500

    Nos 2 routers.
    E testa..
    Funcionou :O

    Tinha conversado com o pessoal da engenharia da empresa que fabricou os conversores e eles ficaram de ver esse caso pra mim e até agora não responderam, nesses últimos dias tava corrido e não deu pra testar, porem fiz isso agora no laboratorio e funcionou perfeitamente. Obrigado amigo!