+ Responder ao Tópico



  1. Boa noite pessoal, andei pesquisando mas não encontrei, por isso resolvi postar aqui.

    Gostaria de saber se é possível passar a informação para o parâmetro parent da simple queue através de radius quando um cliente pppoe se conecta.

    Hoje minha rede trabalha com pppoe em cima de mikrotik conversando com radius, faço o controle de banda, mas gostaria de passar a trabalhar também com a informação de garantia de banda, e pelo que andei lendo, a garantia só tem como ser respeitada caso a queue esteja dentro de uma outra queue pai (parent) para que o mikrotik possa saber através dessa queue pai qual o meu link total, deixando o cliente na garantia em momentos de sufoco no link, e deixando ele confortável no max-limit quando o link está folgado.

    Alguém saberia informar se é possível e dar uma luz de como faço isso ?

  2. Citação Postado originalmente por gustavo_marcon Ver Post
    Boa noite pessoal, andei pesquisando mas não encontrei, por isso resolvi postar aqui.

    Gostaria de saber se é possível passar a informação para o parâmetro parent da simple queue através de radius quando um cliente pppoe se conecta.

    Hoje minha rede trabalha com pppoe em cima de mikrotik conversando com radius, faço o controle de banda, mas gostaria de passar a trabalhar também com a informação de garantia de banda, e pelo que andei lendo, a garantia só tem como ser respeitada caso a queue esteja dentro de uma outra queue pai (parent) para que o mikrotik possa saber através dessa queue pai qual o meu link total, deixando o cliente na garantia em momentos de sufoco no link, e deixando ele confortável no max-limit quando o link está folgado.

    Alguém saberia informar se é possível e dar uma luz de como faço isso ?
    Você pode fazer isso pelo proprio MK, sem precisar receber esses dados do Radius.

    Vá em PPP > Profile
    Clique em cima do profile principal, geralmente o default.
    Vá na aba Queue, na opção parent seleciona o desejado.

    Pronto, todo cliente que se autenticar vai usar aquele parent configurado.
    PS: opção disponível apenas na versão mk 6.x



  3. Entendi, realmente uma boa saída.

    Só fiquei com uma dúvida.

    Como minha rede é roteada e meus clientes autenticam nos POPs, essa minha regra pai terá que ser feita em cada concentrador, certo ?

    Neste caso, em cada concentrador terei esta regra com o valor total do meu link.

    Sendo assim, não haverá o controle da garantia de banda....

    Ou estou pensando da forma errada ?


    Obrigado desde já pelo retorno.

  4. Citação Postado originalmente por gustavo_marcon Ver Post
    Entendi, realmente uma boa saída.

    Só fiquei com uma dúvida.

    Como minha rede é roteada e meus clientes autenticam nos POPs, essa minha regra pai terá que ser feita em cada concentrador, certo ?

    Neste caso, em cada concentrador terei esta regra com o valor total do meu link.

    Sendo assim, não haverá o controle da garantia de banda....

    Ou estou pensando da forma errada ?


    Obrigado desde já pelo retorno.

    aqui eu utilizo um script pra planos banda larga ele compara o up e o dow se o valor for diferente ele joga na queue Qos_bandalarga.




    Código HTML:
    # Procura Queue dinamicas e na condicao de estar sem parent=none
    # adiciona a QoS Geral na queeu dinamic
    #-----------------------------------------------------------------------------------
    # SETANDO AS VARIAVEIS GLOBAIS
    :global Limit 0
    :global tpos
    :global dRate 0
    :global uRate 0
    :global GRUPO
    
    
    
    
    :foreach id in=[/queue simple find dynamic] do={
    
    
    # SCRIPT QoS
    # BANDA Dowload / Upload
    :set Limit [/queue simple get $id max-limit]
    
    
    # Verifica qual linha encontro "/"
    :set tpos [:tonum ([:pic [:find $Limit "/"]] +1)]
    
    
    # Captura Banda Download
    :set dRate [:pic $Limit $tpos 30]
    
    
    # Captura Banda Upload
    :set uRate [:pic $Limit 0 ($tpos -1)]
    
    
    
    
    :if ([/queue simple get $id parent]="none") do={
    
    
    :if ($dRate = $uRate) do= {
    :put [/queue simple set $id parent="none"]
    :put [/queue simple set $id queue=default/default total-queue=default]
    :put [/queue simple move numbers=$id QoS_BANDALARGA]
    } else={
    :set GRUPO QoS_BANDALARGA
    :put [/queue simple set $id parent="$GRUPO"]
    }
    
    
    
    
    }
    }





    essa regra abaixo e outro script pra limpar os parents, se tiver algo errado



    Código HTML:
    # Procura Queue dinamicas e na condicao de estar sem parent=none
    # adiciona a QoS Geral na queeu dinamic
    #-----------------------------------------------------------------------------------
    :foreach i in=[/queue simple find dynamic] do={ 
    
    
    ut [/queue simple set $i parent="none"] 
    
    
    }
    Última edição por isacloko; 21-02-2014 às 13:11.






Tópicos Similares

  1. Fixar Mac a IP através de Radius com pppoe
    Por pruonckk no fórum Redes
    Respostas: 4
    Último Post: 28-12-2009, 08:09
  2. Limite de Downloads atraves do Radius
    Por mgn5005 no fórum Redes
    Respostas: 0
    Último Post: 26-02-2009, 14:04
  3. Acesso externo através de subredes
    Por AndrewAmorimdaSilva no fórum Servidores de Rede
    Respostas: 6
    Último Post: 30-10-2002, 11:35
  4. Comunicação de dominios NT através de Firewall
    Por Spetsnaz no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-09-2002, 14:15
  5. Acesso atraves de Telnet ...
    Por MarcelScan no fórum Servidores de Rede
    Respostas: 1
    Último Post: 09-05-2002, 10:28

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L