+ Responder ao Tópico





  1. Eis um script para o monitoramento de hosts via netwatch que envia um e-mail caso haja a queda do IP que estiver sendo monitorado, bastando adicionar o script abaixo em netwatch-down e alterando os valores de:

    "seuemail@gmail.com"
    "suasenha"
    "destinodoaviso@provedor.com"


    peço que mantenham os créditos no inicio e claro se for útil a você clique em agradecer ali embaixo, qualquer problema me avisem...


    Código :
     
    #---------------------------------------------------------
    #---=== MONITORAMENTO NETWATCH COM AVISO POR E-MAIL ===---
    #---===--Compilador por: LUCIANO RAMPANELLI / M4D3--===---
    #---===----------22/02/2014 - Mikrotik V6.9---------===---
    #---------------------------------------------------------
     #
    #---=== CONFIGURAÇÃO DA CONTA DE E-MAIL ===---
    :local servermailip [:resolve "smtp.gmail.com" ]
    :local servermailport "587"
    :local servermailtls "yes"
    :local fromemail "seuemail@gmail.com"
    :local passemail "suasenha"
    :local toemail "destinodoaviso@provedor.com" 
    #
    #---=== CAPTURA DE VARIÁVEIS LOCAIS ===---
    :local idlocal ([/system identity get name] . "/" . [/system license get software-id]);
    :local datenow ([:pick [/system clock get date] 4 6] . "/" . [:pick [/system clock get date] 0 3] . "/" . [:pick [/system clock get date] 7 11]);
    :local timenow ([:pick [/system clock get time] 0 2] . ":" . [:pick [/system clock get time] 3 5] . ":" . [:pick [/system clock get time] 6 8]);
    :local ipremote $host
    #
    #---=== MONTAGEM DAS MENSAGENS ===---
    :local subemail "Monitor de $ipremote acusou falha em $datenow / $timenow"
    :log info message="Monitor de $ipremote acusou falha em $datenow as $timenow - Enviando aviso por email para: $toemail"
    #
    #---=== ENVIO DE E-MAIL ALERTA ===---
    /tool e-mail send start-tls=$servermailtls subject=$subemail user=$fromemail password=$passemail to=$toemail port=$servermailport server=$servermailip body="O monitoramento em $idlocal encontrou uma falha na comunicação com $ipremote em $datenow as $timenow"

    Para utilizar este script em MikroTik Router OS v5.xx altere a linha de envio do e-mail de 'start-tls' para 'tls='


    Abraço a todos

  2. Showwww






Tópicos Similares

  1. Respostas: 2
    Último Post: 24-02-2014, 17:36
  2. Respostas: 6
    Último Post: 23-04-2010, 07:43
  3. Liberar acesso Area de trabalho remoto pelo MAC
    Por Eduardo_Alves no fórum Servidores de Rede
    Respostas: 1
    Último Post: 15-06-2009, 08:54
  4. Script de monitoramento de servidor com RRDTOOL
    Por fdotta no fórum Linguagens de Programação
    Respostas: 4
    Último Post: 28-09-2004, 16:55
  5. Monitoramento de rede com gráfico????
    Por c4f0f0 no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-11-2003, 07:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L