+ Responder ao Tópico






  1. Eis um script para o envio de backup por e-mail, bastando adicionar o script no seu mikrotik e rodar via scheduler ou manutalmente, alterando os valores de:

    "suaconta@gmail.com"
    "suasenha"
    "destinodobackup@provedor.com"


    peço que mantenham os créditos no inicio e claro se for útil a você clique em agradecer ali embaixo, qualquer problema me avisem...



    Código :
     
    #---------------------------------------------------------
    #---===--- GERAÇÃO DE BACKUP COM ENVIO POR E-MAIL --===---
    #---===--Compilador por: LUCIANO RAMPANELLI / M4D3--===---
    #---===----------22/02/2014 - Mikrotik V6.9---------===---
    #---------------------------------------------------------
    #
    #---=== CONFIGURAÇÃO DA CONTA DE E-MAIL ===---
    :local servermailip [:resolve "smtp.gmail.com" ]
    :local servermailport "587"
    :local servermailtls "yes"
    :local fromemail "suaconta@gmail.com"
    :local passemail "suasenha"
    :local toemail "destinobackup@provedor.com" 
    #
    #---=== CAPTURA DE VARIÁVEIS LOCAIS ===---
    :local idlocal ([/system identity get name] . "/" . [/system license get software-id]);
    :local datenow  ([:pick [/system clock get date] 4 6] . "/" .  [:pick [/system clock get date] 0 3] . "/" . [:pick [/system clock get date] 7 11]);
    :local timenow ([:pick [/system clock get time] 0 2] . ":" . [:pick [/system clock get time] 3 5] . ":" . [:pick [/system clock get time] 6 8]);
    :local bkpname [([/system identity get name] . "_" . [/system license get software-id] . "_" . [:pick [/system clock get date] 4 6] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 7 11] . "_" . [:pick [/system clock get time] 0 2] . [:pick [/system clock get time] 3 5] . [:pick [/system clock get time] 6 8] .".backup")];
    #
    #---=== MONTAGEM DAS MENSAGENS ===---
    :local subemail "BACKUP de $idlocal gerado em $datenow as $timenow"
    :log info message="Backup de $idlocal gerado em $datenow as $timenow - Enviando por email para: $toemail"
    #
    #---=== GERA O BACKUP E AGUARDA 10 SEGUNDOS ===---
    /system backup save name=$bkpname
    /delay 10
    #---=== ENVIO DE E-MAIL COM O BACKUP ===---
    /tool e-mail send start-tls=$servermailtls file=$bkpname subject=$subemail user=$fromemail password=$passemail to=$toemail port=$servermailport server=$servermailip body="BACKUP MikroTik de $idlocal gerado em $datenow as $timenow"


    Para utilizar este script em MikroTik Router OS v5.xx altere a linha de envio do e-mail de 'start-tls' para 'tls='


    O e-mail de destino irá receber uma mensagem que irá ter o seguinte formato:


    Assunto: BACKUP de RB2011-IDENTIFY/0BX1-6AJ7 gerado em 22/feb/2014 as 15:36:22
    Corpo: BACKUP MikroTik de RB2011-IDENTIFY/0BX1-6AJ7 gerado em 22/feb/2014 as 15:36:22
    Anexo: RB2011-IDENTIFY_0BX1-6AJ7_22feb2014_153622.backup


    Abraço a todos

  2. Amigo por favor poderia me explicar esse termo: "destinodobackup@provedor.com"

    Se eu usar o email do yahoo, como ficaria??






Tópicos Similares

  1. Script para envio de backup e log por email
    Por italope no fórum Redes
    Respostas: 5
    Último Post: 24-01-2014, 10:17
  2. Envio de backup por e-mail
    Por Ollenini no fórum Redes
    Respostas: 20
    Último Post: 06-06-2012, 21:25
  3. Respostas: 7
    Último Post: 24-12-2008, 08:39
  4. Respostas: 5
    Último Post: 08-10-2007, 17:50
  5. Arquivo de Backup Mikrotik,
    Por faieppi no fórum Redes
    Respostas: 0
    Último Post: 18-07-2007, 14:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L