+ Responder ao Tópico



  1. #1

    Padrão Direcionar rede para link especifico

    Boa Tarde Pessoal


    Minha divida é simples e de iniciante, seguinte tenho dois links validos, Link A e Link B, e quero por exemplo direcionar o trafego de uma determinada rede para o link A e outra para Link B.

    Exemplo

    tudo que for da rede 192.168.0.0/24 vai para link A
    tudo que for da rede 192.168.1.0/24 vai para link B

    como o jeito correto de fazer isso é usar roteamento estático ?? marcação de pacotes ??

  2. #2
    Avatar de shuttner
    Ingresso
    Aug 2008
    Localização
    Boa Vista - Roraima
    Posts
    257
    Posts de Blog
    1

    Padrão Re: Direcionar rede para link especifico

    Código :
    /ip firewall address-list
    add address=192.168.0.0/24 comment="" disabled=no list=LINKA
    add address=192.168.1.0/24 comment="" disabled=no list=LINKB

    Código :
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=LINKA disabled=no \
        new-routing-mark=lnka passthrough=no src-address-list=LINKA
    add action=mark-routing chain=prerouting comment=LINKB disabled=no \
        new-routing-mark=linkb passthrough=no src-address-list=LINKB


    Código :
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        "seu gateway" routing-mark=linka scope=30 target-scope=10
     
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        "seu gateway" routing-mark=linkb scope=30 target-scope=10



  3. #3

    Padrão Re: Direcionar rede para link especifico

    Citação Postado originalmente por shuttner Ver Post
    Código :
    /ip firewall address-list
    add address=192.168.0.0/24 comment="" disabled=no list=LINKA
    add address=192.168.1.0/24 comment="" disabled=no list=LINKB

    Código :
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=LINKA disabled=no \
        new-routing-mark=lnka passthrough=no src-address-list=LINKA
    add action=mark-routing chain=prerouting comment=LINKB disabled=no \
        new-routing-mark=linkb passthrough=no src-address-list=LINKB


    Código :
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        "seu gateway" routing-mark=linka scope=30 target-scope=10
     
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        "seu gateway" routing-mark=linkb scope=30 target-scope=10


    Esta certíssimo mas esqueceu de tratar o caso de queda de um dos links.

    acrescenta em router a regra:

    add comment="" disabled=no distance=10 dst-address=0.0.0.0/0 gateway=\
    "gateway A" scope=30 target-scope=10
    add comment="" disabled=no distance=10 dst-address=0.0.0.0/0 gateway=\
    "gateway B" scope=30 target-scope=10

    e nas outras duas regra acescenta a opção check-gateway=ping

    ficando assim:

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    "gatewayA" routing-mark=linka scope=30 target-scope=10 check-gateway=ping

    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    "gatewayB" routing-mark=linkb scope=30 target-scope=10 check-gateway=ping

    add comment="" disabled=no distance=10 dst-address=0.0.0.0/0 gateway=\
    "gatewayA" scope=30 target-scope=10

    add comment="" disabled=no distance=10 dst-address=0.0.0.0/0 gateway=\
    "gatewayB" scope=30 target-scope=10


    preverencia e sempre a menor distancia mais se um dos link cair sai tudo pelo que tiver ativo, voce ainda pode melhor criando um script que te envia um email se caso um dos link cair.

  4. #4

    Padrão

    Boa Noite Pessoal, no meu caso estou com uma dúvida...
    tenho uma RB 750GL funcionando como load balance juntando 3 internet de 10 megas cada, depois ligado nela tenho um pc com mikrotik que os clientes conectam nele via POE passando pelas nano M5 tudo em bridge e utilizo o MK-Auth para gerenciamento dos clientes....
    Não quero mais trabalhar com a RB juntando todos os link´s, mas sim especificando cada link para cada plano.
    Como devo fazer com as configurações nessa caso?

    minhas rb´s se comunicam pelos ip´s 172.16.x.x/24 e meus clientes autenticam no PPOE com os IP´s 192.168.100.x



  5. #5

    Padrão

    Boa noite Pessoal, estou precisando definir 1 cliente para sair por 1 link especifico e tambem atribuir ip publico para o mesmo, o meu cenario é o seguinte:
    tenho uma rb 493AH balanceando tres links de operadoras diferentes para evitar paralisação, e uma RB 433(estarei trocando por uma RB 1100AHx2) como concentrador, e para este cliente tenho um ponto a ponto, alguém poderia me ajudar nas regras?

  6. #6

    Padrão

    Citação Postado originalmente por shuttner Ver Post
    Código :
    /ip firewall address-list
    add address=192.168.0.0/24 comment="" disabled=no list=LINKA
    add address=192.168.1.0/24 comment="" disabled=no list=LINKB

    Código :
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=LINKA disabled=no \
        new-routing-mark=lnka passthrough=no src-address-list=LINKA
    add action=mark-routing chain=prerouting comment=LINKB disabled=no \
        new-routing-mark=linkb passthrough=no src-address-list=LINKB


    Código :
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        "seu gateway" routing-mark=linka scope=30 target-scope=10
     
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        "seu gateway" routing-mark=linkb scope=30 target-scope=10

    No meu caso tenho duas routerboards, uma que esta recebendo os link´s de internet e outra onde os clientes autenticam

    Em qual delas seria correto implementar essas regras?



  7. #7

    Padrão Re: Direcionar rede para link especifico

    Bom dia Pessoal, consegui resolver o problema de direcionamento dos clientes, porem depois disso não estou conseguindo acessar meus mikrotik´s que estão em bridge, os equipamentos dos clientes e nem o mk-auth.
    vou tentar exemplificar como está meu cenário.
    tenho uma RB750GL fazendo o balance pegando 3 link´s cada link está assim:
    Link 0 10.1.1.1/30
    Link 1 10.2.2.1/30
    Link 2 10.3.3.1/30
    e a interface que comunica com meus clientes, está com 172.16.0.1/24 que tem o POE.
    o meu MK-Auth é: 172.16.0.3
    e os demais equipamentos da rede estão com 172.16.0.x/24 e os clientes estão com 192.168.100.1-192.168.254.254
    O que esta acontecendo é o seguinte:
    depois que implementei as regras de rotas, eu perdi completamente o acesso aos meus equipamentos internos de rede só conseguindo acessar o mikrotik que esta com o ip 172.16.0.1 que é o servidor de POE, dele eu pingo normalmente para qualquer equipamento dentro da rede porem quando tento acessar um dele que seja por winbox ou via (http no caso dos equipamentos dos clientes e o mk-auth) não vai de forma alguma.
    as regras que implementei para a divisão dos clientes por link são:
    ip>firewall>mangle
    Conexão por Rota

    chain=prerouting action=mark-connection new-connection-mark=ether2_conn
    passthrough=yes src-address=192.168.100.0/24


    4294967295>
    chain=prerouting action=mark-connection new-connection-mark=ether3_conn
    passthrough=yes src-address=192.168.102.0/24


    4294967295>
    chain=prerouting action=mark-connection new-connection-mark=ether4_conn
    passthrough=yes src-address=192.168.104.0/24


    4294967295>
    chain=prerouting action=mark-connection new-connection-mark=ether4_conn
    passthrough=yes src-address=192.168.110.0/24


    4294967295>
    Marcação de Conexões

    chain=prerouting action=mark-routing new-routing-mark=to_ether2
    passthrough=no src-address=192.168.100.0/24


    4294967295>
    chain=prerouting action=mark-routing new-routing-mark=to_ether3
    passthrough=no src-address=192.168.102.0/24


    4294967295>
    chain=prerouting action=mark-routing new-routing-mark=to_ether4
    passthrough=no src-address=192.168.104.0/24


    4294967295>
    chain=prerouting action=mark-routing new-routing-mark=to_ether4
    passthrough=no src-address=192.168.110.0/24


    4294967295>
    em firewall tem mascaramento para os três link´s

    Antes utilizava esse mesmo equipamento como PCC fazendo o Balanceamento dos link´s e entregando para outro mikrotik que era o Servidor POE, utilizando o mesmo IP porem era assim: 172.16.0.1/30 que passava a internet para o IP 172.16.0.2/30 que era o mikrotik com o POE que desativei.

    Alguém já passou por isso antes ou pode me ajudar com esse problema de acesso aos meus equipamentos internos????