Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Debian + FreeRadius [Resolvido]

    Bom dia povo, estou tentando instalar o FreeRadius no Debian 7
    quando utilizo o comando
    freeradius -X

    nao passa mais dessa tela
    Clique na imagem para uma versão maior

Nome:	         Sem título.jpg
Visualizações:	136
Tamanho: 	71,8 KB
ID:      	51522

    alguem pode me ajudar, se tiver algum material sobre instalação do mesmo e poder me mandar agradeço
    obrigado
    Última edição por brunobelas; 01-05-2014 às 21:20.

  2. #2

    Padrão

    Aparentemente, o serviço esta subindo, mas vc esta tentando configura ele sem banco de dados ??



  3. #3

  4. #4

    Padrão

    Citação Postado originalmente por Arthur Bernardes Ver Post
    ja tentei tbm, e deu o mesm problmea



  5. #5
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    Citação Postado originalmente por brunobelas Ver Post
    Bom dia povo, estou tentando instalar o FreeRadius no Debian 7
    quando utilizo o comando
    freeradius -X

    nao passa mais dessa tela
    Clique na imagem para uma versão maior

Nome:	         Sem título.jpg
Visualizações:	136
Tamanho: 	71,8 KB
ID:      	51522

    alguem pode me ajudar, se tiver algum material sobre instalação do mesmo e poder me mandar agradeço
    obrigado
    Amigo eu nao entendi sua duvida.

    A reclamação é pq ele esta parado ai ? Se sim o motivo é que você iniciou em debug mode logo irá ficar parado ai.

  6. #6
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    Ou seja

    freeradius -X

    é a mesma coisa que iniciar ele em debug mode.

    Você tentou autenticar ? viu se funcionou?



  7. #7

    Padrão

    Clique na imagem para uma versão maior

Nome:	         Sem título2.jpg
Visualizações:	53
Tamanho: 	33,2 KB
ID:      	51540

    alguem pode me ajudar com isso, instalei fiz o banco de dados, criei usuario.

    Quando faço o teste como "radtest" fica repetindo essa mensagem o tempo todo, o certo seria apareçer no final

    NAS-Port = 1812
    rad_recv: Access-Accept packet from host 127.0.0.1 port 1812, id=147, length=20
    Última edição por brunobelas; 01-05-2014 às 15:33.

  8. #8
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    eu nao vi nada de errado na mensagem pra mim isso quer dizer que funcionou



  9. #9

    Padrão

    Estou seguindo esse tutorial aqui

    http://getlan.blogspot.com.br/2012/0...ao-de-uma.html

    Mesmo assim continua dando RADIUS server not resp.

    vou descrever oque estou tentando fazer
    estou usando vmware virtualizado com DEBIAN 7 instalado FreeRadius + Mysql + PHPMyAdimin
    IP: 192.168.40.2/30

    Tudo funciona mas fica dizendo q nao responde

  10. #10
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    Rodando o freeradius com -X e você tenta autentica você ve a requisição chegando ?

    Se não voce pode ter um problema de roteamento ou firewall bloqueando a tentativa...



  11. #11

    Padrão

    Coloquei freeradius -X
    Clique na imagem para uma versão maior

Nome:	         Sem título 3.jpg
Visualizações:	54
Tamanho: 	105,4 KB
ID:      	51542

  12. #12
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    Sim o Radius já esta rodando...

    Você tem que parar o serviço do radius e depois rodar o freeradius -X



  13. #13

    Padrão

    killall -9 freeradius
    dps freeradius -X
    Clique na imagem para uma versão maior

Nome:	         Sem título 4.jpg
Visualizações:	63
Tamanho: 	61,2 KB
ID:      	51543

  14. #14
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    OK agora tenta autenticar e veja oq aparece no log...



  15. #15

    Padrão

    No log do mk ta assim
    Clique na imagem para uma versão maior

Nome:	         Sem título 5.png
Visualizações:	55
Tamanho: 	15,3 KB
ID:      	51544

    tem algum log no freeradius q eu possa ver?

  16. #16
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    Ué voce iniciou em debug mode se não ta aparecendo nada quer dizer que não ta recebendo a requisição. Logo ou você tem um firewall ou um problema de rede.

    Você já tentou pingar o seu servidor de radius pelo mikrotik pra ver se um consegue falar com o outro ?



  17. #17

    Padrão

    Pingando normalmente

    Clique na imagem para uma versão maior

Nome:	         Sem título 6.jpg
Visualizações:	55
Tamanho: 	19,8 KB
ID:      	51545

  18. #18
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    tem algo errado cara..

    Pensa só quando voce fez testes com o radtest voce viu o login no debug do freeradius e quando voce tenta logar do mikrotik não ve então penso que a conexao pode estar sendo bloqueada... Voce tem certeza que não tem nenhum firewall nesta maquina ?



  19. #19
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    tira um screenshot da configuracao de radius no seu mikrotik

  20. #20

    Padrão

    Fiz o radtest novamente

    Clique na imagem para uma versão maior

Nome:	         Sem título 6.jpg
Visualizações:	54
Tamanho: 	88,0 KB
ID:      	51546

    as config do radius

    Clique na imagem para uma versão maior

Nome:	         Sem título 6.jpg
Visualizações:	62
Tamanho: 	38,8 KB
ID:      	51547