+ Responder ao Tópico



  1. Olá.

    Atualmente tenho uma topologia roteada da seguinte forma: Rede ----- Router 1 ------ Router 2 ------ Gateway ------ Internet
    Tanto o Router 2 quanto o Gateway possuem outras redes ligadas a eles então quero mantê-los funcionando como roteadores. Agora, o Router 1 apenas controla algumas coisas na Rede e a liga ao Router 2, então não há a necessidade dele funcionar como roteador, e inclusive acho que posso resolver alguns problemas aqui mais facilmente mudando isso. Então decidi colocar esse Router 1 para funcionar como bridge, só que não tenho experiência ou prática com esse tipo de configuração.

    No Router 1 criei uma bridge e coloquei as interfaces da Rede e do Router 2 como portas dela. Configurei um IP na mesma faixa que a usada na Rede na interface bridge do Router 1 e também na interface ethernet do Router 2 e alterei o servidor DHCP do Router 1 para funcionar na bridge. Ah sim, também removi as regras de NAT que tinham no Router 1; em bridge não precisa disso, certo?

    No entanto, isso aí não está funcionando. Os nós na Rede estão conseguindo IP com o DHCP no Router 1 normalmente mas eles não conseguem pingar o bridge nem o Router 2, nem o Router 1 consegue pingar o 2 ou vice versa.

    O que há de errado nessa configuração? Não tenho nenhuma regra no filter ou nat da bridge ou do IP/Firewall.

    Detalhes adicionais:
    - Router 1 roda Mikrotik RouterOS 6.12 e Router 2 roda Mikrotik RouterOS 5.20.
    - Toda a rede é cabeada.
    - No /interface bridge host mostra tantos os dois MACs locais das interfaces nw e ptp-router quanto o MAC do Router 2 e das máquinas na Rede.

    Configurações que tentei:
    No Router 2 defini na interface do ptp o IP 192.168.46.1, já no Router 1, fiz isso (apenas as partes relevantes, o MAC foi suprimido):
    Código :
    /interface ethernet set ether1 name=nw
    /interface ethernet set ether2 name=ptp-router
     
    /interface bridge add admin-mac=11:11:11:11:11:11 auto-mac=no name=bridge-nw-router
    /interface bridge port add bridge=bridge-nw-router edge=yes external-fdb=no interface=ptp-router point-to-point=yes
    /interface bridge port add bridge=bridge-nw-router edge=yes external-fdb=no interface=nw
     
    /ip address add address=192.168.46.2/24 inteface=bridge-nw-router network=192.168.46.0
     
    /ip dhcp-server network set 0 gateway=192.168.46.1 dns-server=192.168.46.1
    E aí, alguma ideia? Tem algo mais que eu precise fazer para ter isso funcionando?

    Obrigado pela atenção.
    Até mais.
    Última edição por TsouzaR; 01-05-2014 às 21:45.

  2. Citação Postado originalmente por Arthur Bernardes Ver Post
    Como está a rota "default" no Router2? Ela está apontando para o gateway ou para o Router1 (hoje bridge)?
    Ela aponta para o gateway.
    Mas a rota default não tem relação com o problema, visto que não é só a questão de ninguém ter acesso à Internet, mas também que as máquinas dentro da rede não se comunicam umas com as outras e nem com os Routers 1 e 2.

    Um detalhe que quero adicionar e que possa ser útil é que no /interface bridge host mostra tantos os dois MACs locais das interfaces nw e ptp-router quanto o MAC do Router 2 e das máquinas na Rede.
    Última edição por TsouzaR; 01-05-2014 às 21:20.






Tópicos Similares

  1. Redundancia em rede bridge
    Por sneeep no fórum Redes
    Respostas: 6
    Último Post: 25-02-2014, 07:40
  2. Trafego em rede Lan
    Por pietro_scherer no fórum Redes
    Respostas: 3
    Último Post: 03-09-2013, 12:06
  3. Auxilio em REDE BRIDGE
    Por adrianodiasng no fórum Redes
    Respostas: 1
    Último Post: 04-04-2013, 16:31
  4. Bloqueio fatal para trafego em rede
    Por gotch no fórum Redes
    Respostas: 3
    Último Post: 02-12-2008, 15:48
  5. pppoe em routerboard em rede bridge wireless
    Por samuelfar no fórum Redes
    Respostas: 4
    Último Post: 22-12-2007, 16:51

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L