+ Responder ao Tópico



  1. Boa tarde galera do under, estou com um problema aqui para resolver, passei a semana toda e nao consegui...

    Tenho um servidor OpenVPN (debian7) atras de um firewall, configurei para poder acessar algum sistemas da empresa de casa, quando conecto de casa consigo pingar no servidor OpenVPN até na placa eth0 dela, mas nao consigo pingar no resto dos micros dentro da rede da empresa...

    segue como foi feita minha conf. no servidor e cliente


    #######SERVIDOR MATRIZ#########
    # Dispositivo usado pela VPN
    dev tun
    # Porta usada para conexão
    port 443
    # Protocolo de conexão
    proto udp
    # Certificado da CA
    ca keys/ca.crt
    # Certificado do Servidor de VPN (Matriz)
    cert keys/matriz.crt
    # Chave usada pela matriz
    key keys/matriz.key
    # Chave Diffie-Hellman
    dh keys/dh1024.pem
    # Rede usada pela VPN (Matriz 192.168.254.1 e os clientes a partir de 192.168.254.2)
    server 192.168.255.0 255.255.255.0
    # Rota usada pelos clientes para acessar a rede da matriz
    push "route 192.168.0.0 255.255.255.0"
    push "dhcp-option DNS 192.168.1.2"


    push "default-gateway 192.168.1.1"


    # Envia um ping a cada 10 segundos e cancela a conexão se não houver resposta em 120 segundos
    keepalive 10 120
    # Máximo de clientes conectados simultaneamente
    max-clients 15
    # Compressão usando lzma
    comp-lzo
    float
    tls-server
    # Usuário e grupo que o openvpn usará para ser executado
    user nobody
    group nogroup
    # Manter a chave e os túneis persistentes
    persist-key
    persist-tun
    # Nível de Log.
    verb 3
    #####################


    #########CLIENTE############

    client
    dev tun
    proto udp
    port 443
    remote 191.253.xxx.xxx
    ifconfig 192.168.255.2 192.168.255.1
    ca ca.crt
    cert jefferson.crt
    key jefferson.key
    tls-client
    keepalive 10 120
    comp-lzo
    user nobody
    group nogroup
    persist-key
    persist-tun
    verb 3
    ##################
    ####### conf servidor firewall ######
    eth0 191.253.xxx.xxx (entra link)
    eth2 192.168.0.1 (rede local)
    ############################
    #######conf servidor vpn##########
    eth0 192.168.0.6
    ############################

    vale lembrar que a porta 443 esta perfeitamente liberada no meu firewall tanto que estou conectando no servidor vpn

  2. Olá, você consegue pingar a eth0 de quem? do seu firewall? essa eth0 é a parte local ou referente a parte wan? o seu servidor openvpn recebe pacotes? já monitorou pacotes vindo na porta do openvpn com tcpdump?
    Vai por partes:
    1- Verifica se seu firewall recebe um telnet na porta do openvpn se abrir telnet ok
    2- abrindo o telnet no firewall, verifica se o serv openvpn esta recebendo telnet, se SIM, blza passar para o problema de conectividade entre sua rede local e seu pc de casa, se NÃO sabemos que tem um bloqueio ai, tenta matar esse problema para ir para o outro






Tópicos Similares

  1. Respostas: 2
    Último Post: 25-06-2012, 08:20
  2. Openvpn - cliente acessar rede interna do servidor
    Por edurbs no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-09-2007, 08:24
  3. MOVIDO: acesso a rede interna do servidor onde tá a openvpn
    Por Duca no fórum Servidores de Rede
    Respostas: 0
    Último Post: 30-05-2006, 19:56
  4. acesso a rede interna do servidor onde tá a openvpn
    Por caosdp no fórum Servidores de Rede
    Respostas: 8
    Último Post: 30-05-2006, 10:12
  5. o ubuntu nao acessa as partições do windows
    Por ara no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-12-2005, 09:15

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L