Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Ola a todos!
    Eu ja agradaço quem possa ajudar pois estou quebrando a cabeça c\ um script de atualizar o ddns no no-ip.
    Usu uma rb 450 fazendo um balance e gostaria de acessar ela usando o no-ip mas o script q achei não atualiza e so da uma msg mas nada
    msg: NO-IP. corrent ip 200.200.201.200 is not equal to previous IP. updat needed
    no-ip seening
    e mas nada
    script

    /system script
    add name=dns_noip policy=ftp,read,write,test,winbox source="# No-IP automatic Dynam\
    ic DNS update\r\
    \n\r\
    \n#--------------- Change Values in this section to match your setup -------\
    -----------\r\
    \n\r\
    \n# No-IP User account info\r\
    \n:local noipuser \"usuario\"\r\
    \n:local noippass \"senha\"\r\
    \n\r\
    \n# Set the hostname or label of network to be updated.\r\
    \n# Hostnames with spaces are unsupported. Replace the value in the quotatio\
    ns below with your host names.\r\
    \n# To specify multiple hosts, separate them with commas.\r\
    \n:local noiphost \"host no-ip\"\r\
    \n\r\
    \n# Change to the name of interface that gets the dynamic IP address\r\
    \n:local inetinterface \"adsl_ether2\"\r\
    \n\r\
    \n# Addon by silviola ( for MK's v. 5.X without DNS configured )\r\
    \n:local noipadr [:resolve dynupdate.no-ip.com server=8.8.4.4]\r\
    \n\r\
    \n#-------------------------------------------------------------------------\
    -----------\r\
    \n# No more changes need\r\
    \n\r\
    \n:global previousIP\r\
    \n\r\
    \n:if ([/interface get \$inetinterface value-name=running]) do={\r\
    \n# Get the current IP on the interface\r\
    \n :local currentIP [/ip address get [find interface=\"\$inetinterface\" d\
    isabled=no] address]\r\
    \n\r\
    \n# Strip the net mask off the IP address\r\
    \n :for i from=( [:len \$currentIP] - 1) to=0 do={\r\
    \n :if ( [ick \$currentIP \$i] = \"/\") do={ \r\
    \n :set currentIP [ick \$currentIP 0 \$i]\r\
    \n } \r\
    \n }\r\
    \n\r\
    \n :if (\$currentIP != \$previousIP) do={\r\
    \n :log info \"No-IP: IP Atual \$currentIP diferente do anterior, atua\
    lizando\"\r\
    \n :set previousIP \$currentIP\r\
    \n\r\
    \n# The update URL. Note the \"\\3F\" is hex for question mark (\?). Require\
    d since \? is a special character in commands.\r\
    \n :local url \"http://\$noipadr/nic/update\\3Fmyip=\$currentIP\"\r\
    \n :local noiphostarray\r\
    \n :set noiphostarray [:toarray \$noiphost]\r\
    \n :foreach host in=\$noiphostarray do={\r\
    \n :log info \"No-IP: Requisitando atualizacao para \$host\"\r\
    \n /tool fetch url=(\$url . \"&hostname=\$host\") user=\$noipuser \
    password=\$noippass mode=http dst-path=(\"no-ip_ddns_update-\" . \$host . \"\
    .txt\")\r\
    \n :log info \"No-IP: IP do Host \$host atualizado para \$currentI\
    P\"\r\
    \n }\r\
    \n } else={\r\
    \n :log info \"No-IP: IP anterior \$previousIP sem alteracao, atualiza\
    cao dispensada\"\r\
    \n }\r\
    \n} else={\r\
    \n :log info \"No-IP: \$inetinterface nao esta atualmente respondendo, log\
    o, a atualizacao nao sera possivel.\"\r\
    \n}"

  2. Atualiza para a versão 6.15, e tenha um ddns da propria mikrotik...



  3. Citação Postado originalmente por rogeriodj Ver Post
    Atualiza para a versão 6.15, e tenha um ddns da propria mikrotik...
    Obrigado pela solução apresentada mais não é a q procuro.
    Uso a versão do mk 4.17

  4. Vai no wiki da mikrotik, la tem varias regras de ddns, essa ai é pra versão 5.xx. E na versão 6.xx é totalmente diferente!!



  5. Nos winks do mk tem apenas para 5xx versão
    quria uma na 4.17






Tópicos Similares

  1. Preciso de uma ajuda, com aviso de bloqueio via web no meu mk
    Por thiagokjf no fórum Servidores de Rede
    Respostas: 6
    Último Post: 28-01-2011, 14:51
  2. Preciso de uma ajuda
    Por Juliocd no fórum Redes
    Respostas: 0
    Último Post: 16-09-2009, 14:58
  3. ltsp+boot (preciso de uma ajuda)
    Por ecbr2003 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-05-2009, 10:48
  4. Respostas: 3
    Último Post: 13-05-2009, 07:50
  5. Pessoal preciso de uma ajuda!
    Por rogeriodj no fórum Redes
    Respostas: 3
    Último Post: 01-04-2009, 09:18

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L